Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probelm mit ISA Server 2000 und HTTP-Connect

Frage Internet

Mitglied: xDannyOx

xDannyOx (Level 1) - Jetzt verbinden

08.08.2005 um 08:32 Uhr, 3443 Aufrufe

Hi,

ich habe ein Programm geschrieben, dass sich zu einer HTTP-Seite verbindet und wahlweise mit einem HEAD- oder GET-Request prüft, ob die Seite erreichbar ist. Dies funktioniert auch wunderbar. Auch wenn ich über einen Proxy gehe funktioniert es bei fast allen, ausser bei einem ISA Server 2000 mit Proxy Authentifizierung.

Meine Vorgehensweise sieht wie folgt aus:

Zuerst verbinde ich mich mit dem ISA-Server und sende dann einen HTTP CONNECT Request an diesen. Wenn keine Authentifizierung von nöten ist, funktioniert es auch und ich werde zu gewünschten HTTP-Seite verbunden und kann meinen GET-Request senden. Wenn aber eine Proxy Authentifizierung von nöten ist, und ich diese an meinen CONNECT Request anhänge ("CONNECT www.xyz.de:80\nProxy-authorization: BASIC abcdesf\n\n") dann erhalte ich als Response den Fehler 502.

Kann mir jmd helfen, was ich falsch mache und mir einen Tipp geben. Wäre für jeden Hinweis sehr dankbar!!!!

Danke im Vorraus!!!

Gruß
Ähnliche Inhalte
Windows Server
gelöst Server-connect ergibt Fehler 500.19 (11)

Frage von beamenwaerschoen zum Thema Windows Server ...

Windows Server
Windows und Exchange Server 2016 Betrieb vorerst ohne CALs (2)

Frage von deelite zum Thema Windows Server ...

Microsoft Office
Umzug Mail Server (2)

Frage von PascalSt zum Thema Microsoft Office ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Exchange Server
Microsoft Exchange Weiterleitung mit anderer primären E-Mail Adresse (14)

Frage von Rene12345 zum Thema Exchange Server ...

Windows Userverwaltung
gelöst Wie verfahrt Ihr mit den Windows-Benutzerkonten und -dateien von ausgeschiedenen Mitarbeitern? (14)

Frage von Bl0ckS1z3 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
Devolo DLAN 500 pro Wireless+ (13)

Frage von IceAge zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...