Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit dem Auto Signon auf einer ASA 5505

Frage Netzwerke

Mitglied: sandheber

sandheber (Level 1) - Jetzt verbinden

17.08.2009, aktualisiert 12:52 Uhr, 3525 Aufrufe, 7 Kommentare

Hallo,

erstmal stelle ich die Umgebung vor:

Eine asa 5505 mit 8.0.4 version und dem Cisco ASDM 6.1 admin tool.

So nun zu meinen Vorliegen:

Ich möchte gerne mit WEBVPN direkt nach eingabe des Benutzers / Passwort zugriff auf Verzeichnisse bzw einen FTP bekommen.
Es klappt soweit, dass ich die möglichkeit habe oben in der Adresszeile die IPs/Namen einzugeben um von dort auf eine "Authentication request" Seite zu gelangen wo ich die angeforderten Daten eingeben kann.

Dies soll direkt übersprungen werden.

Ich versuche es mit der einstellung "Auto signon" in der ASA habe ich einen user erstellt, welcher die Möglichkeit hat auf den FTP server zuzugreifen.

Nun habe ich unter
"Local user" - > VPN Policy - > Clientless SSL VPN -> Single Signon -> Auto Signon Server
einen Eintrag verfasst mit der IP von dem Rechner/Server auf dem der FTP läuft. So sieht es aus 180.1.101.180 mask 255.255.255.255 Auth Basic / ntml / ftp / cifs


Nun bekomme ich immer sobald ich versuche zugriff auf die Verzeiche zu bekommen die Meldung Authentication error.
Aber bei dem FTP kommt nichtmal eine Meldung an, das jemand versucht hat auf den Rechner raufzukommen.


Hätte einer eine Idee?




Vielen Dank schonmal!
Mitglied: aqui
17.08.2009 um 12:42 Uhr
.
"...Es sollen also die ich habe folgendes Problem...."

Tja, dafür benötigt man aber einen Decoder um diese kryptische Frage zu verstehen...
Fazit: Mit dem Rumpelsatz kann man dir keine qualifizierte Hilfe geben
Bitte warten ..
Mitglied: sandheber
17.08.2009 um 12:56 Uhr
Öhm entschuldige ich hatte das vorerst als "entwurf gespeichert" und wollte das noch bearbeiten.
Aber wohl den falschen Button gedrückt.
Bitte warten ..
Mitglied: aqui
17.08.2009 um 13:00 Uhr
Was sagt denn ein "debug authentication" ?? an der Konsole ?
Damit sollte im Handumdrehen klar sein wo der Fehler liegt ??
Bitte warten ..
Mitglied: sandheber
17.08.2009 um 13:14 Uhr
hmm okay, ich habe wohl das "Vorwort" vergessen.

Ich bin atm als Praktikant eingesetzt und soll die Möglichkeiten der ASA unter die Luppe nehmen.
Das Problem ist, dass die ASA im betrieb ist und mehr als 200 Rechner vernetzt. Somit habe ich schon etwas Respekt/Angst etwas falsch zu machen.


Ich kenne mich mit dem Gerät noch nicht so gut aus, arbeite damit erst seit ca 2 Wochen.

Könntest du aqui mir vielleicht sagen, wie ich den debug authentication starte.

Weil im CLI würde ich ungerne etwas probieren.
Bitte warten ..
Mitglied: sandheber
18.08.2009 um 13:03 Uhr
Hey aqui danke soweit, aber wie komme ich mit dem ASDM in die Konsole???
Es gibt einmal die unter Tools -> Command Line Interface
dann unter Device Management -> CLI -> usw...
Und meine andere Frage ist wie wirken sich befehle aus, ändern sich diese sofort. Oder muss man in einen anderen Modus wechseln?
Bitte warten ..
Mitglied: aqui
19.08.2009 um 13:33 Uhr
Ohne das CLI wirst du nichts werden denn der ADM bzw. Weboberfläche ist was für Dummies...

Du nimmst also einen telnet und SSH Client wie Putty oder TeraTerm
Machst einen Telnet oder SSH auf die Box, je nachdem was erlaubt ist, und fertig bist du !

Vergiss nicht ein term moni einzugeben am Terminal, sonnst wandern die Debug Outputs auf die serielle Konsole an die du dich natürlich auch anklemmen kannst, allerdings musst du dann auch physisch in der Nähe der Maschine sein so das Putty und TTerm die bequemeren Alternativen sind.

Mit debug ? kannst du dir die Debug Kommandos ansehen. Das "?" ist immer dein Freund wenn man auf dem CLI nicht weiterweiss.

Wenn du den Authentication Prozess debuggst solltest du sofort sehen wo das problem liegt...
Bitte warten ..
Mitglied: sandheber
21.08.2009 um 08:23 Uhr
Hey Aqui danke abermals, aber irgentwie finde ich den Fehler immer noch nicht.


Ich habe mir auch gerade nochmals meine Fragestellung oben angeschaut und festgestellt das dort leider etwas fehlt.


Vielleicht hilft das weiter.

Also ich komme via WEB VPN auf den FTP/CIFS Server muss aber den User / PW eingeben. Diesen Schritt möchte ich gerne wegfallen lassen.

d.h. wenn sich eingeloggt wird soll er direkt die möglichkeit haben auf die Resourcen zugriff zu bekommen ohne weitere Eingaben.


Ich probiere das mit dem auti Sign-on service. Dort habe ich wie oben geschreiben die IP 180.1.102.160 und den subnet 255.255.255.255 benutzt. Doch ich bekomme immer nur die meldung "authentication error" ABer in meinen FTP programm steht in der Log nichts. also kommt er bis dahin garnicht, hast du vielleicht eine Idee?


Wenn ich in dem SSH in den config modus bin und
"debug webvpn 255" eingeben bekomme ich die Meldung: webvpn_session.c:http_webvpn_find_session[159]

Und das, sobald ich rumsurfe via webvpn.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
gelöst ASA 5505 in einer bestehenden VLAN Layer 3 Umgebung (3)

Frage von Nightloop zum Thema Router & Routing ...

Windows Netzwerk
Problem mit PSexec64 von Sysinternals (2)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...