Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Installation

Problem bei automatisierter Installation

Mitglied: 1x1speed

1x1speed (Level 1) - Jetzt verbinden

10.09.2012, aktualisiert 11.09.2012, 2437 Aufrufe, 2 Kommentare

Hallo,

habe folgendes Problem mit einer Software die automatisiert per OPSI installiert werden soll.  Die Installation per MSI mit Angabe einer zusätzlich erstellten MST File schlug fehl. Die Fehlermeldung lautete: MSI kann ohne setup.exe nicht aufgerufen werden.

Aus diesem Grund hab ich nach Installationsdoku des Herstellers per "setup.exe -r" eine setup.iss Antwortdatei erstellt und in das Installationsverzeichnis kopiert. Die Installation per Aufruf über eine cmd mit dem Kommando "setup.exe -s" funktionierte auch wie gewünscht. Nun habe ich dieses Kommando in das OPSI Wininst Script mit dem Aufruf: "%scriptpath%\setup.exe -s" eingefügt. 
Das Problem ist nun, dass das Wininst Script das Kommando aufgeruft und die Installation scheinbar durchläuft, aber die Software auf dem Client letztendlich nicht installiert wurde.

Hab den Aufruf auch über eine extra install.cmd versucht, mit dem selben Eergebnis.

Hat jemand eine Idee, woran das liegen könnte, bzw. wie ich eine MSI mit Orca dahingehend anpasse, dass die Installation silent ohne die Fehlermeldung durchläuft.

Danke schon mal!
Mitglied: Fidel83
10.09.2012 um 19:30 Uhr
Hallo

Eventuell die Rechtschreibung noch korrigieren, damit man das auch bequem lesen kann?! Hast du die setup.exe mal manuell ohne Antwortdatei ausgeführt? Dann sollte ja eine Fehlermeldung aufkommen, wenn die Installation nichts ausgibt an Installationsordner bzw. Startmenüeintrag bzw. andere Sachen, die angelegt werden.

LG
Bitte warten ..
Mitglied: 1x1speed
11.09.2012 um 08:11 Uhr
Danke erst mal für deine Antwort. Hab den Beitrag überarbeitet. Sah ja schrecklich aus ;), das kommt vom zu schnellen Erstellen mit dem iPhone.

Werd mir Dein Vorschlag gleich anschauen.

Beste Grüsse
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
CAD: CATIA Automatisierte Installation
gelöst Frage von SchlafwvndlerBatch & Shell3 Kommentare

Hallo Zusammen, Ich wollte mal wissen ob es unter euch Internet Nutzern auch Leute mit Erfahrung bei der CAD ...

RedHat, CentOS, Fedora
Problem nach Kolab Groupware installation
Frage von mwagenknechtRedHat, CentOS, Fedora

Hallo zusammen, bei der Kolab Installation unter Centos 7 wird auch ein LDAP Server mit installiert. In diesem Fall ...

Monitoring
Icingaweb2 Installations Problem
gelöst Frage von theoberlinMonitoring18 Kommentare

Hallo zusammen, ich setze gerade ein Monitoring System auf. OpenSuse auf einer HyperV Maschine. Icinga2 habe ich komplett installiert. ...

Linux
Snipe-IT Installation Problem
gelöst Frage von Fenris14Linux2 Kommentare

Guten Tag Community, ich bin mittlerweile mittel-schwer am verzweifeln, da ich es ums verrecken nicht hinbekomme Snipe-IT zu installieren. ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 1 TagLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit29 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

SAN, NAS, DAS
Hilfe beim Einrichten eines Storages (SAN)
gelöst Frage von Vader666SAN, NAS, DAS15 Kommentare

Hallo Admins! Ich bin in einer kleineren Firma und hatte bisher mit dem Thema SAN nur in meiner Ausbildung ...

Batch & Shell
Meltdown Microsoft Prüf Script - .zip Datei leider leer
gelöst Frage von MasterBlaster88Batch & Shell13 Kommentare

Hallo zusammen, ich patche gerade unsere Windows Server bzgl. der Meltdown Lücke. Patch vorhanden, Reg Keys gesetzt Um das ...