Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Blat.exe beim Festplattenüberwachen

Frage Microsoft Windows Server

Mitglied: chow

chow (Level 1) - Jetzt verbinden

08.10.2009, aktualisiert 13:07 Uhr, 5285 Aufrufe, 6 Kommentare

Batchdatei Startet zwar manuell, aber automatisiert wird sie nicht komplett ausgeführt??

Moinmoin,

ich habe da ein Problem mit einer Batchdatei;

und zwar will ich dden freien Speicherplatz einer Partition überwachen und bei unterschreiten einer gewissen Kapazität eine E-Mail an den Admin absetzen.

Der zu überwachende Rechner ist ein 2003 Standard in einer Domäne mit einem 2003 SBS.

Nach folgender Anleitung habe ich alles eingerichtet

http://www.serverhowto.de/Teil-3-Taegliche-Wartung-automatisiert-III.24 ...

meine Batchdatei sieht folgendermaßen aus:

Blat -install SRV-CACHE-5.xxx.local cache@xxx.local
Blat "C:\plattenvoll\test.txt" -to administrator@xxx.de -server 150.10.1.111 -debug -timestamp -log blatSMTPlog.txt -subject "Platten auf Cache voll"

jetzt kommts,

wenn ich die Batchdatei manuell auslöse kommt die Mail beim Admin an, wenn ich Ihn ihn in der Überwachung laufen lasse nicht.

Die Batchdatei wird auch ausgeführt, habe zum testen einen Copybefehl angehängt und dieser funktioniert einwandfrei, nur die Mail geht nicht raus.

danke für eure Hile im Vorraus
Mitglied: KowaKowalski
08.10.2009 um 14:16 Uhr
Hi chow,


wenn isch rischtisch guck sind in Deiner Syntax der Server und der Empfänger vertauscht

blat.exe body.txt -server mailserver -to ziel@firma.de -f sender@firma.de -s Betreff
oder auch
echo Testmail | blat.exe - -server mailserver -to ziel@firma.de -f sender@firma.de -s Betreff


aber beachte auch mal diesen Hinweis:
BLAT wird komplett per Kommandozeile gesteuert. Die Hilfe ist mit der Option "-h" erreichbar. Die einfachste Funktion zum Versand einer Mail mit "Blat <filename> -to <recipient>" funktioniert aber nur, wenn die erforderlichen Parameter wie Mailserver und Absenderadresse vorab schon in der Registrierung hinterlegt wurden. Da ich als Administrator davon besser nicht ausgehe, ist eine längere Kommandozeile erforderlich.

siehe: http://www.msexchangefaq.de/tools/blat.htm

Viel Erfolg
Bitte warten ..
Mitglied: 60730
08.10.2009 um 16:12 Uhr
Servus,

  • warum installierst du jedesmal Blat in der Bat?
  • warum steht euer SBS in Japan?
  • Was steht in der log blatSMTPlog.txt ?

Gruß
Bitte warten ..
Mitglied: chow
08.10.2009 um 19:51 Uhr
Hi Kowakowalski,

die Sache ist die,

wenn ich die Batchdatei per Doppelklick ausführe kriegt der Admin die Mail, nur wenn ich sie über diesen Überwachungsmodus ausführen lasse, wenn die HD volläuft tut er es nicht. Das die Batch ausgeführt wird kontrolliere mittels Kopierbefehl am Ende der Routine.
????
Bitte warten ..
Mitglied: DerWoWusste
08.10.2009 um 22:21 Uhr
Führ nochmal alles nach Anleitung aus, ohne davon abzuweichen.
Klappt's nicht, kannst Du nahezu sicher sein, dass es Randumstände auf Deinem PC sind und nicht blat (falls es in der selben Version vorliegt, die Profi Weinmann verschweigt (oder an anderer Stelle nennt? [Edit - ja, tut er: 2.50, es gibt schon eine Neuere).
Evtl. hast Du Sicherheitssoftware drauf, die nur bestimmte Nutzer smtp benutzen lässt? Und der Nutzer System ist nicht darunter... - könnte der Unterschied zur manuellen Ausführung (Dein Nutzer) sein.
Bitte warten ..
Mitglied: chow
09.10.2009 um 17:51 Uhr
Hi derwowusste,

in der Überwachungsfunktion kann man den ausführenden Benutzer ja festlegen und da hab ich den adminmit entsprechendem Passwort eingetragen, also den selben User unter dem die Batchdatei manuell funktioniert.

irgendwie komisch
Bitte warten ..
Mitglied: 60730
09.10.2009 um 23:26 Uhr
Zitat von 60730:
Servus,

Blat -install SRV-CACHE-5.xxx.local cache@xxx.local

warum installierst du jedesmal Blat in der Bat?

Blat "C:\plattenvoll\test.txt" -to administrator@xxx.de -server 150.10.1.111 /snip

warum steht euer SBS in Japan?

/snap -log blatSMTPlog.txt

Was steht in der log blatSMTPlog.txt ?

  • Was passiert, wenn die blatbat als geplanter Task mit den gleichen User Credentials läuft?

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
Aufgabenplaner - E-Mail Benachrichtigung mittels blat.exe (7)

Frage von staybb zum Thema Windows Server ...

Batch & Shell
Problem mit Funktion und Combobox (7)

Frage von Druide83 zum Thema Batch & Shell ...

Outlook & Mail
MAPI-Schnittstelle testen: MAPI-Problem Outlook 2013 (3)

Frage von BirdyB zum Thema Outlook & Mail ...

Windows Server
gelöst Problem mit KMS aktivierung (7)

Frage von Judgelg zum Thema Windows Server ...

Heiß diskutierte Inhalte
Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (13)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (13)

Frage von thomasreischer zum Thema Hardware ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...