Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit den Boost Librarys

Frage Linux

Mitglied: biwboy

biwboy (Level 1) - Jetzt verbinden

08.10.2008, aktualisiert 11.10.2008, 4465 Aufrufe, 3 Kommentare

Hallo, ich habe ein kleines Problem mit den Boost Libraries und hoffe Ihr könnt mir helfen.

Beim installieren von licq bekomme ich nach Eingabe von ./configure folgende Fehlermeldung:

checking for Boost >= 1.33.1... configure: error: We could not detect the boost libraries (version 1.33 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option. If you are sure you have boost installed, then check your version number looking in <boost/version.hpp>. See http://randspringer.de/boost for more documentation.

Habe die Boost Libraries und alles was dazu gehört installiert (Version 1.34.1-66)
Ich benutze Open Suse 11.1

Danke im Vorraus
euer Biwboy
Mitglied: datasearch
09.10.2008 um 00:44 Uhr
Hallo,

ich möchte dich ja nicht kritisieren, aber gibt es einen speziellen Grund das du licq aus dem source kompilierst? Falls du das wirklich möchtest, brauchst du das Paket boost-devel.

Alternativ kannst du aber auch das Binary Paket verwenden, was deutlich einfacher sein sollte. Benötigst du spezielle Optionen, die im RPM nicht mit kompiliert wurden, kannst du dir das source-RPM installieren und die SPEC anpassen. Ist immernoch sicherer als bei deiner Distri (openSuSE) dateien per make&&make install zu injizieren. Naja, ./configure --prefix=/usr/local sollte verhindern, das du Dateien anderer Pakete überschreibst.
Bitte warten ..
Mitglied: biwboy
09.10.2008 um 19:05 Uhr
Zuerst einmal Hallo und Danke für deine schnelle Antwort.

Es gibt eigentlich keinen besonderen Grund warum ich mit make und und make install arbeite.
Tatsächlich ist es so dass ich mich mit Linux (hoffentlich noch) nicht so gut auskenne.
Wo bekomme ich dieses Binary Paket, wie installiere ich es und kann ich es auch für andere Progs nutzen ?
Frage weil ich ja mit anderen Anwendungen das selbe Problem habe.

MfG Biwboy
Bitte warten ..
Mitglied: datasearch
11.10.2008 um 09:50 Uhr
Okey, kein Problem. Jeder hat einmal angefangen

Unter Linux werden die meisten Programme von der Distribution oder Personen, die sehr viel Zeit haben, Kompiliert und in sogen. Pakete zusammengefasst. Diese Pakete enthalten zudem Informationen, welche Dateien sie beinhalten und welche Abhängigkeiten sie benötigen. Die Distribution kümmert sich darum, das alle Pakete zu einander passen und es keine Probleme mit verschiedenen Versionen gibt.

Du solltest immer zuerst prüfen, ob deine Distribution (also bei dir OpenSuSE 11) das Paket bereits mitliefert. Ist dies einmal nicht der Fall, solltest du in alternative Paketquellen (Diese Leute mit sehr viel Zeit), wie zb. dem Packman Repository, suchen. Kannst du absolut kein passendes Binary finden, musst du tatsächlich aus dem Source kompilieren. Dazu musst du aber schauen, welche "Entwicklerdateien" deiner installierten Pakete du benötigst und diese vorher installieren.

LICQ ist bei so gut wie jeder Distribution vorhanden. Bei SuSE11 musst du das Repository "OSS" unter YAST hinzufügen und anschließend das Paket licq-1.3.5.2 installieren. Es gibt auch noch eine licq GUI.

Ich würde dir aber lieber Pidgin oder kopete als IM für ICQ empfehlen. LICQ ist nicht so toll wenn du ein Betriebssystem mit grafischer Oberfläche verwendest.

Hier ist auch der direktlink zum licq binary package. Verwende aber bitte so oft wie möglich yast, sonst bekommst du Probleme mit Updates usw.
ftp://ftp.tu-ilmenau.de/Mirrors/opensuse/distribution/11.0/repo/oss/su ...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...