Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit CRC Fehlern und defekte Daten beim Downloaden sowie Übertragen von Daten über LAN

Frage Hardware

Mitglied: e51bomag

e51bomag (Level 1) - Jetzt verbinden

26.11.2011 um 16:57 Uhr, 6648 Aufrufe, 20 Kommentare

Hallo Community,

habe folgendes Problem und weiß nun nicht mehr weiter, vll. hat jemand Rat.

Problem:
Beim Downloaden sowie Datenübertragung über die Netzwerkkarte kommen CRC Fehler, als Beispiel auf 100x100MB Parts sind im Durchschnitt 3 Parts defekt. Über WLAN funktioniert es aber!

Lösungsversuche:
Netzwerkkarte getauscht->Problem besteht, an Netzwerkkarte liegt es also nicht
Netzwerkkabel getauscht->Problem besteht, an Kabel liegt es also nicht
Switch getauscht der vorm Router hängt->Problem besteht, am Switch liegt es nicht
Mit Laptop über Kabel zum Router->Funktioniert, am Router liegt es nicht

Jetzt würde ich meinen, das Mainboard/CPU/Ram vll. einen Fehler irgendwo hat, aber der Rechner läuft ja ohne Störungen einwandfrei! So, könnte also nur noch ein Software Fehler sein oder? Aber da die CRC Fehler nur sporadisch auftreten auch kaum denkbar...

Wisst ihr vll. was ich noch versuchen könnte um dieses Problem zu beseitigen?
Mitglied: SlainteMhath
26.11.2011 um 19:48 Uhr
Moin,

auf jedenfall solltest Du einen Speichertest (z.b.memtest86) laufen lassen und mal chkdsk über deine Platte rennen lassen.

lg,
Slainte
Bitte warten ..
Mitglied: mrtux
26.11.2011 um 22:27 Uhr
Hi !

Als Ergänzung:

Bevor Du den chkdsk (mit Korrekturoptionen) auf das Dateisystem loslässt, machst Du noch eine Datensicherung. Und wenn Du es gleich richtig machen willst, dann führst vor dem chkdsk noch eine Plattendiagnose mit dem Tool des Plattenherstellers durch, denn wenn die Platte einen Defekt hat, wirst Du an einem reparierten Dateisystem nicht lange Freude haben...

Aber wenn es über WLAN tatsächlich fehlerfrei funktioniert, kann ich mir einen Platten oder Speicherfehler nur schwer vorstellen, hast Du mal einen ganz anderen Netzwerkadapter versucht, also mit einem wissentlich anderen Chipsatz? Oftmals verwenden unterschiedliche Hersteller trotzdem die gleichen Chipsätze und das OS lädt dann u.U. den selben Treiber für den anderen Adapter...

mrtux
Bitte warten ..
Mitglied: e51bomag
26.11.2011 um 22:55 Uhr
Festplatten habe ich auch schon eine andere probiert. (vergessen dazu zu schreiben)
Netzwerkadapter einmal Atheros und einmal Realtek probiert. Hat nichts gebracht ;( habe sogar auch schon mehrere Treiber probiert ohne Erfolg.

Wegen dem Speichertest, mit WLAN geht es ja aber. Deswegen sollte es ja nicht daran liegen aber machen könnte ich ihn ja trotzdem einmal.
Bitte warten ..
Mitglied: infowars
27.11.2011 um 10:02 Uhr
Überprüfe mal ob über die Abschirmung ein Potentialausgleich stattfindet.
Hört sich nach verPENnter Elektroinstallation an.
Wie lange ist denn das Kabel ?
Bitte warten ..
Mitglied: e51bomag
27.11.2011 um 16:42 Uhr
Kabel ist 2m ;) Kabel habe ich ja auch schon ein anderes ausprobiert.
Bitte warten ..
Mitglied: MrNetman
27.11.2011 um 19:39 Uhr
CRC Fehler.
Sind das Fehler auf dem Übertragungsweg oder der Datei? Was sind 100x100MB Parts? Ethernetpakete?
CRC-Fehler können auch durch falsche Einstellungen am Netzwerkport oder der lokalen Netzwerkkarte passieren.
Aber da gibt es ja noch das TCP-Protokoll. Das erlaubt keine fehlerhaften Übertragungen und korrigiert solche, wenn sie auftreten selbstständig bevor die Daten abgegeben werden.
Bei WLAN gibt es den Mechanismus der Kontrolle einer korrekten Übertragung nicht nur auf Layer 3/4 sondern auch auf Layer 2 und immer.

Ich hoffe neue Gesichtspunkte eingebracht zu haben
Gruß
Netman
Bitte warten ..
Mitglied: e51bomag
27.11.2011 um 20:26 Uhr
Also bei den 100MB Parts, machen sich die Fehler beim entpacken als CRC Fehler bemerkbar (Image auf 100MB Files gesplittet). Bei Direktdownload z.B. vom Windows AIK macht sich der Fehler bemerkbar, dass das image dann nicht geöffnet werden kann.

Netzwerkport kann ich hier nicht einstellen, ist zuhause und da habe ich schon den direkten weg von netzwerkkarte zum router (fritz box) genommen um den switch als fehlerquelle auszuschließen.

Und noch etwas, nicht nur Dateien aus dem Internet werden beschädigt sondern auch wenn ich im LAN dateien auf andere computer kopiere.
Bitte warten ..
Mitglied: MrNetman
27.11.2011 um 23:41 Uhr
Netzwerkport kann ich hier nicht einstellen, ist zuhause und da habe ich schon den direkten weg von netzwerkkarte zum router
(fritz box) genommen um den switch als fehlerquelle auszuschließen.

Und noch etwas, nicht nur Dateien aus dem Internet werden beschädigt sondern auch wenn ich im LAN dateien auf andere computer
kopiere.

Ich rate einmal:" Die ausgetauschte Netzwerkkarte war vom selben Typ. So musste man nicht auf die Treibereinstellungen achten" Alle anderen getesteten Netzwerkports (Router/Switch) sind auf Autosensing. Bei Netzwerkkabeln habe ich schon gleichartige Fehler auf gleichen Kabeln gesehen. Autosensing mit Autosensing sollte gut funktionieren. Je nach NIC kann man aber sehr intensive Einstellungen vornehmen: Speed, Duplex, Priorisierung .... Wenn man keien Messtechnik hat, kann man bei den großen Dateien mit der Stoppuhr checken ob die Übertragungsgeschwindigkeit den Erwartungen entspricht. Bis 100Mbit/s (z.B.) Firtzpox-Port klappt das leidlich. Bei Gigabit gibt es möglicherweise andere Parameter, die die Geschwindigkeit einbremsen. Aber unter 80Mbit/s sollt man auch auf älternen Systemen nicht erreichen.
Bitte warten ..
Mitglied: e51bomag
28.11.2011 um 06:54 Uhr
Also die Geschwindigkeiten sind sehr gut...
Ansonsten schaue ich mal ob man was bei den Treibereinstellungen erreichen kann. Ich hatte auch mal den TCP optimizer eingesetzt aber weiß nicht ob die Fehler von da an da waren...aber daran sollte es ja auch nicht liegen oder?
Bitte warten ..
Mitglied: cardisch
28.11.2011 um 08:36 Uhr
Moin,

hast du Jumboframes aktiviert ?!
Wenn ja, testweise mal ausschalten.

Gruß

Carsten
Bitte warten ..
Mitglied: MrNetman
28.11.2011 um 17:04 Uhr
Also die Geschwindigkeiten sind sehr gut...

==> nicht gemessen und nicht gerechnet

Ansonsten schaue ich mal ob man was bei den Treibereinstellungen erreichen kann. Ich hatte auch mal den TCP optimizer eingesetzt

==> Gut, dass das TCP-Protokoll / Layer4 noch nicht erwähnt worden ist oder?
Also Treiber der NIC auf Factory default - bitte.
Bitte warten ..
Mitglied: e51bomag
03.12.2011 um 14:31 Uhr
Zitat von cardisch:
Moin,

hast du Jumboframes aktiviert ?!
Wenn ja, testweise mal ausschalten.

Gruß

Carsten

War bei der Realtek Karte standartmäßig deaktiviert, probiere es aber noch mal mit der atheros.

//EDIT!
Habe es probiert, daran liegt es leider auch nicht ;(
Bitte warten ..
Mitglied: e51bomag
03.12.2011 um 14:32 Uhr
Zitat von MrNetman:
> Also die Geschwindigkeiten sind sehr gut...

==> nicht gemessen und nicht gerechnet

> Ansonsten schaue ich mal ob man was bei den Treibereinstellungen erreichen kann. Ich hatte auch mal den TCP optimizer
eingesetzt

==> Gut, dass das TCP-Protokoll / Layer4 noch nicht erwähnt worden ist oder?
Also Treiber der NIC auf Factory default - bitte.

wegen geschwindigkeit:

Computer Name: tbschleuder
IP Address : 192.168.178.24
Folder : \\fileserver\c$
---Writing--- ---Reading---
Packet length : 100,000,000 100,000,000
Time to complete: 1.6106529 1.3393368
Bytes per second: 62,086,623 74,663,819
Bits per second : 496,692,984 597,310,552
-------------
Mbps: 496.6929840 597.3105520


Treiber auch bereits auf Default-Einstellungen probiert
Bitte warten ..
Mitglied: MrNetman
04.12.2011 um 10:12 Uhr
Können die Festplatten diese Menge und Geschwindigkeit verarbeiten?
WLAN ist doch um einges langsamer.
Gibt es Cacheeinstellungen auf den Festplatten oder bei den Treibern?
Der Schreibcache könnte sich unangenehm auswirken.
Bitte warten ..
Mitglied: e51bomag
04.12.2011 um 12:19 Uhr
Zitat von MrNetman:
Können die Festplatten diese Menge und Geschwindigkeit verarbeiten?
WLAN ist doch um einges langsamer.
Gibt es Cacheeinstellungen auf den Festplatten oder bei den Treibern?
Der Schreibcache könnte sich unangenehm auswirken.

Die Werte entsprechen ca. 62MB Schreiben und 74MB Lesen was ja doch gut vertretbar ist. Der Test lief über LAN auf einem Raid 5 auf dem Fileserver. Da wäre Schreibcache an. Aber die Fehler treten ja auch auf wenn ich auf meinem Rechner Daten vom Internet downloade. Schreibcache ist hier an über die Einstellmöglichkeit im Geräte Manager.

Über WLAN würde ich nur ca. 2MB / s schaffen.

Ach und an der Festplatte sollte es ja nicht liegen, da über WLAN ja keine CRC Fehler zustande kommen sondern nur wenn ich über LAN downloade. Der Speicherort ist dabei immer derselbe.
Bitte warten ..
Mitglied: e51bomag
18.12.2011 um 17:48 Uhr
Also ich habe nun endlich den Fehler gefunden.

Nachdem ich bereits die TCP/IP Einstellungen vom Windows sowie den TCP Optimizer auf Default Settings erfolgslos zurücksetzte nun die Lösung:

Es liegt am falschen MTU Wert, der eine Fragmentierung der Pakete zur Folge hatte.

Man macht einen Ping zu z.b. google.de und prüft solange MTU-Werte durch bis die Pakete nicht mehr fragmentiert werden.
ping google.de -f -l xxxx
xxxx=MTU Wert, am besten bei 1500 beginnen und in 8er Schritten nach unten

setzen kann man dann den Wert mit folgendem Befehl:
netsh interface ipv4 set subinterface xx mtu=xxxx store=persistent
xx=Index ihres Netzwerkadapters der geändert werden soll
Bitte warten ..
Mitglied: MrNetman
18.12.2011 um 21:33 Uhr
Der MTU Wert ist nur von Relevanz, wenn es an den Router geht, also ins Internet. Die Fehler treten aber auch im LAN auf. Switche brauchen keine Einstellungen für MTU-Werte - zumindest nicht für den Zweck des Datentransports. Also ist der Fehler noch nciht wirklich behoben. Das WLAN kann übrigens eine deutlcih größere MTU verkraften, als die erwähnten netto 1500 Byte. Außerdem trifft das nur den sendenden Teil der Kommunikation - Beim Empfang steht da ein anderer Router, der sich um die MTU kümmert. MTU Problem würden auch kein CRC-Fhler verursachen. Wenn ein Paket verloren geht, ist TCP dafür zuständig. Das reduziert die Datenrate, aber produziert keine CRC-Fehler.
Ich tippe eher auf zuviel Einflussnahme auf zu viele Parameter.
Bitte warten ..
Mitglied: e51bomag
19.12.2011 um 07:06 Uhr
Zitat von MrNetman:
Der MTU Wert ist nur von Relevanz, wenn es an den Router geht, also ins Internet. Die Fehler treten aber auch im LAN auf. Switche
brauchen keine Einstellungen für MTU-Werte - zumindest nicht für den Zweck des Datentransports. Also ist der Fehler
noch nciht wirklich behoben. Das WLAN kann übrigens eine deutlcih größere MTU verkraften, als die erwähnten
netto 1500 Byte. Außerdem trifft das nur den sendenden Teil der Kommunikation - Beim Empfang steht da ein anderer Router,
der sich um die MTU kümmert. MTU Problem würden auch kein CRC-Fhler verursachen. Wenn ein Paket verloren geht, ist TCP
dafür zuständig. Das reduziert die Datenrate, aber produziert keine CRC-Fehler.
Ich tippe eher auf zuviel Einflussnahme auf zu viele Parameter.

Ich hatte vor einigen Tagen nochmal einen genauen Test gemacht für die Übertragung über LAN und da kamen komischerweise keine Fehler. ca. 50GB über LAN geschoben und vorher und nachher einen CRC Check gemacht.

Hatte damals ein Image übers LAN geschoben was dann kaputt war, aber vll war es vorher schon defekt das weiß ich jetzt nicht mehr genau. Ich werde das weiter beobachten, aber hauptsache das mit den defekten Downloads ist jetzt behoben.
Bitte warten ..
Mitglied: e51bomag
19.12.2011 um 16:00 Uhr
Also heute kamen nun wieder CRC Fehler -.-

Und das mit dem MTU-Wert setzen funktioniert nun auch nicht mehr. z.B. wenn ich den MTU Wert auf 1300 setze, weil bei einem Ping mit 1400 das Paket fragmentiert ist aber mit 1300 nicht, geht es nach dem setzen auf 1300 auch nicht, da ist das paket wieder fragmentiert

//UPDATE

Nachdem ich mehrere Bluescreen´s (vorallem unterschiedlichste) und Freezez hatte, habe ich nun mal einen Speichertest ala Memtest86 gemacht! -> 9 Fehler -.-
Habe nun die Taktrate herunter genommen und nun brachte der Speichertest keine Fehler mehr und ich werde es jetzt noch mal prüfen ob die CRC Fehler noch kommen!
Bitte warten ..
Mitglied: e51bomag
20.12.2011 um 15:43 Uhr
LÖSUNG

Also es lag tatsächlich am RAM! Er war vorher auf 1066Mhz getaktet (so ist er auch spezifiziert und lief auch über 3 Jahre so) und MemTest86+ fand 9 Fehler bei 40% Testverlauf. Daraufhin habe ich die Taktung auf 800Mhz heruntergenommen und nun treten keine Fehler mehr auf und die CRC Fehler sind weg.

Aber, was mich wundert, warum waren die Fehler nie beim Downloaden über WLAN aufgetreten? Erst nach einer Optimierung durch TCP Optimizer traten da auch CRC Fehler auf...
Bitte warten ..
Ähnliche Inhalte
Entwicklung
Daten aus Formular sicher übertragen
gelöst Frage von schneerunzelEntwicklung2 Kommentare

Hallo zusammen, Ich möchte meine Frage, die ich heute schon ein mal mit einer anderen Herangehensweise hier im Forum ...

Festplatten, SSD, Raid
Festplattenpartition nicht mehr zugreifbar (CRC Fehler)
gelöst Frage von D46505PlFestplatten, SSD, Raid3 Kommentare

Hallo Zusammen, ich habe eine NTFS formatierte Festplatte, die jede Nacht gebackupt wird. Die Festplatte ist gesten Nacht ausgefallen, ...

LAN, WAN, Wireless
Axis-Webcam CRC-Fehler auf Switchen
Frage von CoreknabeLAN, WAN, Wireless11 Kommentare

Moin Wissende, wir haben diverse Axis M1103-Kameras zur Videoüberwachung im Einsatz. Diese werden über PoE an verschiedenen Switchen betrieben ...

Outlook & Mail
Defekter Laptop Outlook-Konten übertragen?
gelöst Frage von mwieapfelOutlook & Mail8 Kommentare

Hallo, habe einen defekten Laptop bekommen, auf dem Outlook installiert war. Die .pst-Dateien habe ich erfolgreich übertragen können, da ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Sicherheitslücke Spectre und Meltdown: Status prüfen

Anleitung von Frank vor 3 StundenErkennung und -Abwehr

Nach all den Updates der letzten Woche sollte man unbedingt auch den Status prüfen, ob die Sicherheitslücke Spectre und ...

Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office9 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner15 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...