Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit DHCP und DNS

Frage Microsoft Windows Netzwerk

Mitglied: TomMcDuck

TomMcDuck (Level 1) - Jetzt verbinden

31.01.2006, aktualisiert 01.02.2006, 3649 Aufrufe, 3 Kommentare

Hallo!

Ich habe folgendes Problem. In einem Netzwerk werden die IP-Adressen von einem DSL-Router vergeben. Bei einem Rechner klappt das nicht. Der Netzwerkadapter ist normal eingebunden und mit den üblichen Protokollen versehen, DHCP ist aktiviert.
Ein anderer Rechner läuft am gleichen Anschluss problemlos.

Lege ich eine IP manuell fest und trage den Router als DNS-Server ein (so wird das an den anderen Rechnern über DHCP geliefert), kann ich alle Rechner anpingen und auch der defekte Rechner antwortet auf ein Ping.

Im Normalfall wird die angepingte IP nochmal angegeben: "Ping wird ausgeführt für xxx.xxx.xxx.xxx ..." Statt der IP steht dort nur noch "Ping wird ausgeführt für °Y ..."

Weiterhin funktioniert die DNS-Auflösung nicht mehr. Ich habe zwar mit fester Zugriff auf die netzinternen Rechner, aber die Auflösung von Internetadressen funktioniert nicht.

Ich habe zwischenzeitlich schon einiges ausprobiert:

- Neztwerkadapter neu installiert, Treiber aktualisiert
- USB-WLAN-Adapter installiert - gleiches Problem
- Softwarefirewall deinstalliert
- Vierenscan mit Norton und Stinger
- LSPFIX
- über route print keine festen Routen, keine sonstigen Auffälligkeiten
- Hosts und imhosts ohne Einträge
- Windows XP über Installations-CD repariert

Alles war bisher ohne Erfolg. Der Rechner verweigert weiterhin die Anforderung der IP über DHCP und löst keine Namen auf.

Ich bin mit meinem Wissen am Ende. Hat jemand noch Vorschläge für mich? Ich möchte äußerst ungern XP komplett neu installieren. Viele der installierten Programmupdates haben extreme Besonderheiten. Das wollte ich mir ersparen!

Es wäre super, wenn noch jemand eine Idee hätte.

Danke!
Tom
Mitglied: 19726
31.01.2006 um 23:45 Uhr
Scheint so, als wäre dein TCP/IP Stack hinüber...
Es gibt ne Möglichkeit, den wieder in den Urzustand ( wie Neuinstallation ) zu versetzen. Is aber nicht ganz ungefährlich...
Machst mit dem Utility netsh
der gesamte Befehl dafür lautet:
netsh int ip reset [dateiname_fuers_log.txt]

du musst, um den befehl erfolgreich auszuführen, ein logdatei angeben in die die Aktionen geschrieben werden.

Der Befehl macht nix anderes, als zwei Reg Keys verändern.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DHCP\Parameters\

Mach aber auf jeden Fall ein Backup!!!


Gib mir bitte Bescheid, wenns funktioniert hat.

Gruß Stoggy
Bitte warten ..
Mitglied: TomMcDuck
01.02.2006 um 19:37 Uhr
Hallo Stoggy,

Vielen Dank für den Tip! Ich habe nach einer Sicherung die von Dir genannten Befehlszeile so ausgeführt - ohne Erfolg. Nach einem Neustart war das Problem immer noch das gleiche.

Dann habe ich mir netsh mal genauer angeschaut und bin in die einzelnen Unterkontexte gegangen und habe die einzeln resettet. Das hat es dann gebracht!

Nach einem Neustart stand die Verbindung wieder wie gewohnt zur Verfügung.

Danke nochmal für den Tip! Das hat mir ´ne Menge Arbeit erspart!

Gruß
Tom
Bitte warten ..
Mitglied: 19726
01.02.2006 um 20:26 Uhr
Kein Problem. War mir ein Vergnügen...
Und für ne Bewertung macht man ja viel... ;)

Gruß Stoggy
Bitte warten ..
Ähnliche Inhalte
Windows 7
Netzwerk-Domäne gleich Online-Domäne - DNS Problem (10)

Frage von Manik013 zum Thema Windows 7 ...

DNS
Mobiles DNS Problem bei VPN Verbindung (4)

Frage von holladie zum Thema DNS ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...

Windows Server
gelöst Windows Server 2016 ohne DNS und DHCP (6)

Frage von unique24 zum Thema Windows Server ...

Neue Wissensbeiträge
Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Peripheriegeräte

Was beachten bei der Wahl einer USV Anlage im Serverschrank

(7)

Tipp von zetboxit zum Thema Peripheriegeräte ...

Windows 10

Das Windows 10 Creators Update ist auf dem Weg

(6)

Anleitung von BassFishFox zum Thema Windows 10 ...

Administrator.de Feedback

Tipp: Ungelöste Fragen ohne Antwort in Tickeransicht farblich hinterlegen

Tipp von pattern zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Windows Server
gelöst Update BackupExec 2015 auf 2016 führt zu SQL-Server Problem (16)

Frage von montylein1981 zum Thema Windows Server ...

Batch & Shell
gelöst Batch um Benutzer aus Sitzung abzumelden (15)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Userverwaltung
gelöst Nicht Admins erlauben Verknüpfungen zu löschen (13)

Frage von WinLiCLI zum Thema Windows Userverwaltung ...