Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit der Eingabe durch user in einem batch Skript

Frage Entwicklung Batch & Shell

Mitglied: azrael995

azrael995 (Level 1) - Jetzt verbinden

22.09.2011, aktualisiert 10:39 Uhr, 2609 Aufrufe, 5 Kommentare

Hi @,

ich habe ein batchprogramm geschrieben, dass auf bestimmte Werte in der Eingabe triggert.
Wenn ich das bei einer konstanten Zeichenfolge laufen lasse funktioniert das ganze einwandfrei

Aber wenn ich die Variable mit

01.
set /P Variable=
vom User einlesen will dann triggert er nicht mehr

Ich hab Ger als Tastatur und denke, dass es vlt daran liegt, dasss bei der batch vermutlich USA Tastatur verwendet wird

daher 2 Fragen:
weiss einer wie man vlt die Tastatur oder die Codepages im batch-file umstellen bzw synchronisieren kann
oder:
Weiss einer wie ich die Werte via Universalcode (vlt ASCI-Code) synchronisieren kann

Danke für die Mühe im Voraus und gl hf,

arael995
Mitglied: Skyemugen
22.09.2011 um 10:15 Uhr
Aloha,

macht für mich relativ wenig Sinn, ausgenommen, du willst zwangsläufig (deutsche) Umlaute dort eingegeben haben ...

Da wir nicht wissen, wie du triggerst, sprich, was mit der Variable geschieht, ist eine Lösungsfindung schwierig, an sich jedoch dürfte bei der Eingabe lateinischer Buchstaben und arabischen Zahlen batch ziemlich egal sein, wie sie ins Programm kommen (brauchst ja bloß mal, dein Eingabegebietsschema auf US ändern ...)

Wenn ein Problem mit DE-US besteht, dann eventuell eher beim Verarbeiten der Variable. Aber meine Kristallkugel ...

greetz André

P.S.: chcp - ganz toller Befehl
Bitte warten ..
Mitglied: azrael995
22.09.2011 um 10:48 Uhr
das sind einfache if vergleiche, der auf die einzelnen Umlaute reagert d.h.:

01.
if  /i  "%bla%" == "ü" goto blabla 
denn die Buchstaben komen dort einzeln an in der Schleife
aber das prob is:

dass in der Eingabe z.B kann er ein ü darstellen und richtig einlesen, aber er erkennt das ü wenn er es mit meinem ü vergleicht nicht
wenn ich dagegen die konstanten z.b
01.
 set Variable= übel


als konstanten Wert eintrage gibt er mir als Zeichen in der Schleife kein ü sondern ein Kubik an d.h ^3

dass mit chcp is ne gute Idee und werd ich gleich probieren

thx azrael
Bitte warten ..
Mitglied: azrael995
22.09.2011 um 10:59 Uhr
chcp sagt bei meiner batch die richtige codepageseite 850

aber das erklärt mir noch weniger, wieso er nach der Eingabe durch den User die richtigen Zeichen ansonsten die falschen, welche er aber triggert zeigt

now i m totally confused^^
Bitte warten ..
Mitglied: Skyemugen
22.09.2011 um 11:04 Uhr
Aloha,

chcp an sich bewirkt auch nichts, du musst schon selbst die gewollte, neue Codepage mit angeben ...

Also du has die Wahl:
  • wenn du die Abfrage mit Umlauten gestaltest, dann bearbeite entweder die batch am CMD mit EDIT X:\PfadZur\batch.bat und schreibe dort die Umlaute rein und speichere dann.

01.
@echo off & setlocal 
02.
set /p Eingabe= 
03.
if /i %Eingabe% equ  echo Umlaut durch EDIT erkannt 
04.
if /i %Eingabe% neq ü echo Umlaut nicht erkannt (das hier wurde ohne EDIT geschrieben) 
05.
pause 
06.
goto :eof
oder eben
  • mit chcp 1252
01.
set /p Eingabe= 
02.
chcp 1252>nul 
03.
if /i %Eingabe% equ ü echo Umlaut erkannt 
04.
chcp 850>nul
greetz André
Bitte warten ..
Mitglied: azrael995
22.09.2011 um 11:24 Uhr
Vielen Dank Andre,

ich use Nr. 2. geht Alles sehr gut und ebenso Danke für die schnelle Antwort
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Batch Skript während dem Betrieb mittels GPO laufen lassen (14)

Frage von WinLiCLI zum Thema Windows Server ...

Batch & Shell
Wo ist der Fehler in diesem Batch Skript? (11)

Frage von gabrixl zum Thema Batch & Shell ...

Batch & Shell
Batch Skript erweitern (1)

Frage von michi-ffm zum Thema Batch & Shell ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...