Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Erweiterung von QNAP-NAS

Frage Hardware SAN, NAS, DAS

Mitglied: qualidat

qualidat (Level 1) - Jetzt verbinden

17.08.2014, aktualisiert 18.08.2014, 3846 Aufrufe, 6 Kommentare

Sind QNAP-Kenner hier? Ich habe ein TS-412 im Raid-5-Mode, bisher mit 4 x 500 GB und will es auf 4 x 1TB im laufenden Betrieb erweitern.

Bisher hat das Austauschen von 3 der 4 Festplatten auch prima geklappt: In der Oberfläche das Raid ausgewählt, auf "ändern", dann "erweitern" gegangen, die zu tauschende Platte angehalten, getauscht, den Rebuild abgewartet, nächste Platte ... fast schon Routine.

Ausgerechnet die letzte Platte (Platte 1, habe mit 4,3,2 begonnen), wird zwar als solche erkannt (SMART: "gut"), aber der bisher 3 mal immer automatisch angelaufene Rebuild-Prozess will einfach nicht starten. So habe ich eine einzelne Platte, mit der scheinbar Alles in Ordnung ist und dazu ein Raid 5 aus 3 Platten im "herabgesetzten Modus" und ich weiss nicht, wie ich die neue Platte da dazubringe. Tips? Hinweise?

Da wäre nat. noch die Möglichkeit, das NAS komplett neu aufzusetzen (vorher die Daten zu sichern), aber beim Kopieren großer Datenmengen mit dem Mac vom NAS tritt immer wieder der unsägliche Fehler "Datei in Benutzung" auf, der den Kopiervorgang abbricht.
Mitglied: aqui
LÖSUNG 17.08.2014, aktualisiert um 17:40 Uhr
Fehler "Datei in Benutzung" auf, der den Kopiervorgang abbricht.
Kopierst du mit AFP oder SMB/CIFS ??
Bitte warten ..
Mitglied: qualidat
17.08.2014 um 17:41 Uhr
Passiert m.E. bei beiden Protokollen, oder weisst du mehr darüber?
Bitte warten ..
Mitglied: aqui
17.08.2014, aktualisiert um 18:16 Uhr
Was heisst m.E. ?? Passiert es auch bei AFP bzw. hast du überhaupt AFP aktiviert ?

Wieso ist der Thread auf "Gelöst" geklickt ?? Ist das Problem jetzt gelöst oder was ?
Bitte warten ..
Mitglied: Dobby
17.08.2014 um 21:25 Uhr
Hallo zusammen,

Wieso ist der Thread auf "Gelöst" geklickt ?? Ist das Problem jetzt gelöst oder was ?
Tja das ist in letzter Zeit leider immer öfters zu beobachten! Leider!
Ohne ein "Hallo" zu Beginn und einen "Gruß" zum Schluss, und Hauptsache schnell,
schnell, schnell.

Also man kann auch auf den "Bearbeiten" Knopf drücken und den Beitrag wieder als nicht
gelöst markieren.

So ein Backup sollte man grundsätzlich immer machen wenn man an irgendwelchen
HDD etwas macht, egal was. Aber ok nun ist es schon so weit das Du ein Problem
bekommen hast.

Da wäre nat. noch die Möglichkeit, das NAS komplett neu aufzusetzen
(vorher die Daten zu sichern),
Das würde ich jetzt auch als nächstes in Betracht ziehen wollen und zwar
ohne weiter herum zu probieren oder weiter mit irgend welchen Tricksen zu arbeiten.
- Mit was sicherst Du denn das NAS sonst in der Regel?
- Was ist denn das überhaupt für ein NAS?
- Welche Schnittstellen hat das NAS denn?

aber beim Kopieren großer Datenmengen mit dem Mac vom NAS tritt immer wieder
der unsägliche Fehler "Datei in Benutzung" auf, der den Kopiervorgang abbricht.
Dann wird dem wohl auch so sein, oder? Ohne Dein NAS zu kennen muss man hier
einfach mal raten und das ist das aller letzte was Du hier gebrauchen kannst, denn
wenn etwas schief läuft, ist das RAID hinüber und die Daten futsch.

Gruß
Dobby
Bitte warten ..
Mitglied: qualidat
18.08.2014 um 01:41 Uhr
Also das Problem ist nicht gelöst, ich weiss nicht, wer oder wodurch diese Info gesetzt wurde ... ich habe es jetzt rückgängig gemacht.

Um welches NAS es sich handelt, steht doch im Eingangs-Post: ein Qnap TS-412. Der Fehler beim Kopieren großer Datenmengen (Anzahl von Dateien, Größe egal) tritt nur beim Mac auf, wenn das SMB-Protokoll verwendet wird - dann "überschlägt" sich die Kopierroutine im Finder irgendwie und es wird mit der (falschen!) Behauptung abgebrochen, irgend eine Datei sei in Benutzung. Verwendet man AFP (so wie ich jetzt), passiert das nicht.

Ich sichere die Daten nun erstmal ordnerweise, dazu habe ich so ein USB-Dock mit zwei 1TB-Platten direkt an das NAS angeschlossen und nutze dessen eingebaute Backup-Funktion.

Trotzdem bleibt das ursprüngliche Ärgernis: Wieso kann ich dreimal das Raid erweitern (mit fabrikneuen, baugleichen Platten), aber beim vierten Mal geht es plötzlich nicht mehr. D.h. eine Erklärung wäre nat. ein fetter Bug im Betriebssystem des NAS, was mir aber bei dem doch relativ gut reputierten Hersteller Qnap nicht so recht einleuchten will. Zur Not muss ich halt das Raid auflösen, alle Platten neu formatieren, das Raid wieder anlegen und das Backup zurückkopieren ... ja geht, ist aber irgendwie Sch..e.
Bitte warten ..
Mitglied: Dobby
18.08.2014 um 09:30 Uhr
Also das Problem ist nicht gelöst, ich weiss nicht, wer oder wodurch diese
Info gesetzt wurde ... ich habe es jetzt rückgängig gemacht.
Ist ja auch nur für Dich gewesen, denn sonst schreibt eventuell auch keiner mehr
etwas dazu!

Um welches NAS es sich handelt, steht doch im Eingangs-Post: ein Qnap TS-412.
Alles klar war mein Fehler habe ich glatt überlesen.

Ich sichere die Daten nun erstmal ordnerweise, dazu habe ich so ein USB-Dock mit zwei
1TB-Platten direkt an das NAS angeschlossen und nutze dessen eingebaute Backup-Funktion.
Das wäre auch das erste was ich jetzt an dieser Stelle gemacht hätte!
Und zwar ohne Umwege.

Trotzdem bleibt das ursprüngliche Ärgernis: Wieso kann ich dreimal das Raid erweitern (mit
fabrikneuen, baugleichen Platten), aber beim vierten Mal geht es plötzlich nicht mehr.
Würde ich auch komisch finden, kein Thema.

D.h. eine Erklärung wäre nat. ein fetter Bug im Betriebssystem des NAS, was mir
Ok das kann schon von Firmware zu Firmware mal sein.

aber bei dem doch relativ gut reputierten Hersteller Qnap nicht so recht einleuchten will.
Das kann jedem mal passieren, das hat Synology oder sogar Thecus auch mal mit im
Programm.

Zur Not muss ich halt das Raid auflösen, alle Platten neu formatieren,
das Raid wieder anlegen und das Backup zurückkopieren
Jo das wird dann leider wohl das sein was niemand gerne macht, aber willst
Du es riskieren dass Deine Daten irgend wann ganz weg sind?

... ja geht, ist aber irgendwie Sch..e. face-sad
Brauchst Du nicht extra erläutern wer macht das schon gerne!
Ich sichere ab und an auf einen externen USB BlueRay Brenner
und regelmäßig auf ein RDX Laufwerk, daher sehe ich das immer
etwas entspannter.

Gruß
Dobby
Bitte warten ..
Ähnliche Inhalte
Erkennung und -Abwehr
Command Injection: Qnap-NAS-Geräte aus der Ferne angreifbar

Link von magicteddy zum Thema Erkennung und -Abwehr ...

SAN, NAS, DAS
gelöst QNAP NAS Daten von einer Festplatte nach zurücksetzung (22)

Frage von Honkelord zum Thema SAN, NAS, DAS ...

Backup
Integrating RDX QuikStor into QNAP NAS Backup

Link von Dobby zum Thema Backup ...

SAN, NAS, DAS
Zweiwege-Synchronisierung mit QNAP NAS und AD-Berechtigungen (3)

Frage von Sinzal zum Thema SAN, NAS, DAS ...

Neue Wissensbeiträge
Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
VPN Tunnel aufbauen (16)

Frage von Hajo2006 zum Thema LAN, WAN, Wireless ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (14)

Frage von marshall75000 zum Thema Router & Routing ...

Microsoft Office
Saubere HTML aus Word-Dokument (14)

Frage von peterpa zum Thema Microsoft Office ...

E-Mail
gelöst Probleme beim E-Mail Empfang (12)

Frage von TommyB83 zum Thema E-Mail ...