Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Excel Diagramm und dem mitteln von Werten

Frage Microsoft Microsoft Office

Mitglied: corpse2001

corpse2001 (Level 1) - Jetzt verbinden

16.10.2006, aktualisiert 19.10.2006, 10500 Aufrufe, 8 Kommentare

Hallo,

ich habe mit Perfmon eine Auswertung der CPU-Last über drei Tage.
Diese habe ich in eine Excel-Tabelle importiert und möchte nun ein Diagramm darus erstellen was grudsätzlich auch klappt allerdings nicht so wie ich mir das vorstelle.
Es soll so aussehen das auf der X-Achse eine skalierung steht über die drei Tage, welche in Stunden aufgeteilt ist und auf der Y-Achse die Prozent (0 bis 100).
Zudem möchte ich das die CPU-Auslastungswerte (ca. 17000 Werte) gesamt gemittelt werden so das ich eine übersichtliche Kurve in dem Diagramm habe allerdings habe ich keine Ahnung wie ich das nun Umsetzen kann.

Verwendet wird Excel 2003 SP2

mfg corpse2001
Mitglied: Nottrott
16.10.2006 um 15:22 Uhr
Hallo,

Meine Lösung ist für Excel 2000. Vielleicht gehts auch unter 2003.

wenn du die Daten in Excel importiert hast, müsstest du diese ja untereinander in der Tabelle stehen haben. In der ersten Spalte steht dann warscheinlich die Uhrzeit und in der zweiten die gemessenen Werte. Die Spalte mit der Uhrzeit kannst du ja so formatieren, dass du entweder nur die Uhrzeit oder Datum und Uhrzeit siehst.
Nun wählst du beide Spalten aus (ohne die erste Zeile mit "(PDH-CSV 4.0) (Westeuropäische Sommerzeit)(-120)" usw.) und klickst im Menü auf "Einfügen" und auf "Diagramm". Dann wählst du bei Diagrammtyp am besten "Linie" und rechts das ohne Punkte (bei mir links oben) aus (ist übersichtlicher). Nun klickst du auf "Weiter" und solltest bereits eine Vorschau auf das Diagramm sehen.
Wenn du nochmal auf "Weiter" klickst, kannst du eine Beschriftung für die einzelnen Achsen eingeben.
Nochmal auf "weiter" und auswählen, wo das Diagramm hin soll.
Um nun die y-Achse auf 100% zu begrenzen, klickst du mit der rechten Maustaste aus diese und wählst "Achse formatieren". Dann auf "Skalierung" klicken und als Maximum 100 eintragen.
Nun nochmal auf die x-Achse rechtsklicken und Skalierung anwählen und neben "Rubrikenanzahl zwischen Teilstrichbeschriftungen" die Zahl eintragen, nach wievielen Werten wieder eine Beschriftung kommen soll. Das müssten bei dir für jeweils eine Stunde etwa 240 sein.
Um dann noch eine Mittellinie reinzubekommen, musst du glaube ich auf den Graphen rechtsklicken und auf "Trendlinie hinzufügen" klicken. Da bin ich mir jetzt nicht ganz sichen. Musste halt ein Bisschen rumprobieren.

Ich hoffe, ich konnte dir helfen,
Nottrott
Bitte warten ..
Mitglied: corpse2001
17.10.2006 um 15:22 Uhr
danke für die Antwort das funktioniert leider nicht ganz ich habe jetzt manuel ein halbwegs annehmbares Ergebnis produziert.
Habe nun noch eine andere Frage uns zwar ist es möglich in Excel zu sagen:
Mache alle allen z.b. 10 werten einen Mittelwert und schreib die dahin dann mache einen Mittelwert aus den nächsten 10 Werten und schreib die dort hin?

mfg corpse2001
Bitte warten ..
Mitglied: Nottrott
17.10.2006 um 15:28 Uhr
Ja,

da gibts die Funktion MITTELWERT.
Du gehst in eine leere Zelle, am besten neben den zu mittelnden Werten (übersichtlicher) und schreibst =MITTELWERT(a,b) wobei a für die Zelles steht, bei der du anfangen möchtest und b für die, bei der du aufhörst.
Du kannst auch nur =MITTELWERT( schreiben und dann die Felder mit der Maus aufziehen.
Da die Feldangaben in der Klammer relativ zur Formel gleich bleiben, kannst du die Formel einfach z.B. 10 Zeilen weiter unten hinkopieren und du hast dann den Mittelwert von den Werten, die 10 Zeilen unter deinen ersten Werten standen.

Nottrott
Bitte warten ..
Mitglied: corpse2001
17.10.2006 um 15:54 Uhr
danke für die schnelle Antwort gibt es auch die möglichkeit das zu automatisieren das ich das nicht kopieren brauch weil ich habe da über 17000 Werte?

mfg corpse2001
Bitte warten ..
Mitglied: Nottrott
17.10.2006 um 16:17 Uhr
Du kannst versuchen, neben 1 den Mittelwert von 1-10, neben 2 den Mitelwert von 1-10, usw. bis zur 10. Und dann bei der 11 den Mittelwert von 20 daneben. Dann die Mittelwerte auswählen und mit dem kleinen Rechteck rechts unten am Rahmen, der um die Zellen herum ist, die Mittelwerte einfach mit der Maus nach unten ziehen. Dann müssten immer bei 10 aufeinanderfolgenden Feldern der selbe Mittelwert stehen. Daraus kannste dann ein Diagramm machen.

Nottrott
Bitte warten ..
Mitglied: corpse2001
18.10.2006 um 09:29 Uhr
ds ist eigentlich ne gute idee aber irgentwie übernimmt er meinen rüthmus nicht richtig kann man das irgentwo einstellen?
Bitte warten ..
Mitglied: Nottrott
18.10.2006 um 15:49 Uhr
bist du sicher, dass du die ersten paar zeilen richtig eingetragen hast? Versuch mal, die ersten drei unterschiedlichen Mittelwertberechnungen (bei jeweils 10 zusammengefassten Werten --> 30 Zeilen) von Hand auszufüllen und probiers dann nochmal.
Notfalls kannst du mir vielleicht die Datei zusenden.

Nottrott
Bitte warten ..
Mitglied: corpse2001
19.10.2006 um 11:39 Uhr
hallo

ich habe die Lösung schon

=MITTELWERT(BEREICH.VERSCHIEBEN($B$46;(ZEILE(1:1)-1)*121;0;121;))/100000000000000

mfg corpse2001
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Excel Diagramm - Datum wird nicht aktualisiert (10)

Frage von KMP1988 zum Thema Microsoft Office ...

Microsoft Office
Excel Zählewenn aus Formel Wert (2)

Frage von cberndt zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel: Wert aus mehreren Zeilen vergleichen (2)

Frage von Nicolaas zum Thema Microsoft Office ...

Microsoft Office
gelöst Mal wieder ein Excel-Problem (4)

Frage von Yannosch zum Thema Microsoft Office ...

Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Netzwerke
DynDNS Dienst mit Mikrotik Router OS 6.4 (12)

Frage von Mopskiller zum Thema Netzwerke ...

Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...