Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit exponent CMS auf IIS6

Frage Internet CMS

Mitglied: blackwinged

blackwinged (Level 1) - Jetzt verbinden

09.04.2008, aktualisiert 13:23 Uhr, 3616 Aufrufe, 2 Kommentare

Hallo zusammen,
Ich habe einen Windows 2003 Server von XAMPP (PHP5.2&MySQL) auf IIS6 mit PHP 5.2 und MySQL umgestellt.
Auf diesem Server liegt eine Intranet-Webseite, die auf dem exponent-CMS basiert.
Alle Installationen haben geklappt, PHP wird auch geparst, allerdings wird nur ein kleiner Teil der Webseite im Browser angezeigt.

Nachdem ich mich durch den ganzen PHP-Wust geschlagen habe, habe ich festgestellt, dass die Funktion pathos_theme_showModule in der index-Datei des Themes kein Ergebnis liefert.
Jetzt habe ich versucht, die Funktionsdefinition zu finden, konnte sie aber nirgends auftreiben...

Kann es sein, dass die require-Anweisungen, mit denen die Datei mit der Funktion eingebunden wird, unter XAMPP funktioniert, unter IIS jedoch nicht?
Oder woran kann das sonst liegen... die inkludierten Dateien sind alle vorhanden.

die Codestelle, ab der anscheinend kein PHP-Code mehr ausgeführt wird, ist
01.
<div id="NaviMain"><?php pathos_theme_showModule("navigationmodule","Top Nav"); ?></div>
Schonmal vielen Dank für jede Hilfe!
Mitglied: Dani
09.04.2008 um 12:27 Uhr
Hi,
soweit ich das auf der Homepage von denen lese, geht das laut Anforderungen nur mit Apache!
http://www.exponentcms.org/?section=30


Grüße
Dani
Bitte warten ..
Mitglied: blackwinged
09.04.2008 um 13:23 Uhr
Hi,
soweit ich das auf der Homepage von denen
lese, geht das laut Anforderungen nur mit
Apache!
http://www.exponentcms.org/?section=30


Grüße
Dani

Die Lösung liegt oft so nah...
Ich kann die Herren zwar nicht verstehen, dass sie es nicht Server-unabhängig machen, aber dann muss wohl ne Alternative her : /
Vielen Dank!
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Dateinamen mit Batch-Datei ändern - Problem (9)

Frage von fffffuuuuuuuhhhh zum Thema Batch & Shell ...

Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...