Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit FCKeditor

Frage Entwicklung PHP

Mitglied: afri

afri (Level 1) - Jetzt verbinden

26.02.2007, aktualisiert 27.02.2007, 4795 Aufrufe, 7 Kommentare

Der Editor wird trotz richtiger Pfadangaben nicht angezeigt.

Hallo.

Ich entwickle gerade ein kleines CMS und habe ein Problem mit dem FCKeditor.
Und zwar wird er nicht angezeigt, obwohl alle Pfadangaben stimmen.
Die Fehlermeldung "Objekt nicht gefunden" kommt auch nicht. -> Pfadangaben stimmen.

Ich habe mal ein Screenshot hochgeladen:
http://schrempfy.de/pics/fckeditor.gif

Im Quelltext sieht es folgendermaßen aus:
<div><input id="katinhalt" name="katinhalt" value="" style="display:none" /><input type="hidden" id="katinhalt___Config" value="" style="display:none" /><iframe type="hidden" id="katinhalt___Frame" src="../fckeditor/editor/fckeditor.html?InstanceName=katinhalt&amp;Toolbar=Default" width="100%" height="280" frameborder="0" scrolling="no"></iframe></div> <table>

Naja, Google kann mir bei diesem Problem wohl nicht helfen. Ich suche schon mittlerweile seit 5 Tagen nach einer Lösung.

Interessant ist auch, das die Demo auf der FCKeditor-Seite einwandfrei angezeigt wird.
Ich habe auch schon versucht den Cache zu löschen - vergeblich.

Ich hoffe jemand hat einen guten Tipp

Mit freundlichen Grüßen
Daniel
Mitglied: 16568
26.02.2007 um 21:14 Uhr
Nun, sagen wir es doch mal deutlich:

Ich gehe davon aus, daß Du Dein CMS später verkaufen willst.
Sollen wir hier Entwicklern helfen, ihre stümperhaften PHP-Kenntnisse aufzubessern?
Damit diese sie dann gegen teuer Geld verkaufen können?
Und ihre Kunden sooo toll supporten können?

Wohl kaum.

Poste in die Newsgroup von FCKedit.


Und falls das opensource sein sollte:
Bitte nicht schon wieder...
Gründe doch eine Community für Deine Idee / Dein Projekt.


Lonesome Walker
Bitte warten ..
Mitglied: afri
26.02.2007 um 21:32 Uhr
Vielen Dank für die "Antwort".

Erstens: Wer will was verkaufen?
Zweitens: Wer will was unter GPL/GNU/etc veröffentlichen?
Drittens: Dieses Problem hat wohl kaum etwas mit den PHP-Kenntnissen zu tun.
Viertens: Newsgroups, Foren auf SF.net habe ich schon durch. Lösung dort: Neuinstallation, Cache löschen.
Fünftens: Deine hellseherischen Fähigkeiten sind ganz klar unterste Schublade. Ich habe nie erwähnt, dass ich das CMS veröffentlichen will.

Sechstens: Wenn man keine Ahnung hat, ist es besser, einfach mal die Klappe zu halten.

Und weil mir diese Antwort soviel bedeutet und weiterhilft, kriegste auch nen Webtipp von mir wo du dein Wissen weiter ausarbeiten kannst: www.stupidedia.org

Danke, "Gott".
Bitte warten ..
Mitglied: 16568
27.02.2007 um 09:28 Uhr
Was willst Du dann mit dem CMS machen?

Wenn nicht kommerziell oder opensource, wozu dann?

Du bist nur wieder einer der vielen Schnorrer hier...
Ich bin mir sicher, daß dies nur ein programmier-technischer Fehler ist, der, würdest Du eine ordentliche Programmier-Umgebung verwenden, sofort auffallen.
(oh ich vergaß, sowas kostet ja Geld...)

Und zu sechstens:
Anscheinend ist dies Dein erstes PHP-Projekt; daher gilt diese Aussage wohl eher für Dich...


Lonesome Walker
Bitte warten ..
Mitglied: afri
27.02.2007 um 16:15 Uhr
Wenn du meinst...
Ich benutze Eclipse.

Mein erstes PHP Projekt ist es nicht, aber ich programmiere lieber in ASM und C.

Das CMS will ich privat für mich, ja du hast richtig gehört: solche Menschen gibt es auch, nutzen.

Und ich schnorre auch nicht. Ich habe lediglich gefragt ob jemand einen Rat weiss.
Oder habe ich etwa nach Code gefragt? Ist mir jedenfalls nicht aufgefallen.

Achja:
Wenn man sich den FCKeditor runtergeladen hat, dann sind da Beispielanwendungen bei, die ich nicht geschrieben habe, sondern die Entwickler. Komischerweise scheinen meine "ach so spährlichen Programmierkenntnisse" auch daran schuld zu sein, dass die Demos auch nicht klappen. Sehe ich das so richtig?

Vielleicht bekommst du ja nochmal etwas Nützliches aus deinem Plappermaul heraus mit dem du mir und anderen Forenteilnehmern helfen kannst. Schließlich ist das der Sinn dieses Forums.
Aber da scheine ich schon wieder einmal falsch zu liegen, richtig?

Also nochmal eine Zusammenfassung meines Problems:
FCKeditor heruntergeladen.
Die Demo auf FCKeditor.net funktioniert, die im Downloadpaket nicht.
FCKeditor wurde nach Installationsanweisungen installiert und konfiguriert.
Der FCKeditor wird nicht angezeigt. Eine Fehlermeldung erscheint nicht.
An meiner XAMPP-Version, denke ich mal, liegt es nicht. Ich habe alles mal hochgeladen...
Ohne Erfolg.
Bei anderen Editoren (zB TinyMCE) habe ich das selbe Problem: Demo auf der Seite der Entwickler funktioniert, die im Downloadpaket nicht.

Bitte keine "Du kannst nicht Programmieren. Du hast keine gute kostenpflichtige Entwicklungsumgebung, etc..."-Antworten.

Mit freundlichen Grüßen
Daniel
Bitte warten ..
Mitglied: 16568
27.02.2007 um 17:24 Uhr
Doch, die kriegst Du.

Hier würde ich auf einen Installations-Fehler tippen;
aber das hätte ja einem "Gott" mit dem Namen W*** sicher auch schon ins Auge springen können...


Lonesome Walker
Bitte warten ..
Mitglied: afri
27.02.2007 um 17:52 Uhr
Wenn es ein Installationfehler ist, frage ich mich, warum die Beispiele in dem Downloadpaket nicht funktionieren. Wenn ich das ganze mit dem Laptop nachvollziehe, funktioniert es.
Bitte warten ..
Mitglied: 16568
27.02.2007 um 20:08 Uhr
Wo ist da der Unterschied zwischen Laptop und dem Rechner, wo das Problem auftritt?


Lonesome Walker
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Google Chrome Web Store Problem auf Terminal Farm

Frage von dakoerry zum Thema Windows Server ...

Multimedia & Zubehör
gelöst Problem: DVI zu VGA (8)

Frage von Protected zum Thema Multimedia & Zubehör ...

Windows Server
Problem bei Zertifikatsverlängerung auf SBS2008 (2)

Frage von Firewire zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Activesync Problem bei IOS 10.1.1 und Wildcard SSL Zertifikat (2)

Frage von hasel123 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...