Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit FOR-Schleife für Verzeichnisabarbeitung

Frage Entwicklung

Mitglied: Knumskull

Knumskull (Level 1) - Jetzt verbinden

15.04.2009, aktualisiert 10:11 Uhr, 3809 Aufrufe, 3 Kommentare

Problem mit der For-Schleife. Gestern hat es nocht funktioniert.

Ich möchte alle Reg-Files in einem Verzeichnis parsen. Nur irgendwie geht der nicht in meine FOR-Schleife rein. Also die Zeile 'for /R \\remotecomputer\reg\win32 %%A in (*.reg) do (' funktioniert wohl schon irgendwie nicht

Hat jemand eine Idee?

01.
for /R \\remotecomputer\reg\win32 %%A in (*.reg) do ( 
02.
  echo %%A 
03.
  type "%%A" > %LOC_TEMPFILE% 
04.
  set _result=0 
05.
  rem # Reg-files durchparsen und nach REG-Eintraegen suchen und diese vergleichen 
06.
  for /F "skip=1 delims=" %%J in (%LOC_TEMPFILE%) do (   
07.
    rem # Anhand des Zeichens '[' wird der Reg-Schluessel erkannt 
08.
	echo in for-loop 
09.
	echo %%J | find "[" >%LOC_TEMPFILE_2% 
10.
	set /p VAR=<"%LOC_TEMPFILE_2%" 
11.
	reg query "\\%WORKSTATION%\!VAR:~1,-2!" >NUL 2>&1 
12.
	if errorlevel 1 set _result=1 
13.
14.
  if "!_result!"=="1" ( 
15.
    rem # Subroutine fuer Registry-File-import wird aufgerufen 
16.
    echo call :INCLUDE_REG %%A 
17.
	call :INCLUDE_REG %%A 
18.
19.
)
Mitglied: 60730
15.04.2009 um 10:23 Uhr
Servus,

Mit Batch kannst du nur Befehle ausführen - die es auch gibt.

Daher müßte - damit "das" stimmt - auch eine Freigabe Reg auf Remotecomputer existieren.
\\remotecomputer\reg\win32


Entweder mappst du vorher - jedes c$ - jedes Rechners - oder du nimmst PSexec und führst das dann "so"lokal (von deinem Rechner gesteuert) aus.

"wenn" es per Schleife laufen soll, dann ungefähr und ungetestet so:

for /f %%i in (dir /A-D /s *.reg) do regedit /s %%i

Aber wie geschrieben - mach es per Pssexec.

Gruß
Bitte warten ..
Mitglied: Knumskull
15.04.2009 um 10:41 Uhr
die erste Zeile in meiner For-Schleife war eher exemplarisch

genau lautet diese

01.
for /R %CAE_PAKET_REG_HOME%\!ARCH! %%A in (*.reg) do 
die Var: CAE_PAKET_REG_HOME ist eine Freigabe im Netz, in der verschiedene REG-Files liegen. Diese sind noch nach Architektur (32/64bit) unterteilt.

Die Var !ARCH! wird pro Rechner ermittelt und resultiert in win32 oder win64

und ich vermute auch, das in dieser VAR das Problem liegt. Warum auch immer. Ich habe gerade die VAR mal durch "win32" ersetzt und da hat es funktioniert.
Bitte warten ..
Mitglied: Knumskull
15.04.2009 um 10:52 Uhr
ich habe das !ARCH! durch %ARCH% ersetzt.

Ich dachte ich muss das hier auch so machen, allerdings rufe ich diese FOR-Schleife in einer extra Datei auf und das ARCH wird in der Datei zuvor gesetzt.

Demnach ist wohl %ARCH% bekannt.

Jetzt funktioniert es.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Abfrage ERRORLEVEL springt aus der FOR Schleife (8)

Frage von Galindiesel zum Thema Batch & Shell ...

Batch & Shell
gelöst Warum funktioniert das echo in meiner for-Schleife auch mit Sonderzeichen? (9)

Frage von Pedant zum Thema Batch & Shell ...

Batch & Shell
Verschachtelte For Schleife für Batch Neuling (3)

Frage von yperiu zum Thema Batch & Shell ...

Batch & Shell
gelöst Verlinkung erstellen Batch Datei mit for Schleife (2)

Frage von rusdav zum Thema Batch & Shell ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Server-Hardware
Einem Stromausfall entgegen wirken (22)

Frage von OIOOIOOIOIIOOOIIOIIOIOOO zum Thema Server-Hardware ...

Festplatten, SSD, Raid
PC stellt nach dem Bios ab (20)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...

DSL, VDSL
gelöst Ständige Störungen - Internet (12)

Frage von gamerff zum Thema DSL, VDSL ...