Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit forschleife bei pfaden mit leerzeichen

Frage Entwicklung Batch & Shell

Mitglied: didie08

didie08 (Level 1) - Jetzt verbinden

26.05.2010 um 10:23 Uhr, 5427 Aufrufe, 2 Kommentare

Hallo

Ich habe ein Problem mit Pfaden die Leerzeichen beinhalten.

Ich will mit einer for schleife eine Liste abarbeiten, die sich auf einem Pfad mit leerzeichen befindet. Leider wird die liste nicht richtig erkannt.
01.
for /f "tokens=* delims= " %%l in (K:\wkh\01300000\01345201_dc_w211_einlm_han\cam neu3\prt-liste.txt) do ( 
02.
	echo %%l>>d:\temp\test.txt 
03.
04.
pause
Den Pfad in "" zu setzen hilft leider auch nicht.
Was muss ich tun damit meine Liste ordnungsgemäß abgearbeitet wird?


Gruß
didie08
Mitglied: LotPings
26.05.2010 um 11:22 Uhr
Hallo didie08,

versuche mal
01.
for /f "usebackq tokens=*" %%l in ("K:\wkh\01300000\01345201_dc_w211_einlm_han\cam neu3\prt-liste.txt") do ( 
02.
	echo %%l>>d:\temp\test.txt 
03.
04.
pause
Das Leerzeichen ist einStandard delims , das brauchst du nicht setzen.

Gruß
LotPings
Bitte warten ..
Mitglied: didie08
26.05.2010 um 11:45 Uhr
Hallo LotPings,

Danke. So gehts.

Gruß
didie08
Bitte warten ..
Ähnliche Inhalte
Rechtliche Fragen
gelöst Microsoftkonto wurde gehackt - Liegt das Problem direkt bei Microsoft? (6)

Frage von Stefan007 zum Thema Rechtliche Fragen ...

Python
Problem mit Python und imaplib2

Frage von meinsm zum Thema Python ...

Windows 7
gelöst Windows 7 Umzug zum neuen PC (SATA-Problem) (7)

Frage von MaxMoritz6 zum Thema Windows 7 ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (12)

Frage von planetIT2016 zum Thema Windows Server ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...

Netzwerkgrundlagen
gelöst Cisco SG500 Series LAG hat sich von selbst umgestellt (11)

Frage von Ex0r2k16 zum Thema Netzwerkgrundlagen ...