Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit %HOMEPATH%-Variable bei Netlogon

Frage Microsoft Windows Server

Mitglied: ITLogger

ITLogger (Level 1) - Jetzt verbinden

07.09.2006, aktualisiert 20:46 Uhr, 10076 Aufrufe, 5 Kommentare

%HOMEPATH% ist unterschiedlich

Hallo,

ich muss auf den Desktops aller unserer Benutzer eine Verknüpfung zu einer Datei erstellen, bzw.
dafür sorgen, dass diese auch bei neuen Benutzern automatisch erstellt wird.

Ich habe hierfür im Netlogon-Script einen einfachen Kopierbefehl angefügt, der die entsprechende Verknüpfung
auf den Desktop des jeweiligen Users kopiert.
Als Zielpfad habe ich "%HOMEDRIVE%%HOMEPATH%\Desktop" angegeben. Und das funktioniert auch problemlos.

Bei allen Rechnern, bis auf drei, liefert die HOMEPATH-Variable "Dokumente und Einstellungen\<Benutzername>"
zurück. Nur bei diesen drei Rechnern liefert sie lediglich "\" zurück.

Frage:
Im Grunde sollten alle Rechner gleich konfiguriert sein. Alle besagten Rechner haben Win2000 SP4, allerdings
funktionieren andere 2000er Rechner problemlos.
Woran liegt es, dass bei diesen drei Rechnern die HOMEPATH Variable falsch ist.

Wo kann ich die HOMEPATH-Variable auf "Dokumente und Einstellungen\%USERNAME%" festsetzen?

Danke im Voraus!

MfG
Mailer
Mitglied: Dani
07.09.2006 um 09:36 Uhr
Guten Morgen,

einfach so:
01.
set homepath = "Dokumente und Einstellungen\%USERNAME%"
Gruß
Daniel
PS: Thread schließen
Geschlossen wird der Thread über den Button "Editieren" ganz oben. Einfach dort dann den letzten Haken setzen und "speichern" drücken.
Bitte warten ..
Mitglied: ITLogger
07.09.2006 um 10:08 Uhr
ERLEDIGT: DANKE
Bitte warten ..
Mitglied: Guenni
07.09.2006 um 19:56 Uhr
@Dani

Hi,

wieso forderst du neuerdings bei deinen Postings die User auf,
den Thread zu schließen?

Schließlich sollte jeder, auch nach Wochen, wenn er diesen Thread liest, noch etwas
hinzufügen können.

Wenn, dann fordere die User auf, den Thread als gelöst zu markieren.

Dann können andere auch noch einen Kommentar hinzufügen.

Gelöst heißt ja schließlich nicht, dass das der Weisheit letzter Schluß ist, oder???

Gruß
Günni
Bitte warten ..
Mitglied: Biber
07.09.2006 um 20:46 Uhr
@Günni
...schliesslich sind wir alle bei gelösten Fragen viel gelöster als bei geschlossenen...
Bitte warten ..
Mitglied: CptSplint
03.08.2009 um 10:34 Uhr
Hi,

ich such wegen dem Thema auch gerade. Bei uns ist seit einiger Zeit die Variable %Homepath% auf "\" gesetzt. Davor war sie auf "\Documents and Settings\Username"

Das verursacht bei Applikationen, welche sich auf den 'alten' Eintrag bezogen, natürlich Störungen.

Bisher bin ich soweit dass es an der verwendeten GINA (Graphical Identification and Authentication) liegt. Sofern ich die Microsoft GINA verwende bleibt alles normal. Mit der NWGINA von Novell jedoch wird seit einiger Zeit dieser Homepath verworfen. Nur benutzen wir seit Jahren die NWGINA. Was hat sich also geändert?

--> Die Ursache an sich hab ich noch nicht heraus, aber ich schreibe dies als Kommentar falls jemand anderes auch am suchen ist.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Dateinamen mit Batch-Datei ändern - Problem (9)

Frage von fffffuuuuuuuhhhh zum Thema Batch & Shell ...

Batch & Shell
Domainübergreifendes netlogon script ausführen (7)

Frage von Lukas4580 zum Thema Batch & Shell ...

Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Windows Server
Problem mit Webdav und Webserver IIS (3)

Frage von JUJUS31 zum Thema Windows Server ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(2)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(4)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows 7
gelöst Lokales Adminprofil defekt (25)

Frage von Yannosch zum Thema Windows 7 ...

LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...