Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit IIS 6.0 und verschiedenen Domains / Php

Frage Internet Server

Mitglied: bkimme

bkimme (Level 1) - Jetzt verbinden

20.06.2006, aktualisiert 13:04 Uhr, 4499 Aufrufe, 5 Kommentare

über IP Erriechbar, aber nicht über Domain

Hallo zusammen,

ich habe den IIS Win 2k3 Server laufen und habe folgendes Problem.

Ich habe im Ordner Inetpub\wwwroot für jede Website einen Ordner angelegt.

z.B. Web 1, Web 2, etc.

Im IIS-Manager habe ich über Hostheader die Verzeichnisse zugewiesen.

Jetzt möchte ich bei Web 1 ein Phpbb Forum installieren und da liegt das
Problem.

Gebe ich im Explorer die IP mit samt dem Unterverzeichnis, also bsp.
http://xx.xx.xx.xx/web1/phpbb/install.php an, dann klappt es, gebe ich aber
die Domain an z.B. http://www.fritzmueller.de/web1/phpbb/install.php dann
bekomme ich einen 404er HTTP Error, daß die Datei nicht gefunden wurde.

Das witzige daran ist, wenn ich eine Testdatei nur mit dem Phpinfo mache und
in den Pfad lege, dann zeigt er mir die an. Also z.b. http://www.fritzmueller.de/test.php in der steht dann aber wirklich nur das phpinfo()

Jemand einen Vorschlag, woran das liegen kann?

Vielen Dank im Voraus für jeden Tip!
Mitglied: 16568
20.06.2006 um 13:01 Uhr
Mal eine ganz doofe Frage:

Ist das ein w2k3 Server oder ein SBS?


Lonesome Walker
Bitte warten ..
Mitglied: bkimme
20.06.2006 um 13:04 Uhr
w2k3 Server
Bitte warten ..
Mitglied: Madjoo
16.03.2009 um 10:21 Uhr
Hi,

hat jemand 'ne Lösung für dieses Problem gefunden? Ich hab gerade das gleiche Phänomen.


Grüße, Marco
Bitte warten ..
Mitglied: 16568
16.03.2009 um 14:18 Uhr
Man kombiniere mal kurz:

http://xx.xx.xx.xx/web1/phpbb/install.php liegt in web1.
Dann kann http://www.fritzmueller.de/web1/phpbb/install.php wohl nur zu einem 404-Fehler führen, da das web1 in der URL zuviel ist.

Den Beweis dazu erbringt ja http://www.fritzmueller.de/test.php mit Erfolg.

Also einfach mal probieren, ob die Zuweisung des Ordners richtig ist...


Lonesome Walker
Bitte warten ..
Mitglied: Madjoo
16.03.2009 um 14:22 Uhr
Schon klar, dass web1 zu viel ist.

Beispiel von mir:
Über IP funktioniert's: http://212.227.88.21/sabine-hellwig.de/phpinfo.php
Über Domain funktioniert's net: http://www.sabine-hellwig.de/phpinfo.php

Im Übrigen ist's ein Virtual Private Server von 1und1 mit dem Betriebssystem Windows Server 2003 Standard 64 bit.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
CMS
PHP - WordPress auf Apache schneller als auf IIS? (13)

Frage von Rene1976 zum Thema CMS ...

Informationsdienste
PHP-IIS 8 Websitefehler (2)

Frage von Blaccky zum Thema Informationsdienste ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...