Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit der Integration Win2008 Server in Win2000 Domäne

Frage Microsoft Windows Server

Mitglied: JanBo85

JanBo85 (Level 1) - Jetzt verbinden

14.09.2010, aktualisiert 15.09.2010, 3570 Aufrufe, 4 Kommentare

Hallo Community,

ich habe trotz einiger Nachforschung in der MS Knowledge Base und diversen Foren ein großes Problem bei der Integration eines Windows 2008 R2 64bit Servers in eine Windows2000 Domäne.

Erstmal zu den Gegebenheiten:
Wir betreiben eine Win2000 Domäne mit nur einem DC. Wir wollen so langsam aber sicher auf den neuen Stand kommen und Richtung win2008 wechseln.
Der DC ist im Moment noch physikalisch angesiedelt, besteht aber zu Testzwecken auch in der ESX-Umgebung als virtuelle Maschine.

Wir wollen versuchen, unseren Win2k8R2 entweder Schritt für Schritt oder in einem Schwung zum PDC(entschuldigt den alten Ausdruck) zu machen.

So kommen wir nun zum eigentlichen Problem.

Ich habe mehrfach versucht, auf dem Windows2000 Server(SP4) ein adprep /forestprep auszuführen. Sowohl das adprep von Win2003 als auch das adprep der beiden Releases von Win2008.
Der Virenscanner ist bereits abgeschaltet.
Trotzdem bekomme ich im Logfile vom adprep bei jedem Versuch folgenden Fehler:

Auszug aus der \winnt\debug\adpreps\logs...
Updating change from:"注音顯示名稱" to "注音標示顯示名稱" for locale 404, object inetOrgPerson-Display and property attributeDisplayNames.
[2010/09/14:10:19:57.155]
Adprep konnte wegen eines Fehlers der Rückruffunktion nicht abgeschlossen werden.
[Status/Folgen]
Fehlermeldung: Beim Binden zum Objekt mSMQSiteLink-Display unter Verwendung von Pfad LDAP://myServer.myDomain.local/CN=mSMQSiteLink-Display,CN=804,CN=DisplaySpecifiers,CN=Configuration,DC=myDomain,DC=local ist ein Fehler aufgetreten. Es ist ein Fehler bei der Ausführung
aufgetreten.
(0x80072020).
[Benutzeraktion]
Weitere Informationen finden Sie in der Protokolldatei "ADPrep.log" im Verzeichnis "C:\WINNT\debug\adprep\logs\20100914101853".
[2010/09/14:10:19:57.201]
Adprep konnte die Gesamtstrukturinformationen nicht aktualisieren.
[Status/Folgen]
Adprep benötigt Zugriff auf die vorhandenen gesamtstrukturweiten Informationen vom Schemamaster, um diesen Vorgang abzuschließen.
[Benutzeraktion]
Weitere Informationen finden Sie in der Protokolldatei "ADPrep.log" im Verzeichnis "C:\WINNT\debug\adprep\logs\20100914101853".

Ich hoffe hier jemanden zu finden, der noch kreative Ideen(oder den Fehler schon mal gesehen) hat.
Ich würde mich über jede Hilfe sehr freuen. Vielen Dank

MfG
Jan
Mitglied: napperman
14.09.2010 um 14:15 Uhr
Moin Jan,

Ich habe mich da mit hilfe dieser Seiten durch die gleiche Problematik gehangelt. Bei mir hat so funktioniert:
http://blog.dikmenoglu.de/PermaLink,guid,58a3c79f-f34e-4635-bc5f-0bfc67 ...
Bitte warten ..
Mitglied: JanBo85
14.09.2010 um 15:48 Uhr
Hey,

danke für die schnelle Antwort. Leider wird in Yussufs Blog immer davon ausgegangen, dass der forestprep funktioniert, aber genau das ist ja unser Problem ;)

Wenn mein adprep abbricht ist folgendes passiert:

Der Registrykey steht auf "47" und auch die Datei sch47.ldf liegt im win32-Ordner.

Wenn ich mit dem ADSI Editor in die Konfiguration gucke, wurde allerdings kein Objekt CN=ActiveDirectoryUpdate,CN=ForestUpdates,CN=Configuration,DC=<ForestRootDomäne> erstellt und somit auch kein Attribut "Revision".

Mfg Jan
Bitte warten ..
Mitglied: Yusuf-Dikmenoglu
14.09.2010 um 16:50 Uhr
Servus,

Adprep konnte wegen eines Fehlers der Rückruffunktion nicht abgeschlossen werden.

wenn diese Fehlermeldung erscheint, ist bisher nur der Virenscanner als Verursacher bekannt.

[LDAP://Yusufs.Directory.Blog/ - Hinweise zu ADPREP]
http://blog.dikmenoglu.de/Hinweise+Zu+ADPREP.aspx

Bei manchen Virenscannern genügt das alleinge deaktivieren nicht(!). Daher solltest du den Virenscanner sicherheitshalber deinstalllieren und anschließend den Server neu starten.
Danach führe ADPREP erneut aus.

Funktioniert es dann?


Viele Grüße

/ > Yusuf Dikmenoglu
Bitte warten ..
Mitglied: JanBo85
15.09.2010 um 08:50 Uhr
Danke für den Tipp.

Wir haben gestern den Trendmicro ServerScan erst deaktiviert mit gleichem Ergebnis und dann komplett deinstalliert.

Leider bleibt der forestprep immernoch an der gleichen Stelle hängen. Wir haben den Server auch mehrfach neugestartet.

Mfg Jan


Edit:
Nach weiteren Tests hat sich ergeben, dass die Datenbank beschädigt ist. Das ist das Ergebnis vom Versuch einen 2. Win2000 Server zum DC zu machen.

Bestätigt ist die Beschädigung durch ntdsutil-Prüfungen
Bitte warten ..
Ähnliche Inhalte
Netzwerkmanagement
Problem mit DLNA Server in DMZ (4)

Frage von haye81 zum Thema Netzwerkmanagement ...

Windows Server
Problem mit Windows Server 2012 R2 (MSConfig - Systemstart Modus) (3)

Frage von FloFMS zum Thema Windows Server ...

Windows Netzwerk
gelöst Server 2012 Domäne mit Telekom IP, Clients spinnen (manchmal) (2)

Frage von smeclnt zum Thema Windows Netzwerk ...

Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows 7
gelöst BOOTMGR is missing (auch nach bootrec -RebuildBcd) (21)

Frage von Mipronimo zum Thema Windows 7 ...

Router & Routing
Tipps für Router (ca. 100 clients, VPN) (20)

Frage von oel-auge zum Thema Router & Routing ...

Windows Userverwaltung
Windows Freigabe: Zugriff auf alle Ordner trotz Sicherheitseinstellungen (18)

Frage von Pandreas zum Thema Windows Userverwaltung ...

Exchange Server
gelöst MS Exchange 2016 - Basicconfig Fragen (16)

Frage von maddig zum Thema Exchange Server ...