Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Link in Access-Datenbank

Frage Microsoft Microsoft Office

Mitglied: n4426

n4426 (Level 2) - Jetzt verbinden

22.01.2005, aktualisiert 06.04.2005, 18701 Aufrufe, 16 Kommentare

Betriebssystem 2000 Prof. und XP Prof.
Office XP und 2003
Adobe Acrobat Reader 7.0

Hallo,

ich habe in meiner Access-Datenbank links zu PDF-Dokumenten. Wenn ich auf den Link klicke öffnet sich der Acrobat Reader und schließt sich sofort wieder.

Habe auch einige Links neu erstellt, hat aber auch nicht funktioniert.


Weis einer von euch woran das liegen kann?

Mit freundlichen Grüßen

n4426

edit 06.04.2005

Problemlösung siehe unten.
http://www.administrator.de/Problem_mit_Link_in_Access-Datenbank.html#3 ...
Mitglied: planula
24.01.2005 um 12:51 Uhr
hey
versuch es mal mit einem acrobat update damit müsste das problem gelöst sein

Gruß
Bitte warten ..
Mitglied: n4426
24.01.2005 um 17:34 Uhr
Hallo,

habe den Acrobat Reader gestartet und dann über Hilfe -> Updates suchen nach Updates suchen lassen. Dabei hat er mir nur volgendes Update angezeigt, das ich dann auch Installiert habe, was aber nichts gebracht hat.

- Adobe(R) Photoshop(R) Album 2.0 Starter Edition

Hat da noch einer eine Idee?

Mit freundlichen Grüßen

n4426
Bitte warten ..
Mitglied: planula
25.01.2005 um 08:42 Uhr
welche Access Version benutzt du??
Bitte warten ..
Mitglied: planula
25.01.2005 um 08:46 Uhr
Was hast du denn genau in der Datenbank abgespeichert?
Den kompletten Pfad oder was?

Wie sieht den dein Code aus, mit dem du das PDF-File aufrufst?

Ein bischen mehr an Info´s würde einen Lösungsansatz sicherlich
beschleunigen.

Gruß
Bitte warten ..
Mitglied: n4426
25.01.2005 um 16:21 Uhr
Ich verwende Access XP und 2003 (funktioniert bei beiden nicht).

also in der Access-Datenbank ist der Komplette Pfad abespeichert
(z.B. "\\Server\Freigabe\Unterordner\Daten\00001-~1.pdf" habs auch so "\\Server\Freigabe\Unterordner\Daten\00001 - Beispieltext.pdf" probiert). Ich habs auch versucht über einen Laufwerksbuchstaben (z.B. "P:\Unterordner\Daten\00001 - Beispieltext.pdf").

Mit freundlichen Grüßen

n4426
Bitte warten ..
Mitglied: SEAG
25.01.2005 um 18:08 Uhr
Hallo

Leider habe ich auch keine Lösung für dieses Problem. Ich stehe nämlich genau vor dem selben.
Bisher funktionierte alles einwandfrei (Access2000 oder Access2003 mit Adobe Reader 5 oder 6).
Erst seit dem Update auf Adobe Reader 7 tritt dieser Fehler auf. Es öffnet und schliesst sofort wieder....?

Wäre auf jeden Fall auch sehr dankbar für einen guten Tipp zum lösen dieses Problems.

Gruss
SEAG
Bitte warten ..
Mitglied: planula
27.01.2005 um 13:45 Uhr
Wie rufst du den Link auf?? in einem Formular? wenn ja wie sieht der Code dazu aus..??
Bitte warten ..
Mitglied: SEAG
27.01.2005 um 14:39 Uhr
Mein Link sieht etwa wie folgt aus (VBA mit Access2000):

Application.FollowHyperlink "\\server\freigabe\datei.pdf"
oder
Application.FollowHyperlink "f:\ordner\datei.pdf"
Bitte warten ..
Mitglied: planula
27.01.2005 um 15:31 Uhr
probier mal folgendes aus:
Application.FollowHyperlink "\\server\freigabe\datei.pdf", , True, False
Bitte warten ..
Mitglied: SEAG
27.01.2005 um 16:28 Uhr
Hat leider auch nichts genützt.

Aber trotzdem vielen Dank für den Tipp!
Bitte warten ..
Mitglied: Isserstedt
27.01.2005 um 18:08 Uhr
Hallo,

ich habe das gleiche Problem.

Deinstallation vom Reader 7.0 und Installation von 6.0 und alles funktioniert wieder.

Problem liegt also beim der Version 7.0 (was aber auch nicht weiterhilft)

Für eine Lösung des Problems wäre ich danbar.

Gruss

Thorsten
Bitte warten ..
Mitglied: n4426
28.01.2005 um 22:46 Uhr
aber das kann doch eigentlich auch keine lösung sein, wieder die vorgängerversion zu Benutzen.

Mit freundlichen Grüßen

n4426
Bitte warten ..
Mitglied: planula
31.01.2005 um 07:30 Uhr
so nach langem probieren habe ich euch mal eine lösung geschustert..

diesen Code einfügen:

Private Declare Function ShellExecute Lib "shell32.dll" Alias "ShellExecuteA" (ByVal hwnd As Long, _
ByVal lpOperation As String, ByVal lpFile As String, ByVal lpParameters As String, ByVal lpDirectory As String, _
ByVal lpnShowCmd As Long) As Long

ShellExecute 0, "open", "c:\bericht.pdf", "", "", 1


wieso das jetzt bei version 7 nicht mehr mit application.follow geht bleibt mir ein rätsel habe auch bei acrobat nichts dazu gefunden was sich geändert hat.. sagt mal bescheid ob es funktioniert.

Gruß
Bitte warten ..
Mitglied: SEAG
31.01.2005 um 10:56 Uhr
Super!

Mit deinem Code funktioniert nun auch Adobe Reader 7.0 einwandfrei!

Vielen Dank!

Grüsse
SEAG
Bitte warten ..
Mitglied: n4426
31.01.2005 um 18:21 Uhr
Hallo Planula,

wie muss ich den Code in Acces einfügen?

- Befehlsschaltfläche
- ...

Mit freundlichen Grüßen

n4426
Bitte warten ..
Mitglied: n4426
06.04.2005 um 19:08 Uhr
Hallo Zusammen,

mit dem Momentan erhältlichen update von Adobe funktionierts jetzt (Hilfe -> Jetzt nach updates suchen).

Danke an alle, die sich mit meinem Problem beschäftigt haben.

Mit freundlichen Grüßen

n4426
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
SAN, NAS, DAS
gelöst Access Datenbank auf einer (Synology) NAS? (4)

Frage von garack zum Thema SAN, NAS, DAS ...

Datenbanken
Access Datenbank mit Rechnungen und Summenbildung möglich? (1)

Frage von Stefan007 zum Thema Datenbanken ...

Microsoft Office
Access Problem beim Bericht erstellen (1)

Frage von terpeberi zum Thema Microsoft Office ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...