Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Loginscript unter Vista

Frage Entwicklung Batch & Shell

Mitglied: TuXHunt3R

TuXHunt3R (Level 3) - Jetzt verbinden

05.10.2007, aktualisiert 18.10.2012, 4836 Aufrufe, 4 Kommentare

Hallo ans Forum

Ich habe ein Problem mit meinem Loginscript (Batch) in meiner Heimdomäne.

Immer wenn ich mich an meinem Vista-Client einlogge, bleibt das Loginscript stehen und bringt mir folgende Meldung beim Löschen des Laufwerks P (Befehl: net use P: /delete):

01.
There are open files and/or incomplete directory searches pending on the connection to P:. 
02.
 
03.
Is it OK to continue disconnecting and force them closed? (Y/N) [N]: y
Dieses Phänomen tritt nur auf meinem Vista-Client auf (Vista Business), bei einem Login an einem 2003 Enterprise Server SP2 oder an den XP Pro SP2 Clients tritt das Phänomen nicht auf. Ich habe auch schon das Loginscript stehen lassen und remote per Computerverwaltung geschaut, ob irgendwo auf dem Server offene Dateien in meinem P-Laufwerk sind. Das komische daran ist ja, dass zu diesem Zeitpunkt keine der Dateien im entsprechenden Ordner geöffnet ist. Hat irgendjemand dafür eine Erklärung?

Domäne enthält 3 XP Clients, einen Vista Business Client sowie zwei Server, die mit Windows 2003 Enterprise Edition laufen. Der eine Server übernimmt die Aufgaben des Domänencontrollers, des DNS-Servers, des DHCP-Servers, des Fileservers sowie des Intranet-Webservers (IIS 6.0). Auf diesem Server läuft ein zweiter Server mit Virtual PC 2007. Auf diesem läuft ein Apache 2 Webserver (XAMPP).

Das Loginscript sieht im Prinzip so aus (Beispiel):

01.
::Alle möglichen Laufwerke trennen 
02.
if exist G: ( 
03.
net use G: /delete 
04.
05.
::usw (alle Buchstaben von G: bis Z:) 
06.
 
07.
:: User auswählen 
08.
if "%username"=="suppenkasper" goto suppenkasper 
09.
::usw, alle 5 User sind hier aufgelistet 
10.
 
11.
:suppenkasper 
12.
net use G: \\server\share$ 
13.
::usw. Die jeweiligen Laufwerke werden pro User verbunden.
Das P-Laufwerk ist übrigens das Persönliche Laufwerk (Homeshare) jedes Users (\\server\%username%$)


Also, hat jemand eine Ahnung, wieso das Script unter Vista zickt?
Mitglied: 51705
05.10.2007 um 21:04 Uhr
Hast du Ordner-Umleitungen definiert?
Bitte warten ..
Mitglied: TuXHunt3R
05.10.2007 um 22:12 Uhr
Nicht dass ich wüsste....
Was genau meinst du mit Ordnerumleitungen?

Edit: Ist das irgendeine versteckte Funktion von Vista, die ich vergessen habe zu deaktivieren?
Bitte warten ..
Mitglied: TuXHunt3R
07.10.2007 um 23:17 Uhr
Zwischenstand:

Mir ist in den Sinn gekommen, dass mein Wallpaper ja auf meinem P-Laufwerk liegt, d.h. auf dem dem hier betroffenen Laufwerk. Ich habe also das Wallpaper weggenommen und ein Standard-Wallpaper von Windows verwendet. Beim erneuten Login kam die Fehlermeldung aber trotzdem wieder, an dem kann es also nicht liegen. Wisst ihr noch was?
Bitte warten ..
Mitglied: TuXHunt3R
01.11.2007, aktualisiert 18.10.2012
Habe das Disconnecten der Netzlaufwerke nun anders gelöst. Statt mit "if exist" zu überprüfen, ob das Laufwerk existiert und es dann zu disconnecten, habe ich folgendes gemacht:

Am Anfang des Scripts steht folgender Befehl:
01.
net use * /d /y
Mit dem * werden einfach alle Netzlaufwerke ausgewählt, mit /d werden diese gelöscht und mit /y werden eventuelle Meldungen mit "Yes" bestätigt!

Bis jetzt habe ich keine Probleme mehr gehabt. Ich betrachte daher den Beitrag als gelöst!


Danke an bastla für den Tipp im Beitrag
http://www.administrator.de/forum/anmelde-bzw-abmeldescripts-%c3%bcbers ...
Bitte warten ..
Ähnliche Inhalte
Windows Update
gelöst SUSID im Loginscript (1)

Frage von Sprudi zum Thema Windows Update ...

Windows Vista
Support-Ende erreicht: Tschüss Vista (4)

Link von sabines zum Thema Windows Vista ...

Windows Vista
gelöst Woher bekomme ich noch ein Win Vista Image? (5)

Frage von cramtroni zum Thema Windows Vista ...

Windows Vista
gelöst Vista Home Premium nur Basic Key (8)

Frage von Chonta zum Thema Windows Vista ...

Neue Wissensbeiträge
Viren und Trojaner

Neues Botnetz über IoT-Geräte

Information von certifiedit.net zum Thema Viren und Trojaner ...

Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Externe IP von innen erreichbar machen (15)

Frage von Windows10Gegner zum Thema Router & Routing ...

Windows Installation
Windows 10 neu installieren (12)

Frage von imebro zum Thema Windows Installation ...

Windows Server
Frage zu Server Rack (11)

Frage von rainergugus zum Thema Windows Server ...