Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit einem Macro

Frage Entwicklung VB for Applications

Mitglied: Konne01

Konne01 (Level 1) - Jetzt verbinden

27.02.2009, aktualisiert 13:05 Uhr, 2826 Aufrufe, 3 Kommentare

Hallo zusammen

Mein Problem ist das ich aus einer Zelle z.B. 063/02/04 drei neue Zellen machen möchte 063 02 04

So das Macro was ich bei euch gefunden habe macht dies ja schon fast perfekt.

Leider löscht es mir in den Zielzellen die Nullen so das das Ergebniss z.B so aussieht

063/02/04 63 2 4
Quelle Ziel

Kann man das Macro so ändern das auch die Nullen mit kopiert werden.

Sub Aufteilen()
Range("J:J").Select
Selection.Replace What:=Chr(10), Replacement:="/", LookAt:=xlPart, SearchOrder:=xlByRows
Selection.TextToColumns Destination:=Range("l1"), DataType:=xlDelimited, _
TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Other:=True, OtherChar:="/"
Cells.EntireRow.AutoFit
Range("l1").Select
End Sub

Schon mal im voraus vielen Dank für eure Hilfe

Mfg.

Konrad

Ps. Sollte ich irgent etwas falsch gemacht haben, bitte ich um entschuldigung, aber es ist das erstemal das ich in einem Forum einen Beitrag schreiben.
Mitglied: NetWolf
27.02.2009 um 13:30 Uhr
Hallo Konrad,

du wandelst Text in Zahlen. Bei Zahlen gibt es keine führenden Nullen!!


Grüße aus Schönberg (Lübeck)
Wolfgang
(Netwolf)
Bitte warten ..
Mitglied: bastla
27.02.2009 um 14:58 Uhr
Hallo Konne01!

Je nachdem, was Du als Ergebnis benötigst (Text oder Zahl), kannst Du entweder die Zeilen vor
Cells.EntireRow.AutoFit
durch
01.
Selection.TextToColumns Destination:=Range("I1"), DataType:=xlDelimited, _ 
02.
TextQualifier:=xlDoubleQuote, ConsecutiveDelimiter:=False, Other:=True, OtherChar:= "/", _ FieldInfo:=Array(Array(1, 2), Array(2, 2), Array(3, 2))
ersetzen - dann wird beim Zerlegen das Textformat für die 3 Ergebnisspalten festgelegt, oder Du fügst an der genannten Stelle diese beiden Zeilen
01.
Columns("I:I").NumberFormat = "000" 
02.
Columns("J:K").NumberFormat = "00"
ein, um das Zahlenformat der Ergebnisspalten so anzupassen, dass die entstandenen Zahlenwerte drei- (bzw zwei-)stellig und mit führender/n Null/en angezeigt werden.

Grüße
bastla

P.S.: Findest Du die Darstellung im "Code"-Format nicht auch besser lesbar?
Bitte warten ..
Mitglied: Konne01
28.02.2009 um 10:13 Uhr
Hallo Bastla

An der Stelle schon mal tausend dank für deine Bemühung, werde es stätestens am Montag testen und dann berichten.

In dem Sinne schönes Wochenende

Gruß Konrad



Hat alles super geklappt. Vielen Dank für deine Hilfe

Gruß Konrad
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
SAN, NAS, DAS
gelöst Synolgy 1815+ - Rechte- und Richtlinien-Problem User-Ordner Home (3)

Frage von Nintox zum Thema SAN, NAS, DAS ...

Peripheriegeräte
Roccat Ryos - Support verzweifelt an Problem mit Profilen

Frage von sascha382 zum Thema Peripheriegeräte ...

Windows Update
gelöst Windows Server 2012 R2 - WSUS Problem (1)

Frage von aladin.inder zum Thema Windows Update ...

Batch & Shell
PowerShell Transkript Problem (5)

Frage von Marabunta zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...