Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Netzwerk und 2 Router

Frage Netzwerke

Mitglied: mygilli

mygilli (Level 1) - Jetzt verbinden

13.02.2011, aktualisiert 18.10.2012, 4641 Aufrufe, 7 Kommentare

Hallo!

Wir haben zwei Netzerwerke (192.168.10.x + 192.168.1.x), mein Rechner hängt im 1er Netzwerk und meine NAS hängt im 10er Netzwerk!
Was muss gemacht werden, damit die Namensauflösung korrekt funktioniert?

Über die IP-Adresse lässt sich alles bestens pingen, aber nicht z.b. der Namen meiner NAS!
(Aber ohne alle Geräte in die C:\WINDOWS\system32\drivers\etc\hosts einzutragen ^^)

Hier die beiden Netzwerke: dec3a954d701414f0ffec26c9f30e0b1 - Klicke auf das Bild, um es zu vergrößern

THX für Hilfe!
Mitglied: colinardo
13.02.2011 um 14:05 Uhr
Dazu brauchst du dann entweder einen WINS oder DNS Server in einem deiner Netzwerke ! Dieser muss dann in der Netzwerkkarten-Konfiguration deines PC's als DNS oder WINS-Server eingetragen sein !
Bitte warten ..
Mitglied: mygilli
13.02.2011 um 14:18 Uhr
Also würde ich mich nicht zum Affen machen, wenn ich einfach noch ein Netzwerkkabel von meinem Router (Cisco) direkt zur NAS legen würde um sie damit direkt in mein Netzwerk zu hängen oder?
(Jetzt könnten zwei Fragen auftreten: 1. Warum steht meine NAS überhaupt im oberen Haus? Wegen Datensicherung und weil sie laut ist 2.Warum stell ich meinen Router nicht ins obere Haus? Wegen W-Lan)
Bitte warten ..
Mitglied: colinardo
13.02.2011 um 14:40 Uhr
Kommt drauf an ob du auf einem Baum sitzt
Klar kannst du ein Kabel legen , aber nur um das NAS mit seinem Namen anzusprechen und nicht über seine IP ist das kein schönes Netzwerken !!
Außerdem stellst du dann einen Netzwerk-Loop her. Das kann unschöne Nebeneffekte wie erhöhten Netzwerkverkehr zur Folge haben.
Bitte warten ..
Mitglied: aqui
13.02.2011, aktualisiert 18.10.2012
Leider ist deine Beschreibung etwas oberflächlich aber versuchen wir uns mal ranzutasten....
Auf dem Cisco sollte folgendes eingestellt sein für dein Netz sofern es keine billige Linksys Kiste ist...
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.120 192.168.1.254
!
ip dhcp pool cisco
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.10.1
domain-name mygilli.test
!

Damit vergibt der Cisco dann erstmal in deinem Netzwerk den korrekten DNS Server fürs Internet, da die D-Link Gurke ja der Proxy DNS in dem Netzwerk ist !
Alernativ kannst du das so auch statisch eintragen wenn du kein DHCP in deinem Segment machst.
Lokale DNS Namen die per UDP Name Service Broadcasts lokal in das .10.0 er Netz gepustet werden kannst du nicht auflösen, da der Cisco ja ein Router ist und UDP Broadcasts nicht forwardet wie das für Router allgemein üblich ist und mittlerweile auch jeder Netzwerk Laie weiss !!
Wenn dein Cisco kein Linksys ist kannst du ihm aber beibringen das er UDPs in dein Netz forwardet.
Dafür gehst du auf das Ethernet Interface was die Verbindung ins .10.0er Netz macht und trägst dort folgendes ein:
!
interface ethernet 1
description Link ins .10.0 /24 Netz
ip address 192.168.10.254 255.255.255.0
ip helper-address 192.168.1.255
!
Dann kommen diese UDP NS Broadcasts auch bei dir an !
Am sichersten gehst du aber wenn du den Namen des NAS lokal statisch in deine Datei lmhosts einträgst. Dann erreichst du es immer über den Namen.
Die Datei findest du unter c:\windows\system32\drivers\etc\
Wie man es genau macht steht hier:
http://www.administrator.de/forum/xp-home-mit-2-kabelgebundenen-und-wla ...
Beide Wege führen zum Erfolg !!

Wenn es doch eine billige Linksys Kiste ist findest du hier eine detailierte Beschreibung was beim Koppeln der Netze zu beachten ist:
http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Ist es ein WRT54G hast du Glück, denn den kannst du mit DD-WRT flashen um ihn vom Zwangs NAT am WAN Port zu befreien ! Es sei denn du musst dich mit einer NAT FW gegen das .10.0er Netz abschotten ?!
Bitte warten ..
Mitglied: mygilli
13.02.2011 um 17:28 Uhr
Hallo!

Erstmals vielen Dank für deine ausführliche Antwort!
Leider besitzte ich wohl so eine billige Linksys Kiste, obwohl so billlig war die auch wieder nicht und klappt eigentlich bis auf diese Funktion ziemlich genial! -> WRT320N

Warum hast du 192.168.10.254 als DNS-Server angegeben?
Ich habe dort die vom D-Link router stehen: 192.168.10.1 ist das falsch? Hier mal meine Settings beider Router:

CISCO:
LAN
Router-IP-Adresse: 192.168.1.1
Subnetzmaske: 255.255.255.0
DHCP-Server
DHCP-Server: Aktiviert
Start-IP-Adresse: 192.168.1.100
End-IP-Adresse: 192.168.1.149
WAN
Verbindungstyp: Automatische Konfiguration - DHCP
Internet-IP-Adresse: 192.168.10.190
Subnetzmaske: 255.255.255.0
Standard-Gateway: 192.168.10.1
DNS1: 192.168.10.1
DNS2:
DNS3:
D-LINK:
LAN
MAC-Adresse : *
IP-Adresse : 192.168.10.1 .
Subnetzmaske : 255.255.255.0 .
Auto IP Address: 0.0.0.0 .
Standardgateway : 0.0.0.0 .
Primärer DNS-Server : 0.0.0.0 .
Sekundärer DNS-Server : 0.0.0.0 .
DHCP-Server : Enabled .
WAN
IP-Adresse : 83.211.
*
Subnetzmaske : 255.255.255.255 .
Standardgateway : 10.10.10.10 .
Primärer DNS-Server : 83.211.*
Sekundärer DNS-Server : 83.211.
*

Bezüglich meinem ursprünglichen Problem werde ich wohl das mit einem 2. Netzwerkkabel lösen
Bitte warten ..
Mitglied: aqui
13.02.2011 um 23:04 Uhr
Ooops sorry du hast natürlich Recht mit der IP. Ein Dreckfuhler...ist korrigiert.
Wie löst man ein DNS Problem mit einem 2ten Kabel ??? Ist eigentlich Blödsinn, den ein NAS hat immer eine statische feste IP Adresse in einem Netz.
Was hindert dich daran das in die lmhost einzutragen ?? Das ist die simpelste und effizienteste Lösung.
Bitte warten ..
Mitglied: mygilli
14.02.2011 um 22:22 Uhr
Danke für den Tipp mit der lmhost!

Das mit dem 2. Netzwerkkabel löst natürlich kein DNS Problem, aber ich kann da meine NAS in (NUR) mein Netzwerkhängen obwohl sie brav im anderen Haus stehen bleibt (wegen Datensicherung örtl Trennung + LÄRM)

Danke für alle Tipps!!!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
W7 TCP NDIS problem - Netzwerk braucht ewig zum vollständigen Start (4)

Frage von spiderx zum Thema Windows Netzwerk ...

Virtualisierung
gelöst VirtualBox offline (ohne Netzwerk bzw. Router) erreichen (5)

Frage von QnavWhat zum Thema Virtualisierung ...

LAN, WAN, Wireless
Habe ein Problem im Heimnetzwerk (2 Router) (11)

Frage von deb10er0 zum Thema LAN, WAN, Wireless ...

Router & Routing
Problem - Router cisco 2821 hinter Fritzbox mit WLAN (23)

Frage von Cyberurmel zum Thema Router & Routing ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...