Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Openvpn

Frage Linux Linux Netzwerk

Mitglied: Luciver1981

Luciver1981 (Level 1) - Jetzt verbinden

26.01.2012, aktualisiert 18.10.2012, 5183 Aufrufe, 9 Kommentare

Hallo Member!
Habe Open VPN auf meinen V-Server mit debian 5 installiert und die configs angepasst.

Das Problem beim Start kommt folgende Fehlermeldung:

Thu Jan 26 10:11:49 2012 OpenVPN 2.1_rc11 x86_64-pc-linux-gnu [SSL] [LZO2] [EPOLL] [PKCS11] built on Sep 18 2008
Thu Jan 26 10:11:49 2012 Diffie-Hellman initialized with 1024 bit key
Thu Jan 26 10:11:49 2012 /usr/bin/openssl-vulnkey -q -b 1024 -m <modulus omitted>
Thu Jan 26 10:11:50 2012 TLS-Auth MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
Thu Jan 26 10:11:50 2012 ROUTE default_gateway=191.255.255.1
Thu Jan 26 10:11:50 2012 Note: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
Thu Jan 26 10:11:50 2012 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
Thu Jan 26 10:11:50 2012 Cannot allocate TUN/TAP dev dynamically
Thu Jan 26 10:11:50 2012 Exiting

Für mich sieht das aus als würde der Standart Gateway nicht passen, lieg ich da richtig.
Mitglied: joergheyne
26.01.2012 um 11:09 Uhr
Hallo,

Wenn man diese Fehlermeldung bekommt, fehlt meistens das tun/tap Modul. Versichern Sie sich, das Sie das Modul geladen, oder einkompiliert haben.

Versichern Sie sich, das Sie die Option CONFIG_TUN (Device Drivers->Network Device Support>Universal TUN/TAP Device Driver Support) auf y oder Module gestellt und gegebenenfalls das Modul geladen haben.

nach google-Suche :
http://www.online-tutorials.net/security/openvpn-tutorial/tutorials-t-6 ...


und hier noch etwas:
Kernelkonfiguration

Zur Verwendung von OpenVPN benöten Sie einen einen Linuxkernel, der den "tun"-Treiber enthält. Die meisten Distributionen liefern bereits einen solchen mit, so dass Sie erst einmal in dieser Reihenfolge überprüfen sollten, ob es vorhanden ist:

Gibt grep tun_net_open /proc/kallsyms eine Zeile aus? Wenn ja, ist das Modul bereits geladen oder fest in den Kernel eincompiliert. Damit wären bereits alle Voraussetzungen erfüllt.
Gibt modprobe tun eine Fehlermeldung aus? Wenn nicht, ist das Modul installiert.
Benutzen Sie ein devfs, und existiert ein Device /dev/net/tun? Wenn ja, ist das Modul installiert.
Steht in Ihrer Kernelkonfigurationsdatei, also meist eine /boot/config* oder /proc/config.gz nach Entpacken, die Zeiile CONFIG_TUN=m oder CONFIG_TUN=y? Wenn ja, ist das Modul installiert.

Hat sich herausgestellt, dass das Modul nicht installiert ist, müssen Sie Ihren Kernel neu kompilieren (was Sie dann höchstwahrscheinlich ohnehin bereits einmal getan haben, denn die fertigen Kernels der bekannten Distributionen enthalten das Modul schon). Bei der Konfiguration (make menuconfig) achten Sie darauf, dass unter Device Drivers/Networking support/Network device support der Treiber Universal TUN/TAP device driver support auf Y oder M steht, denn das ist genau der Treiber, den OpenVPN braucht.





LG Jörg
Bitte warten ..
Mitglied: Luciver1981
26.01.2012 um 11:20 Uhr
Hallo Jörg also müsste ich den Kernel neu kompilieren?

Das Problem bei der Thematik es ist nur ein Virtueller Server bei meinen Hoster und da wird sowas schwierig. Gibts da irgendeine Möglichkeit?
Bitte warten ..
Mitglied: joergheyne
26.01.2012 um 11:25 Uhr
...da hab ich hier noch was zum Thema gefunden:

http://www.webhostingtalk.com/archive/index.php/t-720412.html
Bitte warten ..
Mitglied: aqui
26.01.2012, aktualisiert 18.10.2012
Bitte warten ..
Mitglied: Luciver1981
26.01.2012 um 15:49 Uhr
Danke Server läuft ohne kompilieren

mit welchen Befehl in der server.conf kann ich die Ip des Servers und den Ippool der clients festlegen?
Bitte warten ..
Mitglied: joergheyne
26.01.2012 um 16:44 Uhr
wende dich bitte an den Support deines Hosters, auf das er die TUN/TAP freischaltet.
Die Fehlermeldung besagt doch, das genau dieser Dienst nicht erreichbar bzw, zur Verfügung steht-

LG Jörg
Bitte warten ..
Mitglied: Luciver1981
26.01.2012 um 17:02 Uhr
Lösung des Problems bin ich noch schuldig.

mkdir -p /dev/net
mknod /dev/net/tun c 10 200
chmod 600 /dev/net/tun

Danke Jörg für den Link.
Bitte warten ..
Mitglied: aqui
26.01.2012, aktualisiert 18.10.2012
In der Server.conf legt "server 172.16.2.0 255.255.255.0" (IP hier ist nur Beispiel) das interne Netzwerk und damit auch den IP Pool für die Clients fest.
Steht auch so im obigen Tutorial....wenn man es denn mal lesen würde
Zur Wahl der IPs sollte man keine 192.168er Allwerwelts IPs verwenden. Es gilt das hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Bitte warten ..
Mitglied: Luciver1981
26.01.2012 um 18:56 Uhr
Ok das mit dem Ippool ist jetzt klar aber die clients sehen sich nicht?
Obwohl Client to Client aktiv ist, wir d wohl ein routing problem sein.
Mein VPN-Server hängt direkt am Netz und die clients hängen zum Teil hinter Routern manche verbinden sich aber auch über UMTS Sticks.
Welche Routen muss ich einrichten.
Der Server 10.8.0.0 255.255.255.0
Client 01 hat 10.8.0.4
Client 02 hat 10.8.0.8
usw.

@aqui dein tuto ist gut, mein Problem ich hab keine gui muss also alles zu fuß machen.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows 10
Problem: einzige Konto gesperrt + Bitlocker aktiv (11)

Frage von Windows11 zum Thema Windows 10 ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Multimedia & Zubehör
gelöst BENQ Beamer Fernbedingung Frequenz Problem (4)

Frage von xbast1x zum Thema Multimedia & Zubehör ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...