Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit pif und bat

Frage Entwicklung Batch & Shell

Mitglied: Haegar75

Haegar75 (Level 1) - Jetzt verbinden

07.12.2008, aktualisiert 08.12.2008, 3295 Aufrufe, 5 Kommentare

Hallo Leute,
ich bräuchte wiedermal Hilfe beim batchen
Ich möchte 186er Assemblerprogramme linken. Dazu benutze ich bisher Batchdateien die über pifs aufgerufen werden.

Die Batch sieht z.B. so aus:
set progname=XXX12345
LINK86 & <%progname%.con
pause

Der direkte Aufruf der Batch klappt nicht, nur wenn es über die entsprechnde Pif aufgerufen wird..
Warum ist das so? Wie erstelle ich überhaupt eine Pif? Die Angaben darüber im Hilfecenter helfen gar net..
Wie könnte es ohne Pif gehen?

Gruß Haegar

Edit: Ich habe mal versucht die _default.pif im Windows-Verzeichnis so einzustellen wie die pif die den Batch startet, aber der Batch läuft trotzdem nicht..
Mitglied: miniversum
07.12.2008 um 20:09 Uhr
Könnte was mit der Kompatibilität zu tun haben. Hast Du mal geschaut was ind er pif eingestellt ist? Kannst ja mal versuchen der Batch direkt in den Eigenschalten beim Kompatibilitätsmodus was zu machen.
Bitte warten ..
Mitglied: Haegar75
07.12.2008 um 20:25 Uhr
In der Pif ist nichts bzgl Kompatibilität eingestellt. Bei der Batch hab ich sämtliche Modi ausprobiert,aber geht net..
Bitte warten ..
Mitglied: miniversum
07.12.2008 um 21:01 Uhr
Was sit den dann eingestellt? Ein Arbeitsverzeichnis oder sowas?
Ohne zu wissen was dort eingestellt ist oder warum es die pif gibt ist es halt ein bischen schwer in der batch was zu ändern
Bitte warten ..
Mitglied: Haegar75
07.12.2008 um 21:15 Uhr
-Program:Unter Befehlszeile steht der Pfad auf die Batch,Kein Arbeitsverzeichnis, Unter Erweitert: %SystemRoot%\SYSTEM32\AUTOEXEC.NT und
%SystemRoot%\SYSTEM32\CONFIG.NT

-Speicher:alles auf "automatisch", verwende HMA
-unter Sonstiges ist alles ausgewählt ausser "exklusiver Modus" und "immer aussetzen"
-Kompatibilität: alles deaktiviert
Bitte warten ..
Mitglied: Haegar75
08.12.2008 um 10:47 Uhr
Hab noch was herausgefunden..
Laut einiger Funde in Google, sollte jede Batch die Einstellungen der _default.pif aus dem Windir benutzen.. Daraufhin hatte ich die _default.pif entsprechend angepasst, aber das half auch nicht. Jetzt hab ich mir die _default.pif mal in mein Verzeichnis kopiert und auf die Batch verweisen lassen. Das hat funktioniert. Ist mein System evtl so eingestellt, dass es eben nicht nach dieser _default.pif guckt? Hatte mal eine sehr große Schriftart ausgewählt, die aber in keiner Batch zu sehen war...
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
gelöst SG300-10 Layer 2 VLAN Problem (4)

Frage von chulio zum Thema Netzwerkgrundlagen ...

E-Mail
Problem mit Spam-Mail (6)

Frage von huberd zum Thema E-Mail ...

Hosting & Housing
Problem mit: Reverse DNS Resolution - PTR Record (2)

Frage von Krabbat zum Thema Hosting & Housing ...

Batch & Shell
gelöst FTP und bach script I Problem von nicht komplett geladener Files (9)

Frage von drscoop zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(5)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(38)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
POS Hardware und alternativen zu Raid 1? (21)

Frage von Brotkasten zum Thema Festplatten, SSD, Raid ...

Viren und Trojaner
Verschlüsselungstrojaner simulieren (18)

Frage von AlbertMinrich zum Thema Viren und Trojaner ...

Windows 10
Windows 10 Home "Netzlaufwerk nicht bereit" (13)

Frage von Oggy01 zum Thema Windows 10 ...

Exchange Server
Exchange Postfach leeren - nicht löschen (10)

Frage von AndreasOC zum Thema Exchange Server ...