Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit pif und bat

Frage Entwicklung Batch & Shell

Mitglied: Haegar75

Haegar75 (Level 1) - Jetzt verbinden

07.12.2008, aktualisiert 08.12.2008, 3280 Aufrufe, 5 Kommentare

Hallo Leute,
ich bräuchte wiedermal Hilfe beim batchen
Ich möchte 186er Assemblerprogramme linken. Dazu benutze ich bisher Batchdateien die über pifs aufgerufen werden.

Die Batch sieht z.B. so aus:
set progname=XXX12345
LINK86 & <%progname%.con
pause

Der direkte Aufruf der Batch klappt nicht, nur wenn es über die entsprechnde Pif aufgerufen wird..
Warum ist das so? Wie erstelle ich überhaupt eine Pif? Die Angaben darüber im Hilfecenter helfen gar net..
Wie könnte es ohne Pif gehen?

Gruß Haegar

Edit: Ich habe mal versucht die _default.pif im Windows-Verzeichnis so einzustellen wie die pif die den Batch startet, aber der Batch läuft trotzdem nicht..
Mitglied: miniversum
07.12.2008 um 20:09 Uhr
Könnte was mit der Kompatibilität zu tun haben. Hast Du mal geschaut was ind er pif eingestellt ist? Kannst ja mal versuchen der Batch direkt in den Eigenschalten beim Kompatibilitätsmodus was zu machen.
Bitte warten ..
Mitglied: Haegar75
07.12.2008 um 20:25 Uhr
In der Pif ist nichts bzgl Kompatibilität eingestellt. Bei der Batch hab ich sämtliche Modi ausprobiert,aber geht net..
Bitte warten ..
Mitglied: miniversum
07.12.2008 um 21:01 Uhr
Was sit den dann eingestellt? Ein Arbeitsverzeichnis oder sowas?
Ohne zu wissen was dort eingestellt ist oder warum es die pif gibt ist es halt ein bischen schwer in der batch was zu ändern
Bitte warten ..
Mitglied: Haegar75
07.12.2008 um 21:15 Uhr
-Program:Unter Befehlszeile steht der Pfad auf die Batch,Kein Arbeitsverzeichnis, Unter Erweitert: %SystemRoot%\SYSTEM32\AUTOEXEC.NT und
%SystemRoot%\SYSTEM32\CONFIG.NT

-Speicher:alles auf "automatisch", verwende HMA
-unter Sonstiges ist alles ausgewählt ausser "exklusiver Modus" und "immer aussetzen"
-Kompatibilität: alles deaktiviert
Bitte warten ..
Mitglied: Haegar75
08.12.2008 um 10:47 Uhr
Hab noch was herausgefunden..
Laut einiger Funde in Google, sollte jede Batch die Einstellungen der _default.pif aus dem Windir benutzen.. Daraufhin hatte ich die _default.pif entsprechend angepasst, aber das half auch nicht. Jetzt hab ich mir die _default.pif mal in mein Verzeichnis kopiert und auf die Batch verweisen lassen. Das hat funktioniert. Ist mein System evtl so eingestellt, dass es eben nicht nach dieser _default.pif guckt? Hatte mal eine sehr große Schriftart ausgewählt, die aber in keiner Batch zu sehen war...
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Multimedia & Zubehör
BENQ Beamer Fernbedingung Frequenz Problem (2)

Frage von xbast1x zum Thema Multimedia & Zubehör ...

Windows Server
Google Chrome Web Store Problem auf Terminal Farm

Frage von dakoerry zum Thema Windows Server ...

Multimedia & Zubehör
gelöst Problem: DVI zu VGA (8)

Frage von Protected zum Thema Multimedia & Zubehör ...

Windows Server
Problem bei Zertifikatsverlängerung auf SBS2008 (2)

Frage von Firewire zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...