Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Portangabe bei FTP Login

Frage Internet

Mitglied: leknilk0815

leknilk0815 (Level 3) - Jetzt verbinden

13.05.2006, aktualisiert 14.05.2006, 17923 Aufrufe, 6 Kommentare

Problem mit Portangabe bei FTP Login, Syntax unklar

Hallo zusammen,

da meinen FTP Server (IIS) dauernd ein Witzbold zu hacken versucht, habe ich nun den Standard- Port auf 10021 geändert.
Seitden komme ich nicht mehr über den Browser mit Angabe von Name und Passwort auf die Kiste ("ftp:\\user:passwort@hostname.de:10021") - (die \\ sollen natürlich // sein, aber da wird hier automatisch immer irgend ein Unsinn angehängt).
Vermutlich ist die Syntax falsch, ich finde aber nirgends einen Hinweis drauf.
Login lokal geht, über webftp.de geht auch.

Kann mir jemand sagen, was falsch ist??

Danke mal vorab

Gruß - Toni
Mitglied: odicin
13.05.2006 um 17:52 Uhr
Wenn du versuchst von außen zuzugreifen, muß der Port 10021 im Router auf die IP des FTP-Servers geroutet werden.

Gruß Odi
Bitte warten ..
Mitglied: leknilk0815
13.05.2006 um 18:16 Uhr
Danke für die Antwort,
aber wie oben beschrieben, funktioniert der Zugriff sowohl von innen, als auch von aussen über webftp.de, da hier das Passwort und der Port über Eingabefelder eingegeben wird. Somit ist das Routerproblem ausgeschlossen.
Ich brauche einzig und allein die richtige Syntax im Browser, bei Port 21 (den braucht man nicht extra einzugeben) ist die Syntax ftp:\\user:passwort@host.de.
Bei anonymen Account (wenn dies aktiviert ist) lautet sie: ftp:\\host.de:port-Nr.
Nur die Kombination ftp:\\user:passwort@host.de:port-Nr. funktioniert nicht, daher bin ich sicher, daß da was falsch ist. Dies wäre meine Frage gewesen.

Gruß - Toni
Bitte warten ..
Mitglied: odicin
13.05.2006 um 18:41 Uhr
Ahso, die richtige Syntax ist:

ftp://username:passwort@domain.tld:port/

Gruß Odi
Bitte warten ..
Mitglied: 16568
13.05.2006 um 20:17 Uhr
Kannste mal die IP und die Nutzerdaten per PN schicken?


Lonesome Walker
Bitte warten ..
Mitglied: ilmo
14.05.2006 um 11:21 Uhr
Hi,

vielleicht ist im Netzwerk, indem der Zugriff nicht geht, der Ausgangsport (auf dem Router oder Firewall) gesperrt... dafür würde sprechen, dass normales FTP und webftp.de gehen...

GRuss

Ilja
Bitte warten ..
Mitglied: leknilk0815
14.05.2006 um 12:35 Uhr
Hi,

ich hab jetzt noch mal auf Port 21 zurückgestellt, da akzeptiert er die Syntax.
Möglicherweise hab ich im IIS was übersehen, ich habe den Port 21 auf der aktiven FTP- Site unter "Properties - FTP Site - TCP Port" umgestellt. Muß da evt. noch an anderer Stelle was geändert werden?

Konfig im IIS:
Default FTP Site (Stopped) - (hab ich vorsichtshalber auch umgestellt auf den neuen Port)
testinstall (gestartet) - umgestellt auf neuen Port, wie oben beschrieben


Gruß - Toni
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Java
Problem bei Java und FTP (1)

Frage von Marlon1 zum Thema Java ...

Exchange Server
gelöst Exchange 2013 Outlook 2013 Autodiscover Mailbox Problem (GUID) (4)

Frage von Systembastler zum Thema Exchange Server ...

Windows Server
Portierung IIS6 Virtuelle FTP Verzeichnisse nach IIS8 FTP (1)

Frage von flop zum Thema Windows Server ...

SAN, NAS, DAS
gelöst Synolgy 1815+ - Rechte- und Richtlinien-Problem User-Ordner Home (3)

Frage von Nintox zum Thema SAN, NAS, DAS ...

Heiß diskutierte Inhalte
CPU, RAM, Mainboards
Kaufberatung für mind. 8 verschiedene HighEnd-Mainboards (23)

Frage von yperiu zum Thema CPU, RAM, Mainboards ...

Mac OS X
Mac kann nicht im LAN pingen alle anderen schon (19)

Frage von smartino zum Thema Mac OS X ...

Hardware
gelöst PCI-Express-Adapterfrage (14)

Frage von DerWoWusste zum Thema Hardware ...

Linux Netzwerk
DHCP IP-vergabe erst nach 1-2 Minuten (11)

Frage von Maik82 zum Thema Linux Netzwerk ...