Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Psexec

Frage Microsoft Windows Tools

Mitglied: pandemo69

pandemo69 (Level 1) - Jetzt verbinden

03.11.2014, aktualisiert 20:57 Uhr, 1740 Aufrufe, 11 Kommentare

Werte Experten.

Mit Psexec versuche ich, eine Batch-Datei auf einem Remote-PC im Netzwerk zu starten.
Diese Batch-Datei soll lediglich eine lokale Website starten. (Aufgrund der lokalen Dateien muss es der Internet Explorer sein und da vom System so vorgegeben der IE9 auf einem Win7-PC)

Diese lokale Website lädt mehrere PDF-Dateien und zeigt sie einfach an.
Führe ich die Batch-Datei direkt am Remote-PC aus wird alles wie gewünscht dargestellt (Website startet - PDF wird angezeigt).
Starte ich die Batch-Datei jedoch von einem anderen PC mittels Psexec (psexec -i -u [Benutzername] -p [Passwort] \\[Remote-PC] d:\batch.bat) wird zwar der IE gestartet und die Website geladen und angezeigt, jedoch das integrierte PDF nicht.

Besonders interessant dabei ist, wenn ich auf dem Remote-PC den Internet Explorer starte (direkt per Icon oder auch per Batch) und dann den Psexec-Aufruf mache ... klappt es. Dann wird auch das PDF angezeigt.

Die angesprochene Batch-Datei auf dem Remote-PC enthält nur die Zeile: start iexplore [pfad]\website.html

Warum funktioniert der Aufruf der Website inklusive PDF und nicht mittels Psexec?
Warum jedoch klappt es, wenn zuvor der IE auf dem Remote-PC manuell gestartet wurde?

Ich habe alle möglichen Parameter von Psexe bereits getestet. Auf dem lokalen, wie auf dem Remote-PC habe ich Admin-Rechte. Jedoch vermute ich trotzdem, dass es etwas mit der Berechtigung zu tun haben muss. Oder liegt es vielleicht am Adobe Reader-Addon?

Ich wäre für eure Hilfe sehr dankbar.

Mfg
Günther
Mitglied: emeriks
03.11.2014 um 19:04 Uhr
Hi,
remote ausgelöste Prozesse dürfen nicht auf das Netzwerk zugreifen. Das ist ein fest eingebautes Sicherheitsfeature. Du musst die Batch vorher auf die lokale Platte kopieren (z.B. über \\server\c$) und dann von dort starten.

E.
Bitte warten ..
Mitglied: DerWoWusste
03.11.2014 um 19:05 Uhr
Hi.

Teste bitte mal mit dem Schalter -e.
Weiterer Test: ohne -e sondern nur mit -i, also ebenso ohne -u
Bitte warten ..
Mitglied: pandemo69
03.11.2014 um 19:40 Uhr
Hallo DerWoWusste.

Vielen Dank für deine Hilfe.

Habe jeden der Versuche bereits gemacht.
Mit -e Website wird gar nicht aufgerufen
Mit -i Website wird gestartet jedoch ohne PDF
Ohne -e oder -i (in allen Kombinationen) die Website wird nicht gestartet oder ohne PDF

Ich denke ich hab schon jede (auch schon absurde) Parameter-Kombination versucht. Leider jede ohne Erfolg.
Bitte warten ..
Mitglied: DerWoWusste
LÖSUNG 03.11.2014, aktualisiert 04.11.2014
Gut, bevor ich in's Testen einsteige, teste noch mal, per psexec einen Task zu starten übder schtasks.exe /run /tn Taskname
Ausführendes Konto: der angemeldete Nutzer, ausführen nur wenn angemeldet
Task: iexplore.exe website
Bitte warten ..
Mitglied: pandemo69
03.11.2014 um 19:56 Uhr
Hallo emeriks.

Danke für deine schnelle Hilfe.
Das ist ja ein toller Ansatz. Das heißt ich muss vorher vom Remote die Datei auf meinen lokalen PC kopieren und dann per Psexec ausführen?
Wenn jetzt aber die Batch lokal auf meinem Rechner liegt, wie sieht dann die CMD aus damit sie auf dem Remote ausgeführt wird?
Wenn ich jetzt mit (psexec -i -u [Benutzername] -p [Passwort] \\[Remote-PC] d:\batch.bat) starten will, dann wird ja die Batch auf dem Remote angesprochen.
Wie bringe ich Psexec dazu, die lokale (hierher kopierte) Batch auf dem Remote auszuführen?

Vielen Dank
Günther
Bitte warten ..
Mitglied: pandemo69
03.11.2014 um 20:03 Uhr
Hallo DerWoWusste.

Test gemacht. Der IE wird mit der Website gestartet. Nur leider ohne die PDF anzuzeigen.
So. Neue Erkenntnis:
Wenn ich die Website lokal aufrufe (Website und Batch liegen auf meinem lokalen PC) mit dem CMD:
(psexec -i -u [Benutzername] -p [Passwort] \\[Remote-PC] d:\batch.bat)
so ist das Ergebnis wie gehabt. (Website ohne PDF).

Wenn ich aber lokal den Benutzernamen und das Passwort weglasse (brauch ich ja lokal nicht) dann wird alles korrekt dargestellt
(psexec -i \\[Remote-PC] d:\batch.bat)

Aber es kann doch kein Rechteproblem sein. Hab auf beiden PCs Admin-Rechte. Oder doch?
Bitte warten ..
Mitglied: DerWoWusste
03.11.2014 um 20:14 Uhr
Ich hatte Dich ja zuallererst bereits gebeten, ohne -u zu arbeiten. Geht das den nict remote ohne -u? Sollte gehen, wenn das ausführende Konto remote Admin ist.
Bitte warten ..
Mitglied: pandemo69
03.11.2014, aktualisiert um 20:30 Uhr
Leider funktioniert psexec ohne -u nur wenn ich (wie jetzt zum Testen) alles lokal gespeicht habe. Also die Website und die Batch. Wenn ich aber auf den Remote per psexec zugreifen will muss ich -u -p verwenden. Sonst komm ich nicht drauf. Und dann klappt es wieder nicht mehr mit der PDF-Anzeige in der Website.
Bitte warten ..
Mitglied: DerWoWusste
03.11.2014 um 20:33 Uhr
Ich würde Dir gerne helfen und bin mir sicher es recht schnell zu finden, aber welche Website soll ich nehmen?
Kannst Du Deine Batch und Website zippen und bereit stellen? Oder gibt es im Internet eine Site, mit der man das nachstellen kann?
Bitte warten ..
Mitglied: emeriks
LÖSUNG 03.11.2014, aktualisiert um 20:57 Uhr
Nochmal:
Wenn man mit psexec einen Prozess startet, dann kann dieser, und alle von diesem weiter gestarteten, nicht auf das Netzwerk zu greifen. Ende der Tatsachen.
Also IE starten - ja geht. Dieser IE-Prozess kann aber kein PDF von einem Share laden.
Batch starten, die lokal auf dem Remote-PC vorliegt - ja geht. Aus dieser Batch (CMD) heraus kann man aber nicht auf ein Share zugreifen.
OK?

Wenn die Batch nur "irgendwas" lokal machen soll, dann Batch auf den Remote-PC kopieren und dann mit PSexec starten. Wenn die Batch dann auch noch auf Dateien im Netzwerk zugreifen soll, dann geht das nicht. Dann also diese Dateien auch vorher nach lokaler Platte des Remote-PC kopieren und die Batch entsprechend anpassen, dass sie lokal zugreift.

Bsp.
Batch-Datei \\server\freigabe\start_doc.cmd
01.
start Dokument.pdf
Starten auf Remote-PC
01.
copy \\server\freigabe\start_doc.cmd \\remote-pc\c$\start_doc.cmd 
02.
copy \\server\freigabe\dokument.pdf \\remote-pc\c$\Dokument.pdf 
03.
psexec \\remote-pc c:\start_doc.cmd
E.
Bitte warten ..
Mitglied: pandemo69
03.11.2014 um 20:58 Uhr
Hallo Leute.

Vielen Dank euch Beiden für eure Hilfe.
Recht hatten natürlich Beide aber Emeriks Hinweis hat jetzt zur Lösung geführt. Nachdem ich die Dateien kopiert hatte und dann mittels Psexec die Batch gestartet wurde hats geklappt. Jetzt funktioniert alles. Ich wusste einfach nicht, dass zwar der IE korrekt gestartet wird und auch die Website anzeigen kann, aber ein integriertes PDF (das ja lokal vom Share nachgeladen werden muss) aufgrund der Sicherheitsbestimmungen nicht geladen wird.

Lokal sieht es natürlich gleich anders aus, da ja keine Sicherheitsbestimmungen verletzt werden.
Jetzt funktionierts auch im Netzwerk.

Nur warum bei meinen vorigen Versuchen die Website lokal mit -u nicht korrekt dargestellt wurde ist mir nicht klar. Nur jetzt funktionierts.

Ich bedanke mich vielmals bei euch für euer Wissen und eure Hilfe

Schönen Abend.
Günther
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...