Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Robocopy und Dateidatum

Frage Entwicklung Batch & Shell

Mitglied: rg-87

rg-87 (Level 1) - Jetzt verbinden

09.01.2009, aktualisiert 18:56 Uhr, 7443 Aufrufe, 2 Kommentare

Guten Abend an die Administratoren,

Ich sichere mittels Robocopy-Script den Inhalt meines Laufwerkes Z: auf ein NAS.
Es wir meines Wissens die komplette Verzeichnisstruktur gesichert.
Dabei schaut der Robocopybefehl folgendermaßen aus:

robocopy.exe "Z:" "\\192.168.100.2\sicherung" /MIR /ZB /R:0 /W:0 /XD "Z:\RECYCLER" /XD "Z:\System Volume Information"

Soweit funktioiert das alles auch, jedoch wird bei jeder Sicherung ein meherer Ordner an verschiedenen Stellen als neu bzw. als geändert erkannt.
Diesen werden wie es das Script soll natürlich mitgesichert.
Diese Ordner bzw. Dateien wurden in der letzten Zeit jedoch noch nicht ein mal von mir geöffnet bzw. von mir geändert.

Es sind immer die selben Dateien welche beim Scriptablauf fälschlicherweise als neu bzw. geändert erkannt werden.

Vielleicht kann mir jemand einen Tip geben.
Habe mir extra nochmal folgende seite durchgelesen:
http://www.msu-hb.de/system/system/robocopy.htm

Jedoch bin ich dem Fehler bzw. meinem Fehler nicht auf die Schliche gekommen.

Danke im Voraus für eure Mühen
Mitglied: Biber
09.01.2009 um 19:17 Uhr
Moin rg-87,

Schau mal in die Robocopy-hilfe (robocopy /???) am CMD-Prompt.
Wenn Du die jetzt angesagte Robocopy-Version (also XP ff) hast, wird Dir auch ein Schalter
/FFT :: assume FAT File Times (2-second granularity).
..angeboten.
Nutze den - ist gratis und effizient.

(Erläuterung: Eines von beiden beteiligten Dateisystemen speichert genauer [auf Sekunden genau], das andere etwas gröber.)

Grüße
Biber

P.S. Bitte in Zukunft nie wieder "Danke im Voraus für eure Mühen" in diesem Zweigarm des Forums.
Bitte warten ..
Mitglied: rg-87
09.01.2009 um 19:35 Uhr
Hallo Biber,

ein großes danke für den tip.
Es hat echt prima geklappt.
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
PowerShell Transkript Problem (4)

Frage von Marabunta zum Thema Batch & Shell ...

Ubuntu
Problem mit MailServer unter Debian - Postfix, Dovecot (4)

Frage von Richard8 zum Thema Ubuntu ...

Router & Routing
gelöst Mikrotik Switching und Routing Problem (11)

Frage von aqui zum Thema Router & Routing ...

Batch & Shell
gelöst Robocopy geht und geht nicht gerade nicht (9)

Frage von TicTakTeo zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (18)

Frage von oel-auge zum Thema Router & Routing ...

Windows 7
BOOTMGR is missing (auch nach bootrec -RebuildBcd) (16)

Frage von Mipronimo zum Thema Windows 7 ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...