Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Robocopy und Dateidatum

Frage Entwicklung Batch & Shell

Mitglied: rg-87

rg-87 (Level 1) - Jetzt verbinden

09.01.2009, aktualisiert 18:56 Uhr, 7434 Aufrufe, 2 Kommentare

Guten Abend an die Administratoren,

Ich sichere mittels Robocopy-Script den Inhalt meines Laufwerkes Z: auf ein NAS.
Es wir meines Wissens die komplette Verzeichnisstruktur gesichert.
Dabei schaut der Robocopybefehl folgendermaßen aus:

robocopy.exe "Z:" "\\192.168.100.2\sicherung" /MIR /ZB /R:0 /W:0 /XD "Z:\RECYCLER" /XD "Z:\System Volume Information"

Soweit funktioiert das alles auch, jedoch wird bei jeder Sicherung ein meherer Ordner an verschiedenen Stellen als neu bzw. als geändert erkannt.
Diesen werden wie es das Script soll natürlich mitgesichert.
Diese Ordner bzw. Dateien wurden in der letzten Zeit jedoch noch nicht ein mal von mir geöffnet bzw. von mir geändert.

Es sind immer die selben Dateien welche beim Scriptablauf fälschlicherweise als neu bzw. geändert erkannt werden.

Vielleicht kann mir jemand einen Tip geben.
Habe mir extra nochmal folgende seite durchgelesen:
http://www.msu-hb.de/system/system/robocopy.htm

Jedoch bin ich dem Fehler bzw. meinem Fehler nicht auf die Schliche gekommen.

Danke im Voraus für eure Mühen
Mitglied: Biber
09.01.2009 um 19:17 Uhr
Moin rg-87,

Schau mal in die Robocopy-hilfe (robocopy /???) am CMD-Prompt.
Wenn Du die jetzt angesagte Robocopy-Version (also XP ff) hast, wird Dir auch ein Schalter
/FFT :: assume FAT File Times (2-second granularity).
..angeboten.
Nutze den - ist gratis und effizient.

(Erläuterung: Eines von beiden beteiligten Dateisystemen speichert genauer [auf Sekunden genau], das andere etwas gröber.)

Grüße
Biber

P.S. Bitte in Zukunft nie wieder "Danke im Voraus für eure Mühen" in diesem Zweigarm des Forums.
Bitte warten ..
Mitglied: rg-87
09.01.2009 um 19:35 Uhr
Hallo Biber,

ein großes danke für den tip.
Es hat echt prima geklappt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...

Windows Netzwerk
gelöst Problem mit PSexec64 von Sysinternals (8)

Frage von MaxMoritz6 zum Thema Windows Netzwerk ...

Windows Server
gelöst Problem nach DC-Installation unter Server 2012 R2 (9)

Frage von manuel1985 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...