Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Samba Winbind und Windows Server 2012 R2

Frage Linux Samba

Mitglied: Andreasde95

Andreasde95 (Level 1) - Jetzt verbinden

01.12.2014 um 09:49 Uhr, 2889 Aufrufe, 12 Kommentare

Hallo,

ich probiere derzeit mit deinem Linux Client (Kubuntu 14.04) mich mit den Benutzern vom Windows Server 2012 R2 anzumelden.

Anmeldung soll mit Kerberos funktionieren.

Leider bekomme ich eine Fehlermeldung und weiß nicht was ich falsch mache.

Fehlerbeldung:

andreas@Kubuntu:~$ sudo smbclient -L kubuntu.example.com -U EXAMPLE+administrator
Enter EXAMPLE+administrator's password:
session setup failed: NT_STATUS_LOGON_FAILURE

was funktiniert ist mir die Gruppen und User anzeigen lassen mit wbinfo -u und wbinfo -g
wbinfo -u:

andreas@Kubuntu:~$ sudo wbinfo -u
EXAMPLE+administrator
EXAMPLE+gast
EXAMPLE+krbtgt
EXAMPLE+test


mit getent passwd und getent groups geht dies lieder nicht. hier werden nur die lokalen User angezeigt.

andreas@Kubuntu:~$ sudo getent passwd
root:x:0:0:root:/root:/bin/bash
daemon:x:1:1:daemon:/usr/sbin:/usr/sbin/nologin
bin:x:2:2:bin:/bin:/usr/sbin/nologin
sys:x:3:3:sys:/dev:/usr/sbin/nologin
sync:x:4:65534:sync:/bin:/bin/sync
games:x:5:60:games:/usr/games:/usr/sbin/nologin
man:x:6:12:man:/var/cache/man:/usr/sbin/nologin
lp:x:7:7:lp:/var/spool/lpd:/usr/sbin/nologin
mail:x:8:8:mail:/var/mail:/usr/sbin/nologin
news:x:9:9:news:/var/spool/news:/usr/sbin/nologin
uucp:x:10:10:uucp:/var/spool/uucp:/usr/sbin/nologin
proxy:x:13:13:proxy:/bin:/usr/sbin/nologin
www-data:x:33:33:www-data:/var/www:/usr/sbin/nologin
backup:x:34:34:backup:/var/backups:/usr/sbin/nologin
list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
irc:x:39:39:ircd:/var/run/ircd:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin
nobody:x:65534:65534:nobody:/nonexistent:/usr/sbin/nologin
libuuid:x:100:101::/var/lib/libuuid:
syslog:x:101:104::/home/syslog:/bin/false
messagebus:x:102:106::/var/run/dbus:/bin/false
usbmux:x:103:46:usbmux daemon,,,:/home/usbmux:/bin/false
dnsmasq:x:104:65534:dnsmasq,,,:/var/lib/misc:/bin/false
avahi-autoipd:x:105:113:Avahi autoip daemon,,,:/var/lib/avahi-autoipd:/bin/false
kernoops:x:106:65534:Kernel Oops Tracking Daemon,,,:/:/bin/false
rtkit:x:107:114:RealtimeKit,,,:/proc:/bin/false
saned:x:108:115::/home/saned:/bin/false
whoopsie:x:109:116::/nonexistent:/bin/false
avahi:x:110:117:Avahi mDNS daemon,,,:/var/run/avahi-daemon:/bin/false
lightdm:x:111:118:Light Display Manager:/var/lib/lightdm:/bin/false
colord:x:112:121:colord colour management daemon,,,:/var/lib/colord:/bin/false
hplip:x:113:7:HPLIP system user,,,:/var/run/hplip:/bin/false
pulse:x:114:122:PulseAudio daemon,,,:/var/run/pulse:/bin/false
andreas:x:1000:1000:Andreas,,,:/home/andreas:/bin/bash


beim Windows Server habe ich die Domäne eingerichten und DNS Ping klappt auch.

smb.conf:

[global]
workgroup = EXAMPLE
realm = EXAMPLE.COM
security = ADS
password server = testserver.example.com
idmap config * : range = 100000 - 199999
idmap config EXAMPLE : backend = rid
idmap config EXAMPLE : range = 100000 - 199999
winbind separator = +
winbind enum users = yes
winbind enum groups = yes
winbind refresh tickets = yes

krb5.conf:

[libdefaults]
default_realm = EXAMPLE.COM
[realms]
EXAMPLE.COM = {
kdc = TESTSERVER.EXAMPLE.COM
admin_server = TESTSERVER.EXAMPLE.COM
}
[domain_realm]
.example.com = EXAMPLE.COM





Hoffe ihr könnt mir helfen eine Lösung zu finden.

Mit freundlichen Grüßen
Andreas
Mitglied: Lochkartenstanzer
01.12.2014 um 10:04 Uhr
Zitat von Andreasde95:

Fehlerbeldung:

andreas@Kubuntu:~$ sudo smbclient -L kubuntu.example.com -U EXAMPLE+administrator
Enter EXAMPLE+administrator's password:
session setup failed: NT_STATUS_LOGON_FAILURE

Hoffe ihr könnt mir helfen eine Lösung zu finden.


Moin,

Stimmt denn das Paßwort?
Stimmt die tastaturbeölegung, falls Sonderzeichen oder y/z verwendet werden?

lks
Bitte warten ..
Mitglied: Andreasde95
01.12.2014, aktualisiert um 10:16 Uhr
ich benutze das lokale Passwort vom Windows Server Administrator.

ja ich bin mir sicher mit einem Anderen User tritt genau das gleiche Problem auf.

anonym ohne Passwort bekomme ich eine Antwort

andreas@Kubuntu:~$ sudo smbclient -L kubuntu.example.com -U EXAMPLE+administrator
Enter EXAMPLE+administrator's password:
Anonymous login successful
Domain=[EXAMPLE] OS=[Unix] Server=[Samba 4.1.6-Ubuntu]

Sharename Type Comment
--------- ---- -------
IPC$ IPC IPC Service (Samba 4.1.6-Ubuntu)
Anonymous login successful
Domain=[EXAMPLE] OS=[Unix] Server=[Samba 4.1.6-Ubuntu]

Server Comment
--------- -------
KUBUNTU Samba 4.1.6-Ubuntu
TESTSERVER Testserver

Workgroup Master
--------- -------
EXAMPLE KUBUNTU
WORKGROUP FRITZ-NAS
Bitte warten ..
Mitglied: Chonta
01.12.2014 um 10:54 Uhr
Hallo,

kannst Du die chaown einem Domänenbenutzer eine Datei auf dem Linuxsystem zuweisen?
Wenn nein, dann kennt zwar winbind die Domänennutzer aber gibt das nicht richtig an Linux weiter.

Es gab/gibt einen Bug in Winbind bei Samba 4.2.xx der verhindert das die Benutzer in beide Richtinen aufgelößt werden.
Unglücklicherweise hat Ubuntu diesen Bug bei einem der "letzten" Updates mitübernommen und dann geht nix.

Mit Samba 3.6.6 geht noch alles wunderbar.
Um Dich mit den Windowsbenutzern am Linux anzumelden wie ein Linuxuser muss noch ein PAM Modul nachinstalliertwerden.

Gruß

Chonta
Bitte warten ..
Mitglied: Andreasde95
01.12.2014 um 11:11 Uhr
ja genau das geht nicht da kommt das das der Benutzer unbekannt ist.

andreas@Kubuntu:/etc$ sudo chown -c Administrator /etc/test.conf
chown: ungültiger Benutzer: »Administrator“

wie kann ich dieses Problem jetzt lösen?

kann ich einfach eine ältere Samba Version installieren oder gibt es ein Patch um das Problem von Samba 4.2 zu lösen?

Mit freundlichen Grüßen
Andreas
Bitte warten ..
Mitglied: Lochkartenstanzer
01.12.2014 um 11:12 Uhr
Zitat von Andreasde95:

ich benutze das lokale Passwort vom Windows Server Administrator.


Du willst AD-Benutzer evrwenden udn gibst das pwd vom lokalen Admin an? irgendetwas läuft da schief. entweder verstehe ich Dich falsch, oder Du weißt nicht, wie AD fktioniert.

Also:

Wenn Du Ad nutzen willst, mußt du auch einen AD-User mit seinem Pawßwort verwenden.

lks
Bitte warten ..
Mitglied: Lochkartenstanzer
01.12.2014 um 11:13 Uhr
Zitat von Andreasde95:

ja genau das geht nicht da kommt das das der Benutzer unbekannt ist.

andreas@Kubuntu:/etc$ sudo chown -c Administrator /etc/test.conf
chown: ungültiger Benutzer: »Administrator“

wie kann ich dieses Problem jetzt lösen?


Administrator klein schreiben (=administrator)?

lks
Bitte warten ..
Mitglied: Andreasde95
01.12.2014 um 11:14 Uhr
entschuldigen sie ja habe mich verschrieben meine natürlich den Domänen-Administrator oder Domänen-User und beides ging nicht.
Bitte warten ..
Mitglied: Andreasde95
01.12.2014 um 11:15 Uhr
kommt genau das gleiche raus egal ob klein oder groß geschrieben.

andreas@Kubuntu:/etc$ sudo chown -c administrator /etc/test.conf
chown: ungültiger Benutzer: »administrator“
Bitte warten ..
Mitglied: Gersen
01.12.2014, aktualisiert um 12:30 Uhr
Hallo,

Zitat von Andreasde95:
mit getent passwd und getent groups geht dies lieder nicht. hier werden nur die lokalen User angezeigt.

zumindest dieses Problem hört sich sehr danach an: "Die beiden Pakete libnss-winbind und libpam-winbind müssen ab 14.04 LTS mit installiert werden, da sonst die getent passwd Prüfung nur lokale Einträge liefert." Hast Du mal diesen Artikel für Deine Konfiguration geprüft, insbes. hier ff.?

Gruß,
Gersen
Bitte warten ..
Mitglied: Andreasde95
01.12.2014 um 13:03 Uhr


zumindest dieses Problem hört sich sehr danach an: "Die beiden Pakete libnss-winbind und libpam-winbind müssen ab
14.04 LTS mit installiert werden, da sonst die getent passwd Prüfung nur lokale Einträge liefert." Hast Du mal
diesen Artikel für Deine Konfiguration geprüft, insbes.
hier ff.?

Gruß,
Gersen

ja jetzt mit deinen Paketen bekomme ich die Domänen-User auch mit übergeben.

leider kann ich bei chown immer noch nicht einen Domänen-User einsetzen.
Bitte warten ..
Mitglied: Gersen
01.12.2014 um 13:13 Uhr
Gut. Die Einstellungen für /etc/nsswitch.conf und die /etc/pam.d/-Dateien hast Du gemacht - und Samba/winbind neu gestartet?
Bitte warten ..
Mitglied: Andreasde95
01.12.2014 um 13:51 Uhr
Zitat von Gersen:

Gut. Die Einstellungen für /etc/nsswitch.conf und
die /etc/pam.d/-Dateien hast Du gemacht - und Samba/winbind neu
gestartet?

nach einem Neustart hat es dann auch geklappt Dankeschön für die Hilfe ;)
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Problem mit Windows Server 2012 R2 (MSConfig - Systemstart Modus) (3)

Frage von FloFMS zum Thema Windows Server ...

Windows Server
Windows Server 2012 R2 Benutzerkonto für Zugriff auf AD Benutzer (2)

Frage von JulianOhm zum Thema Windows Server ...

Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch (3)

Frage von onkel87 zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...