Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit SC Batch übers Netzwerk

Frage Microsoft Windows Tools

Mitglied: kugelschreiber

kugelschreiber (Level 1) - Jetzt verbinden

24.09.2008, aktualisiert 25.09.2008, 6141 Aufrufe, 3 Kommentare

STOP geht aber START nicht

Hallo Ihr Lieben,

ich habe folgendes Szenario und Problem.

Ich habe einen Proxy Server (Squid) auf Windows 2000 Professional laufen. Zusätzlich läuft dort ein "kleiner" Webserver auf XAMPP Basis zur Administration der ACL Listen des Proxys über das Web.
Des Weiteren habe ich einen Laptop mit Windows Vista Home Premium - bezeichnen wir ihn mal als Clienten.

Nun folgendes:

Vom Laptop aus rufe ich per IE http://proxy/squid auf und komme zur (selbst gebastelten) Web-Oberfläche, welche mir die Listen mit gesperrten Seiten und Wörtern administrieren läßt (MySQL) und diese dann wieder als Datei in das im Proxy angegebene Verzeichnis schreibt. Dies funktioniert reibungslos.
Da der Proxy aber nach jedem Update der Listen neu gestartet werden muss, habe ich mir zwei Batchdateien stop.bat und start.bat ins Webverzeichnis des Proxys(Webservers) angelegt und auf der Administrationsoberfläche per HTML verlinkt.
<a href="stop.bat">STOP</a>
<a href="start.bat">START</a>
Die Dateien haben folgenden Inhalt:

-stop.bat:

SC \\proxy STOP squid
PAUSE

-start.bat

SC \\proxy START squid
PAUSE

Nach dem Drücken auf die STOP-Verlinkung poppt ein Windows Fenster auf, wo ich das ausführen der Datei bestätigen muss.
Dies tue ich und erhalte:

8ef732a27a6e453adcc17a52f2b0e953-prompt - Klicke auf das Bild, um es zu vergrößern

Der Service wird auch auf dem Proxy gestoppt.

Nur das Starten will nicht funktionieren!

Kopiere ich allerdings "SC \\proxy START squid" in meine per Start -> ausführen -> CMD aufgerufene Konsole -> Funktioniert es. Der Squid startet und es erscheint:

c6443a1ce91d1c154169700d9e37b37a-prompt2 - Klicke auf das Bild, um es zu vergrößern

Woran liegt das?
Der Befehl ist doch richtig, oder?
Die PSTools sind auf dem Clienten installiert. Gibt es noch einen Trick, den ich nicht kenne? Habe ich etwas übersehen?
Ist das Starten von Diensten nicht erlaubt? Benötige ich eventuell Benutzername und passwort zum Starten von Diensten? Wenn ja wie übergebe ich die dem Batchbefehl?

Gruß und vielen Dank für Eure Hilfe

Der Kuli
Mitglied: 60730
24.09.2008 um 18:41 Uhr
Servus,

du schreibst - die Pstools sind auf dem "Squid" installiert/kopiert.
Benutzt aber das "SC" von XP....

Psservice \\proxy -u domain\admin -p Passwd START squid
würde ich erstmal probieren.

Und wenn es dann auch nicht klappt - würde ich das Problem auf Vista schieben und mit einem anderen Client deine Version testen

Gruß
Bitte warten ..
Mitglied: kugelschreiber
25.09.2008 um 12:40 Uhr
Hallo Timo,

danke für den Tip mit den psservice hats geklappt.

Allerdings habe ich noch ein kleines Problemchen. Die PSTOOLS müssen gar nicht auf dem Proxy "installiert" sein, sondern auf der Maschine(Client), die den Befehl ausführen wird, richtig?

Danke und Gruß Kuli
Bitte warten ..
Ähnliche Inhalte
TK-Netze & Geräte
Fax Signal übers Netzwerk
Frage von dermolaTK-Netze & Geräte7 Kommentare

Hallo zusammen, wir haben eine Telefon Anlage von Agfeo (ES 512) leider kann die Anlage keine Fax Geräte über ...

Grafikkarten & Monitore
Screensharing übers Netzwerk
gelöst Frage von Rizal1966Grafikkarten & Monitore2 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Lösung für folgendes Problem. An einem Standort von meinem Arbeitgeber ...

Visual Studio
VB.Net Screenshot übers Netzwerk übertragen
Frage von Aicher1998Visual Studio1 Kommentar

Hallo Ich möchte einen Screenshot übers Netzwerk übertragen und hab mir dazu einen simplen Server und Client geschrieben. Irgendwie ...

Batch & Shell
IISReset mit sc stop
gelöst Frage von Viper-BerlinBatch & Shell2 Kommentare

Hallo Leute, habe ein Problem, ich weiss nicht so genau welche Dienste bei ausführung von "IISReset /stop" angehalten werden ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 2 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 7 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 8 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 20 StundenInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...