Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit Summenprodukt in Excel

Frage Microsoft Microsoft Office

Mitglied: stoperror

stoperror (Level 1) - Jetzt verbinden

27.09.2010 um 12:44 Uhr, 4309 Aufrufe, 2 Kommentare

Linker Ausdruck von Summenprodukt ist false und rechter Ausdruck ist true. Beim Verunden, wird daraus ein Gesamttrue.

Hallo zusammen,

Das folgende Summenprodukt ergibt false:

=SUMMENPRODUKT((($A$2:$A$1988 = $A4)*($C$2:$C$1988 = $C4)*($H$2:$H$1988<=$I4)*($I$2:$I$1988>=$H4) *($J$2:$J$1988 <= $K4) * ($K$2:$K$1988 >= $J4)) )>1

Das nächste Summenprodukt ergibt true:

= ((($L4 = 1) * ($L$2:$L$1988 = $L4)) + (($M4 = 1)*($M$2:$M$1988 = $M4)) )

Nun möchte ich beide Ausdrücke mit UND verketten. Eigentlich sollte dann ja False rauskommen. Nur das tut es nicht.


=SUMMENPRODUKT(($A$2:$A$1988 = $A4)*($C$2:$C$1988 = $C4)*($H$2:$H$1988<=$I4)*($I$2:$I$1988>=$H4) *($J$2:$J$1988 <= $K4) * ($K$2:$K$1988 >= $J4) * ((($L$2:$L$1988 = $L4) * ($L4 = 1))+(($M$2:$M$1988 = $M4) * ($M4 = 1)) ))>1


Was ich damit bezwecken möchte:

In Spalte A und Spalte C steht jeweils ein ID-Paar, dass mit dem Satz innerhalb der 1988 Zeilen übereinstimmen muss.
Dann prüfe ich (H2, I2) ob ein Start- und Endedatum sich überschneiden.
Dann prüfe ich (J,K) ob ein Zeitraum sich überschneidet.

Nun gibt es in den Spalten L, M die Tage Montag, Dienstag ich möchte nur wenn der jeweilige TAg auf 1 gesetzt ist und alle anderen Bedingungen übereinstimmen, die Überschneidungen rausbekommen.

Bin für jede Idee dankbar.
Mitglied: bastla
27.09.2010 um 16:28 Uhr
Hallo stoperror!

So hast Du es schon versucht?
=(SUMMENPRODUKT((($A$2:$A$1988 = $A4)*($C$2:$C$1988 = $C4)*($H$2:$H$1988<=$I4)*($I$2:$I$1988>=$H4) *($J$2:$J$1988 <= $K4) * ($K$2:$K$1988 >= $J4)) )>1) * SUMMENPRODUKT((($L4=1)*($L$2:$L$1988=$L4))+(($M4=1)*($M$2:$M$1988=$M4)))
Grüße
bastla
Bitte warten ..
Mitglied: stoperror
28.09.2010 um 08:51 Uhr
Ja. Danke! Ach man muss zwei einzelne Summenproduktfunktionen miteinander verwurschteln und kann da nicht in eine machen...

Ich hab's jetzt aber anders gelöst. Da es eh aufschlussreich ist, an welchem Tag die Überschneidungen sind, berechne ich die einzelnen Spalten pro Tag (das funktioniert ja).
Und dann gibt's noch die Gesamtspalte, die die Ergebnisse der Einzelspalten verodert.
Funktioniert einwandfrei.
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
gelöst Excel Problem Wenn Dann (3)

Frage von Yannosch zum Thema Microsoft Office ...

Microsoft Office
gelöst Excel-Formel-Problem (2)

Frage von MiSt zum Thema Microsoft Office ...

Xenserver
Excel-Problem in Citrix-Umgebung (4)

Frage von reksierp zum Thema Xenserver ...

Microsoft Office
gelöst Mal wieder ein Excel-Problem (4)

Frage von Yannosch zum Thema Microsoft Office ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

LAN, WAN, Wireless
Gebäudeverkabelung 10Gigabit LWL (28)

Frage von raffzwo zum Thema LAN, WAN, Wireless ...

Windows Update
Novemberpatches und Nadeldrucker bereiten Kopfschmerzen (14)

Tipp von MettGurke zum Thema Windows Update ...