Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit svchost.exe

Frage Microsoft

Mitglied: qualidat

qualidat (Level 1) - Jetzt verbinden

05.02.2013, aktualisiert 06.03.2013, 3271 Aufrufe, 4 Kommentare

"svchost.exe*32" im Userkontext sehr verdächtig, verursacht bis zu 25% Systemauslastung pro Instanz

Hallo allerseits,
auf einem Terminalserver (Dell R270 mit Server 2008 R2) bechweren sich seit Kurzem die Benutzer über eine arg gebremste Performance. Ein Blick in den Taskmanager zeigt mir mehrere Prozesse "svchost.exe*32" (aus Syswow64), die nicht als System, Lokal oder Netzwerkdienst laufen, sondern in verschiedenen Usersessions. Das, so habe ich mich belesen, ist höchst verdächtig.

Ein manuelles "Abschießen" dieser Prozesse lässt die CPU-Auslastung des Servers wieder auf die gewohnten 10...15 Prozent sinken und behebt die Performanceprobleme. Zu dieser Zeit geöffnete Anwendungen sind davon nicht sichtbar betroffen. Wir konnten noch nicht herausfinden, welche Anwendung dafür verantwortlich ist.

Nun habe ich bereits an die 10...15 der verschiedensten Viren- und Malwarescanner über das System laufen lassen, aber ich kann den Urheber bzw. den parasitären Prozess einfach nicht finden, der da auf svchost.exe "reitet". Die Software "svchost explorer" (Neuber) findet zwar genau diese Prozesse verdächtig, kann aber nicht auf die Prozessstruktur zugreifen und liefert keine weiteren Infos. Das Progrmm meint "starten sie es im Adminmodus", aber ich bin als Admin angemeldet, auch ein explizides "als Admin ausführen" hilft nicht. Da kapselt sich etwas sehr geschickt.

Wie finde ich den Urheber für das Problem heraus?

Danke für Tips, Frank
Mitglied: DerWoWusste
05.02.2013, aktualisiert um 15:47 Uhr
Hi.

Starte process explorer, der verrät mehr über die einzelnen Instanzen der svchost.exe
Bitte warten ..
Mitglied: Ravers
05.02.2013 um 16:52 Uhr
Hi,

schau dir das mal an: http://www.neuber.com/free/svchost-analyzer/deutsch.html

Und schau, ob da was bei herauskommt. (Habe das Tool noch nicht getestet. Fand es nur interessant und hab es mir beiseite gelegt)

greetz
ravers
Bitte warten ..
Mitglied: qualidat
06.03.2013 um 14:01 Uhr
Ich glaube, ich habe das Problem gelöst, ohne allerdings wirklich die Ursache zu finden - aber die Symptome sind weg.

Ich habe beide svchost.exe (einmal aus System32 und einmal aus SysWOW64) dem Besitzer "Trustedinstaller" entrissen (auf Administratoren gesetzt) und bei den Rechten den normalen Benutzern sämtliche Berechtigungen entzogen. Nun ist erstmal Ruhe und beschwert, dass irgendwas nicht mehr geht, hat sich auch niemand ...
Bitte warten ..
Mitglied: DerWoWusste
06.03.2013, aktualisiert um 19:29 Uhr
Hi.
...und beschwert, dass irgendwas nicht mehr geht, hat sich auch niemand ...
Das darf nicht die Bestätigung sein, dass dieser Schritt gut ist. Unter Umständen schlägt dieser Workaround noch Blasen, ich würde mich um eine Lösung bemühen.

Antworte doch mal auf die Vorschläge.
Bitte warten ..
Ähnliche Inhalte
Windows Server
SimpleHelp - Problem (4)

Frage von ArnoNymous zum Thema Windows Server ...

Microsoft
Problem mit meinem PC (24)

Frage von AaronH96 zum Thema Microsoft ...

DNS
gelöst Wieder ein Problem mit der ASA (4)

Frage von Yannosch zum Thema DNS ...

Vmware
gelöst Keyboard problem (7)

Frage von rocco61 zum Thema Vmware ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 Ordnerfreigabe (21)

Frage von Xaero1982 zum Thema Windows 10 ...

Router & Routing
Allnet - VDSL2 Modem - SFP (mini-GBIC) (20)

Frage von Dobby zum Thema Router & Routing ...

Monitoring
Netzwerk-Monitoring Software (17)

Frage von Ghost108 zum Thema Monitoring ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...