Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Problem mit table-Funktionen in HTML

Frage Entwicklung Webentwicklung

Mitglied: 4263

4263 (Level 1)

08.04.2007, aktualisiert 14.04.2007, 3343 Aufrufe, 3 Kommentare

Guten Abend,

ich möchte eine Homepage mit Hilfe vom Tables darstellen. Die ganze Tabelle soll fix sein, da sie schon in ein zentriertes, fixes Frame eingebunden ist.

Mein Problem ist nun, dass ich es nicht schaffe, die untere Row (also zweite <tr>) an den unteren Rand des Frames zu binden, und zwar in jedem Fall. Das Frame ist 558px, die obere <tr> soll 500px, die untere 58px hoch sein.

Ich habe alle Rahmen und Zwischenräume mit border="0", cellspacing="0" und cellpadding="0" eigentlich eliminiert, dennoch bin ich mir aber nicht sicher ob die 58px und die 500px in das 558px hohe Frame passen...

Hier mal der Code der im Frame angezeigten Page:

01.
<html> 
02.
 
03.
<head> 
04.
<title> bla </title> 
05.
<meta name="author" content="Dennis"> 
06.
</head> 
07.
 
08.
<body text="#000000" bgcolor="#FFFFFF" link="#FF0000" alink="#FF0000" vlink="#FF0000"> 
09.
 
10.
<table width="992px" border="0" cellspacing="0" cellpadding="0"> 
11.
         <tr height="500px" cellspacing="0" cellpadding="0"></tr> 
12.
		<td colspan="9" height="100%">hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo </td> 
13.
                 <td colstan="2" valign="bottom"><h2>logo</h2></td> 
14.
         <tr height="58px" cellspacing="0" cellpadding="0" valign="middle" align="center"> 
15.
                 <td width="50px" bgcolor="#00E0FF"></td> 
16.
                 <td width="164px" bgcolor="#00C0FF" border="0" onMouseover="this.style.backgroundColor='#FFFFFF'" onMouseout="this.style.backgroundColor='#00C0FF'"> 
17.
                 Home</td> 
18.
                 <td width="18px" bgcolor="#00A0FF" border="0"></td> 
19.
                 <td width="164px" bgcolor="#0060FF" border="0" onMouseover="this.style.backgroundColor='#FFFFFF'" onMouseout="this.style.backgroundColor='#0060FF'"> 
20.
                 Aktuell</td> 
21.
                 <td width="18px" bgcolor="#0040FF" border="0"></td> 
22.
                 <td width="164px" bgcolor="#0020FF" border="0" onMouseover="this.style.backgroundColor='#FFFFFF'" onMouseout="this.style.backgroundColor='#0020FF'"> 
23.
                 Arbeiten</td> 
24.
                 <td width="18px" bgcolor="#0000DF" border="0"></td> 
25.
                 <td width="164px" bgcolor="#00009F" border="0" onMouseover="this.style.backgroundColor='#FFFFFF'" onMouseout="this.style.backgroundColor='#00009F'"> 
26.
                 Biographie</td> 
27.
                 <td width="18px" bgcolor="#00E090" border="0"></td> 
28.
                 <td width="164px" bgcolor="#FFBF00" border="0" onMouseover="this.style.backgroundColor='#FFFFFF'" onMouseout="this.style.backgroundColor='#FFBF00'"> 
29.
                 Kontakt</td> 
30.
                 <td width="50px" bgcolor="#00C070"></td> 
31.
         </tr> 
32.
 
33.
 
34.
</table> 
35.
 
36.
</body> 
37.
</html>

das ganze kann man unter http://childrotion.ch.funpic.de anschauen wenn man auf der ersten Seite auf das graue "click" klickt.


So long,

Racer2004
Mitglied: 4263
08.04.2007 um 22:29 Uhr
also ich hab nun mal einen Fehler entdeckt: die table height .. wenn man die angibt klappts schonmal in IE, aber Firefox kommt immer noch nicht klar damit.

Die aktuelle Version:

01.
[...] 
02.
 
03.
<table width="992px" height="558px" border="0" cellspacing="0" cellpadding="0"> 
04.
         <tr height="500px" cellspacing="0" cellpadding="0"></tr> 
05.
		<td colspan="9" height="100%">hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo hallo </td> 
06.
                 <td colstan="2" valign="bottom"><h2>logo</h2></td> 
07.
         <tr height="58px" cellspacing="0" cellpadding="0" valign="middle" align="center"> 
08.
 
09.
[...]
PS:
Ich bin schon Stunden vor dem Problem gesessen, aber dass die table height fehlt ist mir erst jetzt beim erneuten lesen des Codes im Beitrag aufgefallen, sorry...
Bitte warten ..
Mitglied: 46010
13.04.2007 um 01:38 Uhr
hi,

height ist kein befehl gemäss html....

mit css läst sich das easy bewerkstelligen

<style type="text/css">
<!--
body, html, #wrapper{
padding: 0px;
height: 100%;
margin: 0px;
}
-->
</style>

der tabelle gibst du dann noch ne id, id="wrapper" und schon klappt das.

gruss c
Bitte warten ..
Mitglied: 4263
14.04.2007 um 12:41 Uhr
jup danke, funktioniert.

aber ich habe es aus funktionellen gründen nun mit frames gemacht.

-- solved --
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Problem mit Funktion und Combobox
Frage von Druide83Batch & Shell7 Kommentare

Hallo, habe mal wieder ein Powershellproblem bei dem ich nach mehreren Tests nicht mehr weiter weis. Bisher habe ich ...

Netzwerkmanagement
NAT mit IP Tables Frage
Frage von Pajo78Netzwerkmanagement5 Kommentare

Hallo Leute, bin neu hier und ich bitte um Nachsicht, falls ich irgendwie "auffalle", bitte Frage verschieben, wenn hier ...

Windows 7
Invalid partition table fehler
Frage von MarcysWindows 74 Kommentare

Hallo, ich habe ein Problem wo ich nicht mehr weiter weiß. Ich musste die Festplatte neu formatieren und Win ...

E-Mail
Lotus Notes, Problem mit HTML Mails
Frage von Jannis92E-Mail2 Kommentare

Moin Moin, wir verwenden im Unternehmen (leider) Lotus Notes. In einer Abteilung ist die Darstellung von HTML Mails sehr ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 1 TagMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner14 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...