Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit Typo3 DB Umlaute werden falsch angezeigt

Frage Entwicklung Datenbanken

Mitglied: SunziX

SunziX (Level 1) - Jetzt verbinden

20.02.2013 um 16:40 Uhr, 2605 Aufrufe, 4 Kommentare

Hallo liebe Community,

ich bin gerade dabei ein Paar Webs von einem Bekannten nach DomainFactory zu migrieren, leider gibt es bei einem Web (Typo3) ein Problem mit den Umlauten. Ich habe die DB schon expliziert mit UTF8 eingespielt, doch leider habe ich noch immer ein Problem mit den Umlauten.

Ich habe mir die DB mal angeguckt und als erstes fällt auf, dass sie aus einem bunten Mix aus MyISAM und InnoDB Tabellen besteht.

http://s14.directupload.net/file/d/3172/johj3twp_jpg.htm

Die DB habe ich fehlerfrei mittels mysqldump im Terminal erstellt.

Bin über jeden themabezogenen Tipp dankbar!

Viele Grüße,
SunziX
Mitglied: Hitman4021
20.02.2013 um 20:53 Uhr
Hallo,

sind die Tabellen eventuell nicht UTF8?
Mit welchem Charset läuft PHP?
War das Terminal auf dem exportiert wurde UTF8?

Gruß
Bitte warten ..
Mitglied: SunziX
20.02.2013 um 21:00 Uhr
Hallo,

und vielen Dank für deine schnelle Antwort, habe mir grade phpminiadmin.php installiert, kann ich die Daten darüber auslesen?
Bitte warten ..
Mitglied: Hitman4021
20.02.2013 um 21:21 Uhr
Hallo,

ja du siehst den Charset der Tabellen in PHP.
Und du kannst dir die Daten wie sie in der Datenbank sind anzeigen lassen.

Gruß
Bitte warten ..
Mitglied: SunziX
20.02.2013 um 21:45 Uhr
Vielen Dank,

ich muss erstmal schauen wie ich an die Daten kommen und melde mich morgen zurück ;)

LG
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Apache Server
gelöst Nach PHP-Update von 5.4 auf 5.6 werden Umlaute falsch dargestellt (2)

Frage von coltseavers zum Thema Apache Server ...

Exchange Server
Exchange OWA Problem Kennwort falsch (16)

Frage von Henere zum Thema Exchange Server ...

Batch & Shell
Altebekanntes Batch umlaute Problem (txt editor) (2)

Frage von Ritrivia zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...