Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit VLANs zwischen D-Link DES-3550 und DGS-3048

Frage Netzwerke

Mitglied: DanteDMC

DanteDMC (Level 1) - Jetzt verbinden

09.02.2007, aktualisiert 12.02.2007, 5163 Aufrufe, 5 Kommentare

Hallo,


ich habe folgendes Problem mit D-Link-Switchen:

Ich habe ein Netzwerk mit zwei DES-3550-Switchen. Auf den Switchen sind die VLANs 1 (default - klar) und 2 (auf den Ports 23 und 24 für den Druckerzugang eines externen Unternehmens) eingerichtet. Dementsprechend ist die Konfiguration der VLANs auf beiden Switchen folgendermaßen aufgebaut:

Das VLAN 1 ist bis auf die Ports 23 und 24 komplett untagged und auf "egress" eingestellt. Die Ports 23 und 24 sind tagged und "forbidden".

VLAN 2 ist gegenteilig eingestellt. Also die Ports 23 und 24 sind untagged und auf "egress", während alle anderen Ports auf tagged und forbidden stehen. Spezialfall hier: Der Port 49 (Uplink zwischen den beiden Switchen per LWL-Verbindung) ist noch auf tagged und "egress" um die VLAN-Infos zwischen den beiden Switchen auszutauschen.

Am Switch im Serverraum ist auf Port 24 ein Router angeschlossen - Port 23 ist für Testzwecke (Pings etc) reserviert. Am anderen Switch (in der Verwaltung) ist auf Port 24 ein Drucker und auf Port 23 noch ein Management-PC angeschlossen. Eine externe Firma druckt dann über den Router, durch das VLAN 2 auf den in der Verwaltung Drucker.

Läuft alles auch soweit super. Ich komme von den Ports 23 und 24 nicht ins VLAN 1 und von allen anderen Ports nicht in VLAN 2 - so wie es sein soll. TOP!


Nun aber zu meinem Problem. Einer der beiden Switche soll durch einen D-Link DGS-3048 Gigabit-Switch ersetzt werden (der im Serverraum). Auf diesem kann das VLAN 1 allerdings nicht konfiguriert werden (alles ausgegraut). Dementsprechend lassen sich auch die Einstellungen des DES-3550 der ausgetauscht werden soll nicht übernehmen. Beim Anlegen eines dritten VLANs komme ich mir dauernd mit meinen eigenen Tags in die Quere und irgendwie wollen die beiden Geräte auch nur über VLAN 1 kommunzieren. Habe beispielsweise mal auf beiden Switchen ein VLAN 2 komplett offen eingerichtet. Sobald ich VLAN 1 auf dem einen Switch aber "zu" mache, gibt es keine Kommunikation mehr - diese sollte dann ja eigentlich über VLAN 2 laufen.

Ich hab da gestern stundenlang dran gesessen und es einfach nicht hinbekommen. Die Aufgabenstellung ist soweit ja klar. Die beiden Switche (also der DGS-3048 und der DES-3550)sollen untereinander kommunzieren und das VLAN 2 soll vom restlichen Netz (VLAN 1) getrennt werden. Wie also genau würdet ihr den neuen DGS-3048 Switch einstellen, damit er mit der vorhandenen Konfig des DES-3550 läuft? Notfalls wäre auch eine komplett neue Konfig für beide Switche machbar - wär halt nur was Mehraufwand.

Wäre für Hilfestellungen und Vorschläge dankbar!

MFG
Dante
Mitglied: aqui
10.02.2007 um 00:39 Uhr
Das Problem sind wohl deine Endgeräteports ! Dort haben Tags nichts zu suchen ! Ein Endgerät kann 802.1q tagged Frames niemals lesen nur ein Switch !
Ein Tagging macht man nur auf dem Trunk, der beide Switches verbindet um hier die VLAN Information zu übertragen, damit packet auf dem empfangenden Switch wieder einem VLAN zugeordnet werden können.
Was du also machst ist ganz einfach:
Auf beiden Switches VLAN 1 und 2 einrichten und die Entgeräteports untagged den VLAN zuordnene. Den Verbindungslink auf tagged fürs VLAN 2 setzen ggf. auch fürs VLAN 1.
Der 802.1q Standard besagt das das Default VLAN immer untagged übertragen wird auf Trunks aber nicht alle Hersteller halten sich daran also ggf. wenn D-Link sich da anders verhält musst du VLAN1 natürlich auch auf tagged am Verbindungslink der Switches setzen.
Das sollte es gewesen sein.
Bitte warten ..
Mitglied: DanteDMC
11.02.2007 um 21:21 Uhr
Nein, nein, dass ist nicht das Problem. Es gibt gar keine Tags zwischen den Endgeräten und den Switchen, das hab ich schon beachtet, sonst hätte es in der ursprünglichen Zusammensetzung des LANs ja auch nicht geklappt.
Bitte warten ..
Mitglied: aqui
12.02.2007 um 00:59 Uhr
Das ist ja genau das was ich meine: Einen tagged Link gibt es NUR zwischen den Switches auf der Switch to Switch Verbindung !
Dann weisst du ueber das Setup jeweils die Endgeraeteports den VLANs zu...das wars. Damit hast du dann 2 getrennte Broadcastdomains sprich VLANs und alles sollte klappen wie gewohnt...
Bitte warten ..
Mitglied: DanteDMC
12.02.2007 um 10:11 Uhr
VLAN 1 lässt sich auf dem neuen Switch aber nicht konfigurieren, dass ist ja gerade mein Problem ;) Da ist alles ausgegraut.
Bitte warten ..
Mitglied: aqui
12.02.2007 um 21:09 Uhr
Ja VLAN 1 ist scheinbar das default VLAN das du nicht entfernen kannst. Ist ja aber nicht so schlimm, das kannst du ja so lassen und ziehst da nur die Ports für dein VLAN 2 von ab....
Ghet das nicht musst du sonst noch ein VLAN 3 aufsetzen und auf dem anderen Switch auch damit es wieder konsistetnt ist. Dann arbeitets du halt mit deiner Konfig in VLAN 2 und VLAN 3. Ich bin mir aber sicher das die erste Variante auch problemlos klappt !
Bitte warten ..
Ähnliche Inhalte
Monitoring
CLI D-Link DGS 3000
gelöst Frage von 121851Monitoring10 Kommentare

Hallo zusammen, habe eine Frage und finde grade keine Lösung. Bin per ssh auf einem D-Link DGS 3000 und ...

Netzwerkmanagement
D-Link und VLAN
gelöst Frage von Bastler0815Netzwerkmanagement16 Kommentare

Hallo zusammen, ich habe schon viele Einträge gelesen und auch viele probiert, leider kam ich nicht an mein gewünschtes ...

Switche und Hubs
D-Link DGS-1210 per SNMP konfigurieren
gelöst Frage von lasterSwitche und Hubs9 Kommentare

Hallo, habe einen DGS-1210(-48 Rev. D1, F/W Ver.: 4.0.0.026) und will ihn per SNMP konfigurieren/steuern (per macmon). Was funktioniert: ...

LAN, WAN, Wireless
VLAN - D-Link DGS1210 und PFSense
gelöst Frage von bitejanLAN, WAN, Wireless6 Kommentare

Hallo, nach den üblichen Stünden der Fehlersuche, wende ich mich mal vertrauensvoll ans Forum. Dieses Tutorial habe ich gelesen: ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 8 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 13 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 13 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Von rj11 auf rj45
Frage von jensgebkenLAN, WAN, Wireless19 Kommentare

Hallo Gemeinschaft, könnt ihr mir vielleicht bei der anfertigung eines Kabels helfen - habe ein rj 11 stecker und ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Windows Server
Remotesteuerung der Sitzung (Kennung XX) fehlgeschlagen
gelöst Frage von Stefan91Windows Server14 Kommentare

Hallo Zusammen, seit kurzem bekomme ich oben genannte Fehlermeldung, wenn ich versuche eine Remotesitzung über den Taskmanager fernzusteuern (Rechtsklick ...