Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit VLANs zwischen D-Link DES-3550 und DGS-3048

Frage Netzwerke

Mitglied: DanteDMC

DanteDMC (Level 1) - Jetzt verbinden

09.02.2007, aktualisiert 12.02.2007, 5139 Aufrufe, 5 Kommentare

Hallo,


ich habe folgendes Problem mit D-Link-Switchen:

Ich habe ein Netzwerk mit zwei DES-3550-Switchen. Auf den Switchen sind die VLANs 1 (default - klar) und 2 (auf den Ports 23 und 24 für den Druckerzugang eines externen Unternehmens) eingerichtet. Dementsprechend ist die Konfiguration der VLANs auf beiden Switchen folgendermaßen aufgebaut:

Das VLAN 1 ist bis auf die Ports 23 und 24 komplett untagged und auf "egress" eingestellt. Die Ports 23 und 24 sind tagged und "forbidden".

VLAN 2 ist gegenteilig eingestellt. Also die Ports 23 und 24 sind untagged und auf "egress", während alle anderen Ports auf tagged und forbidden stehen. Spezialfall hier: Der Port 49 (Uplink zwischen den beiden Switchen per LWL-Verbindung) ist noch auf tagged und "egress" um die VLAN-Infos zwischen den beiden Switchen auszutauschen.

Am Switch im Serverraum ist auf Port 24 ein Router angeschlossen - Port 23 ist für Testzwecke (Pings etc) reserviert. Am anderen Switch (in der Verwaltung) ist auf Port 24 ein Drucker und auf Port 23 noch ein Management-PC angeschlossen. Eine externe Firma druckt dann über den Router, durch das VLAN 2 auf den in der Verwaltung Drucker.

Läuft alles auch soweit super. Ich komme von den Ports 23 und 24 nicht ins VLAN 1 und von allen anderen Ports nicht in VLAN 2 - so wie es sein soll. TOP!


Nun aber zu meinem Problem. Einer der beiden Switche soll durch einen D-Link DGS-3048 Gigabit-Switch ersetzt werden (der im Serverraum). Auf diesem kann das VLAN 1 allerdings nicht konfiguriert werden (alles ausgegraut). Dementsprechend lassen sich auch die Einstellungen des DES-3550 der ausgetauscht werden soll nicht übernehmen. Beim Anlegen eines dritten VLANs komme ich mir dauernd mit meinen eigenen Tags in die Quere und irgendwie wollen die beiden Geräte auch nur über VLAN 1 kommunzieren. Habe beispielsweise mal auf beiden Switchen ein VLAN 2 komplett offen eingerichtet. Sobald ich VLAN 1 auf dem einen Switch aber "zu" mache, gibt es keine Kommunikation mehr - diese sollte dann ja eigentlich über VLAN 2 laufen.

Ich hab da gestern stundenlang dran gesessen und es einfach nicht hinbekommen. Die Aufgabenstellung ist soweit ja klar. Die beiden Switche (also der DGS-3048 und der DES-3550)sollen untereinander kommunzieren und das VLAN 2 soll vom restlichen Netz (VLAN 1) getrennt werden. Wie also genau würdet ihr den neuen DGS-3048 Switch einstellen, damit er mit der vorhandenen Konfig des DES-3550 läuft? Notfalls wäre auch eine komplett neue Konfig für beide Switche machbar - wär halt nur was Mehraufwand.

Wäre für Hilfestellungen und Vorschläge dankbar!

Mit freundlichen Grüßen
Dante
Mitglied: aqui
10.02.2007 um 00:39 Uhr
Das Problem sind wohl deine Endgeräteports ! Dort haben Tags nichts zu suchen ! Ein Endgerät kann 802.1q tagged Frames niemals lesen nur ein Switch !
Ein Tagging macht man nur auf dem Trunk, der beide Switches verbindet um hier die VLAN Information zu übertragen, damit packet auf dem empfangenden Switch wieder einem VLAN zugeordnet werden können.
Was du also machst ist ganz einfach:
Auf beiden Switches VLAN 1 und 2 einrichten und die Entgeräteports untagged den VLAN zuordnene. Den Verbindungslink auf tagged fürs VLAN 2 setzen ggf. auch fürs VLAN 1.
Der 802.1q Standard besagt das das Default VLAN immer untagged übertragen wird auf Trunks aber nicht alle Hersteller halten sich daran also ggf. wenn D-Link sich da anders verhält musst du VLAN1 natürlich auch auf tagged am Verbindungslink der Switches setzen.
Das sollte es gewesen sein.
Bitte warten ..
Mitglied: DanteDMC
11.02.2007 um 21:21 Uhr
Nein, nein, dass ist nicht das Problem. Es gibt gar keine Tags zwischen den Endgeräten und den Switchen, das hab ich schon beachtet, sonst hätte es in der ursprünglichen Zusammensetzung des LANs ja auch nicht geklappt.
Bitte warten ..
Mitglied: aqui
12.02.2007 um 00:59 Uhr
Das ist ja genau das was ich meine: Einen tagged Link gibt es NUR zwischen den Switches auf der Switch to Switch Verbindung !
Dann weisst du ueber das Setup jeweils die Endgeraeteports den VLANs zu...das wars. Damit hast du dann 2 getrennte Broadcastdomains sprich VLANs und alles sollte klappen wie gewohnt...
Bitte warten ..
Mitglied: DanteDMC
12.02.2007 um 10:11 Uhr
VLAN 1 lässt sich auf dem neuen Switch aber nicht konfigurieren, dass ist ja gerade mein Problem ;) Da ist alles ausgegraut.
Bitte warten ..
Mitglied: aqui
12.02.2007 um 21:09 Uhr
Ja VLAN 1 ist scheinbar das default VLAN das du nicht entfernen kannst. Ist ja aber nicht so schlimm, das kannst du ja so lassen und ziehst da nur die Ports für dein VLAN 2 von ab....
Ghet das nicht musst du sonst noch ein VLAN 3 aufsetzen und auf dem anderen Switch auch damit es wieder konsistetnt ist. Dann arbeitets du halt mit deiner Konfig in VLAN 2 und VLAN 3. Ich bin mir aber sicher das die erste Variante auch problemlos klappt !
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Switche und Hubs
gelöst 2 VLANs, tragged und mit link aggregation oder Verbinden oder einzeln (1)

Frage von ADORSE zum Thema Switche und Hubs ...

Router & Routing
gelöst Routing - Netzwerk Problem - zwischen Filiale und Zentrale (12)

Frage von clonex zum Thema Router & Routing ...

LAN, WAN, Wireless
Kommunikation zwischen Fritz-Lan und TP-link Lan (2)

Frage von TheITGuy zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook Link Problem (5)

Frage von bytetix zum Thema Outlook & Mail ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...