Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Problem mit zwei Netzwerken in einem Rechner.

Frage Netzwerke

Mitglied: Per22121979

Per22121979 (Level 1) - Jetzt verbinden

21.06.2007, aktualisiert 22.06.2007, 4638 Aufrufe, 17 Kommentare

Mein Problem ist folgendes. Ich habe folgende Hardware am laufen.

Rechner 1

Athlon 64
Win XP Home SP2

D-Link USB Stick für Verbindung mit dem Router \ feste IP : 192.168.2.185 SNM : 255.255.255.0 GW : 192.168.2.1
Onboard Netzwerk Adapter zur Verbindung mit dem zweiten Rechner \ Automatisch zugewiesene private IP-Adresse : 169.254.19.156 SNM : 255.255.0.0 GW : leer


Rechner 2

Athlon 1333
Win XP Home SP2

D-Link USB Stick für Verbindung mit dem Router \ feste IP : 192.168.2.163 SNM : 255.255.255.0 GW : 192.168.2.1
Intel Onboard Netzwerk Adapter zur Verbindung mit dem ersten Rechner \ Automatisch zugewiesene private IP-Adresse : 169.254.74.170 SNM : 255.255.0.0 GW : leer

Router D-Link Wlan Router 54 Mbit : IP : 192.168.2.1

ICh möchte das beide Rechner über ihre USB-WLan-Sticks mit dem Router verbinden um ins Internet zu gehen.
Das tun sie auch ganz brav.

Und ich möchte für das Tauschen von Dateien zwischen den beiden Rechnern die Lan-Karten benutzen zwecks größerer Datenübertragungsrate und weniger Verbindungsabbrüchen.

Allerdings laufen alle Verbindungen und Anfragen immer über den Router. Die Netzwerkkarten liegen quasi brach. Wie kann ich das änern?
Mitglied: yumper
21.06.2007 um 18:37 Uhr
erstelle eine datei

\windows\system32\drivers\etc\hosts auf beiden rechner

inhalt

192..... (ip-adresse pc1) pc1
192..... (ip-adresse pc2) pc2

beide netwrekkarten haben eine feste IP Adresse z.b 192.168.0.1 und ....... .2

dann sollte es auch klappen
Bitte warten ..
Mitglied: spacyfreak
21.06.2007 um 18:42 Uhr
  • verbinde die PCs Netzwerkkarten mit Crossoverkabel (nicht Patchkabel)
  • gib PC1 eine IP wie z. B. 10.0.0.1
  • gib PC2 eine IP wie z. B. 10.0.0.2
  • gib kein Gateway an bei beiden Netzwerkkarten
  • gib keinen DNS an bei beiden

  • in die Datei c:\windows\system32\drivers\etc\hosts trägst du ein (mit notepad bearbeiten)

10.0.0.1 rechner1
10.0.0.2 rechner1

Dann kannst Du von rechner1 auf rechner2 zugreifen mit

\\rechner2\freigabename

Statt rechner1 und rechner2 kannst du freilich auch beliebige andere Namen eintragen.
Bitte warten ..
Mitglied: Per22121979
21.06.2007 um 19:03 Uhr
Nein. Er zieht trotzdem alles über WLan.

Wie richte ich denn eine statische Route zwischen den beiden NEtzwerkkarten ein? Das sollte doch funktionieren, oder?

Die IP´s sind jetzt 10.0.0.1 bzw. 10.0.0.2

Das Subnetz demzufolge 255.0.0.0
Bitte warten ..
Mitglied: Egbert
21.06.2007 um 19:26 Uhr
Hallo


dann mach doch mal einen Route print, dann siehst Du die routen.

mit route add kannst Du staische Routen eintragen


Gruß
Egbert
Bitte warten ..
Mitglied: yumper
21.06.2007 um 19:31 Uhr
hast du denn ein cross over netzwerkkabel zwischen den Pc´s ??
Bitte warten ..
Mitglied: aqui
21.06.2007 um 19:32 Uhr
Statisch Routen ist unsinnig, das löst dein Problem nicht. Du solltest die Bindungsreihenfolge der Karten oder die Metrik der LAN Verbindung erhöhen. Wie das geht siehst du hier:

http://support.microsoft.com/kb/894564/de
Bitte warten ..
Mitglied: Per22121979
21.06.2007 um 20:34 Uhr
Auch das hat nix gebracht. was spricht gegen eine route?

Die beiden pc´s sind über patchkabel mit switch angeschlossen..
Bitte warten ..
Mitglied: spacyfreak
21.06.2007 um 20:55 Uhr
Es werden doch automatisch Routen angelegt, sobald die Netzwerkkarten IPs verpasst bekommen. Siehe route print.

Ansonsten kannst statische Routen anlegen mit

PC1:
Netzwerkkarte kriegt 10.0.0.1 verpasst mit 255.0.0.0
Route anlegen mit Start...Ausführen...cmd ENTER

route ADD -p 10.0.0.2 MASK 255.0.0.0 10.0.0.1 METRIC 3 IF 10.0.0.1

PC2:
Netzwerkkarte kriegt 10.0.0.2 verpasst mit 255.0.0.0
route ADD -p 10.0.0.1 MASK 255.0.0.0 10.0.0.2 METRIC 3 IF 10.0.0.2

Das -p bewirkt, dass die route auch nach PC neustart erhalten bleibt.

Hast du geprüft, ob
  • die Netzwerkkarten aktiviert sind?
  • einen Link haben (grünes Lämpchen)
  • am Switch Link angezeigt wird?
Bitte warten ..
Mitglied: Per22121979
21.06.2007 um 21:25 Uhr
Ich bekomme folgende Fehlermeldung :

hinzufügen der route fehlgeschlagen: der angegebene maskenparameter ist ungältig. (ziel & maske) != ziel.

Alle anderen Punkte habe ich gecheckt. Ist alles IO.
Bitte warten ..
Mitglied: spacyfreak
21.06.2007 um 21:26 Uhr
Ich hab hier selber zwei notebooks, die per WLAN mit dem Inet kommunizieren.
Ich probier das mal aus, interessiert mich jetzt so langsam. hehe.
Ich melde mich wenn ich die Lösung habe.
Bitte warten ..
Mitglied: spacyfreak
21.06.2007 um 21:46 Uhr
Also, die Lösung ist ganz einfach.

PC1
IP 10.0.0.1
SN-Maske 255.0.0.0

PC2
IP 10.0.0.2
SN-Maske 255.0.0.0

Nach der Konfiguration Netzwerkkarten deaktivieren u. wieder aktivieren!!!
Die Netzwerkkarten bzw. TCP/IP ist schlau genug, anliegende Netze zu erkennen u. die notwendigen Routen automatisch anzulegen.
Ich komme grade mit beiden PCs bei mir daheim sowohl ins Inet über WLAN, und gleichzeitig kann ich auf den jeweils anderen PC direkt zugreifen.
Probier mal nen ping auf den anderen PC.
ping 10.0.0.2 -t
Schau dir die Route an mit
route print
Kann gut sein, dass die Windows Firewall bei dir blockt! Deaktivier die mal.

Wie gesagt legen die Rechner automatisch Routen an.
Default Gateway musst du wie gesagt auch nicht angeben.


route print Beispiel von PC2 (hat bei mir die 10.0.0.2)
Die 10er route wird automatisch angelegt!!!
Da musst garnix anlegen.

Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.178.1 192.168.178.24 25
10.0.0.0 255.0.0.0 10.0.0.2 10.0.0.2 20
10.0.0.2 255.255.255.255 127.0.0.1 127.0.0.1 20
10.255.255.255 255.255.255.255 10.0.0.2 10.0.0.2 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.178.0 255.255.255.0 192.168.178.24 192.168.178.24 25
192.168.178.24 255.255.255.255 127.0.0.1 127.0.0.1 25
192.168.178.255 255.255.255.255 192.168.178.24 192.168.178.24 25
224.0.0.0 240.0.0.0 10.0.0.2 10.0.0.2 20
224.0.0.0 240.0.0.0 192.168.178.24 192.168.178.24 25
255.255.255.255 255.255.255.255 10.0.0.2 10.0.0.2 1
255.255.255.255 255.255.255.255 192.168.178.24 192.168.178.24 1
Standardgateway: 192.168.178.1
Bitte warten ..
Mitglied: Per22121979
22.06.2007 um 05:09 Uhr
Scheinbar habe ich ein Phänomen entdeckt. Aber mein Lan bleibt weiter unbenutzt. Trotz der angelegten Routen. Der gesamte Datenverkehr geht weiterhin über das WLAN.

Hier mal die route print von PC1 und PC 2

PC1 :

http://www.per-thormann.de/pc1.JPG

PC2 :

http://www.per-thormann.de/pc2.JPG

Steh voll auf dem Schlauch.
Bitte warten ..
Mitglied: spacyfreak
22.06.2007 um 06:33 Uhr
Deaktiviert mal bei beiden das WLAN. Kannst Du die Rechner dann untereinander pingen?
ping 10.0.0.1
Anschliessend WLAN Adapter wieder aktivieren.

Benutze dann für den Freigabezugriff die 10er IP des jeweils anderen PCs, und nicht die Hostnamen.
Also z. B. \\10.0.0.2\Freigabename statt \\Hostname\Freigabe
Oder eben in die /etc/hosts die oben benannten Eintragungen machen, dann kannst auch einen Namen verwenden.


Die Rechner MÜSSEN wenns an das 10er Netz addressiert ist die Pakete direkt über die Netzwerkkarte senden - dafür ist die Routingtabelle ja da.


Hast du mal die XP Firewall deaktiviert zum testen?
Bitte warten ..
Mitglied: Per22121979
22.06.2007 um 15:38 Uhr
Problem gelöst. Habe mir heute mal spaßenshalber ein Crossoverkabel gekauft und den ganzen KRempel mit Switch und so rausgenommen. Dann habe ich die Netzlaufwerke neu verbunden und statt des PC-Namens habe ich die IP angegeben.

Und siehe da. Es läuft.

Danke allen hier für die HIlfe.
Bitte warten ..
Mitglied: yumper
22.06.2007 um 16:17 Uhr
und wenn du die hosts datei richtig anlegst

geht es auch mit den pc namen
Bitte warten ..
Mitglied: aqui
22.06.2007 um 20:00 Uhr
...und wenn er jetzt noch den Thread oben als gelöst markiert sind alle zufrieden

( http://www.administrator.de/index.php?faq=32 )
Bitte warten ..
Mitglied: spacyfreak
22.06.2007 um 20:34 Uhr
...und wenn er jetzt noch den Thread oben als
gelöst markiert sind alle zufrieden

(
http://www.administrator.de/index.php?faq=32
)


...und der letzte macht das Licht aus.
"KLACK!!". Schon erledigt.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...