Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit 2 Netzwerkkarten in einem Server

Frage Netzwerke Router & Routing

Mitglied: nobocom

nobocom (Level 1) - Jetzt verbinden

15.09.2005, aktualisiert 16.09.2005, 7802 Aufrufe, 7 Kommentare

Ich habe zwei Netzwerkkarten in einem Server. Sind beide aktiviert kommt es zu massiven Ausfällen.

Konstellation:
In einem Server befinden sich zwei Netzwerkkarten.

LAN Intern
192.168.120.4 <- Adresse für Internen Zugriff
255.255.255.0
192.168.120.70 <- Gateway für Zugriff über Standleitung

Web-LAN
192.168.120.94 <- Adresse für Web-Zugriff
255.255.255.0
192.168.120.151 <- GatewayPC für Internet, von da aus über VPN-Router ins WWW
Alle Karten fahren mit dem aktuellsten Treiber.

Die erste Netzwerkkarte (internes LAN) bedient Anfragen sowohl von innerhalb, als auch Anfragen die über die Standleitung (Cisco-Router) von einer Zweigstelle herein kommen.
Die zweite Netzwerkkarte (Web) geht über einen Gateway-PC (inkl. Firewall, Virenschutz, etc.) auf einen VPN-Router. Dort werden von Aussenstellen via VPN-Tunnel Anfragen gestellt.

Problem:
Wird die sog. Web-Karte aktiviert, kommt es zu massiven Ausfällen im internen LAN.

Ich habe einmal die Routingtabelle des Servers angehängt.


Meine Frage ist nun: wie kann ich das Problem am einfachsten lösen. Würde es schon reichen die Netzwerkkarten in verschiedene Segmente zu legen z.b. 192.168.120.xxx und 192.168.121.xxx ?
Oder kann ich über das Routing zu einer Lösung kommen?


Schnittstellen
0x1 Loopback
0x1000003 Intel Pro/1000 <-Internes LAN
0x3000004 Intel Pro/1000 <-Web-LAN

Im System vorhandene Routen

Aktive Routen
Netzwekziel Netzwerkmaske Gateway Schnittstelle Anzahl

0.0.0.0 0.0.0.0 192.168.120.70 192.168.120.4 4
0.0.0.0 0.0.0.0 192.168.120.151 192.168.120.94 2
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.120.0 255.255.255.0 192.168.120.4 192.168.120.4 1
192.168.120.0 255.255.255.0 192.168.120.94 192.168.120.94 2
192.168.120.4 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.120.94 255.255.255.255 127.0.0.1 127.0.0.1 2
192.168.120.255 255.255.255.255 192.168.120.4 192.168.120.4 1
192.168.120.255 255.255.255.255 192.168.120.94 192.168.120.94 2
224.0.0.0 224.0.0.0 192.168.120.4 192.168.120.4 1
224.0.0.0 224.0.0.0 192.168.120.94 192.168.120.94 2
255.255.255.255 255.255.255.255 192.168.120.4 192.168.120.4 1

Ständige Routen:
keine



Routen bei deaktivierter WEB-Karte

Aktive Routen
0.0.0.0 0.0.0.0 192.168.120.70 192.168.120.4 4
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.120.0 255.255.255.20 192.168.120.4 192.168.120.4 1
192.168.120.4 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.120.255 255.255.255.255 192.168.120.4 192.168.120.4 1
224.0.0.0 224.0.0.0 192.168.120.4 192.168.120.4 1
255.255.255.255 255.255.255.255 192.168.120.4 192.168.120.4 1
Standardgateway: 192.168.120.70

Ständige Routen:
keine


Gruß nobocom
Mitglied: IceBeer
15.09.2005 um 11:47 Uhr
Hi,

ich bin zwar alles andere als Experte, aber meine was im Kopf zu haben dass es eine schlechte Idee ist den beiden Karten eine Addresse aus dem gleichen IP-Band zu geben...

Kommt der Routing Dienst nicht ein klein wenig durcheinander????

Mit freundlichen Grüßen IceBeer
Bitte warten ..
Mitglied: 16640
15.09.2005 um 11:58 Uhr
Gib' den beiden Karten Adressen aus unterschiedlichen Netzen!
Bitte warten ..
Mitglied: mrtux
15.09.2005 um 13:02 Uhr
Hallo !

Gib' den beiden Karten Adressen aus
unterschiedlichen Netzen!

Ich schliesse mich an und vervollständige:

Das Routing von einem Netz ins andere richtig setzen sonst wird es nix !
Stichwort: Gateway

mr. tux
Bitte warten ..
Mitglied: nobocom
15.09.2005 um 15:52 Uhr
Die beiden Karten liegen jetzt in versch. IP-Segmenten. Trotzdem: Sobald die 2. Karte aktiv geht fällt das andere Netz aus.
Sobald ich die Karte deaktiviere geht´s wieder.
Bitte warten ..
Mitglied: 16640
16.09.2005 um 10:53 Uhr
mehr Details bitte, am liebsten erstmal die Ausgabe von IPCONFIG /ALL auf der Kommandozeile.
Bitte warten ..
Mitglied: IceBeer
16.09.2005 um 11:26 Uhr
Hi,

was passiert eigentlich wenn du nur die 2. Karte aktivierst????? Vielleicht hat die auch einfach nenn Macken ab (MAC-Adresse 00-00-00-00-00-00 oder so)

Mit freundlichen Grüßen IceBeer
Bitte warten ..
Mitglied: nobocom
16.09.2005 um 12:44 Uhr
Hallo,

vielen Dank für eure Antworten. Wir haben gestern nochmal alles getestet und auf die jeweiligen IP Adressen Laufwerke gemappt und BurnIn Test drüber laufen lassen.....
Ich weiß nicht warum, aber alles funktionierte und heute scheint der Betrieb (bis jetzt) störungsfrei mit aktivierter 2.Netzwerkkarte im Adressbereich 192.168.125/0 zu laufen.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...