Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit IF im Batchmodus

Frage Entwicklung Batch & Shell

Mitglied: Vip1975

Vip1975 (Level 1) - Jetzt verbinden

19.01.2007, aktualisiert 24.04.2007, 3125 Aufrufe, 4 Kommentare

Syntax hin und her ?!?!

Hallo,

ich muss Backups übers netzwerk erstellen. Hierbei handelt es sich über Datenbanken auf einen Datenbankserver die ich auf einen Citrix Server kopieren muss. Bevor ich die Datenbank sichern kann prüfe ich zuerst ob die auch hochgefahren ist. (Es handelt sich also beim Backup um einen "Live" Backup)

Hier mein Code:

CALL X:\BACKUP\Admin\_test_verb.cmd ---- Hier wird versuch die Datenbank anzupingen

Wenn der Ping erfolgreich war (also errorlevel 0) dann gehts weiter

if %ERRORLEVEL% == 0 (
CALL X:\BACKUP\Admin\_dbsicherung.cmd
echo Ping zur Datenbank %QUELLE% erfolgreich > %PFAD%\%QUELLE%.txt
echo %Time%: database backup (%QUELLE%) done >> %Log%
) else (
echo %Time%: database backup (%QUELLE%) failed >> %Log%
)

Wenn ich es so im Batchmodus ausführe funktionierts, allerdings im sheduledtasks nicht ?!

Kann mir jemand sagen was an den Syntax nicht stimmt

Mfg.
Lukas
Mitglied: Biber
19.01.2007 um 09:51 Uhr
Moin Vip1975,

Kann mir jemand sagen was an den Syntax nicht stimmt
Liegt wahrscheinlich nicht an den Syntax... der ist fast perfekt.

Wahrscheinlichster Fehler ist, dass für den als Task gestarteten Job gar kein Laufwerk X: existiert. Woher soll er es kennen?.

Nimm ein lokales Laufwerk statt X:\ -oder- einen UNC-Pfad ("\\einServer\eineFreigabe").

Grüße
Biber
Bitte warten ..
Mitglied: Vip1975
19.01.2007 um 11:53 Uhr
Hallo Biber,

du hast Recht ... der Fehler lag tatsächlich im Syntax .... Als ich die "(" und ")" neben die Quellenangabe gelöscht habe, funktionierte es. Also von (%QUELLE%) in %QUELLE%. Ich dachte mit Echo muss alles ausgegeben werden, aber da scheiterte es, allerdings nur in Sheduled Task. Wenns so ausgeführt wird, funktionierts trotzdem.

Danke nochmal

Mfg.
Lukas
Bitte warten ..
Mitglied: Biber
19.01.2007 um 12:36 Uhr
Moin Lukas,

Fussnote:
Sollte es Dir aus ästhetischen Gründen doch wichtig sein, dass die runden Klammern mit im *.Log erscheinen, dann kannst/musst Du diese Klammern mit einer Caret ("^") maskieren.

Also statt
Jetzt: Echo ......von (%QUELLE%) in ....
Besser: Echo ......von ^(%QUELLE%^) in ....
Dann kommt der CMD-Interpreter nicht durcheinander.

Grüße
Biber
Bitte warten ..
Mitglied: Vip1975
24.04.2007 um 12:22 Uhr
Hallo Biber,


danke nach mal .... klappt alles 100% ;)

Mfg.
Lukas
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
gelöst Crontab mit Shell Probleme (9)

Frage von mschaedler1982 zum Thema Batch & Shell ...

Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

Windows 10
gelöst VPN Verbindung Probleme (7)

Frage von Yeter2 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...