Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme bei Benutzern mit Smartcard

Frage Microsoft Windows Server

Mitglied: Badger

Badger (Level 2) - Jetzt verbinden

20.12.2013, aktualisiert 09:44 Uhr, 2482 Aufrufe, 5 Kommentare

Hallo Leute!

Meine Struktur:
AD, DC: Server 2011
TerminalServer: Server 2012
TerminalClients: Win 7 embedded


Folgendes Problem:
Die Anmeldung per Smartcard funktioniert eigentlich relativ problemlos.
Hin und wieder habe ich allerdings das Problem, dass ohne ersichtlichen Grund die User mit Smartcard nicht mehr funktionieren. Das sieht dann so aus, dass (die bereits angemeldeten User) keine Netzwerkprogramme mehr öffnen können usw.
User die sich neu Anmelden wollen, bekommen immer nur dieses Bild zu sehen:

17f7f0ab2f36ff7dc02ca680f9974794 - Klicke auf das Bild, um es zu vergrößern

Es bleibt einfach immer bei "Anderer Benutzer" stehen und ändert sich nicht auf den Anmeldenamen.
Melde ich mich mit normalen Anmeldedaten an (also ohne Smartcard) funktioniert alles ohne Probleme.

Wenn ich nach diesem Problem den TerminalServer neu starte, ist das Problem behoben.

Hat hier wer eine Idee für mich, wie ich dem Problem auf die schliche kommen könnte?


Danke im Voraus
Patrick
Mitglied: Badger
15.01.2014 um 08:03 Uhr
Konnte heute feststellen, dass immer wenn dieses Problem auftritt, im Tastmanager die Benutzernamen (4) erscheinen:

c5fdcefb4df942b15289af4f71e2c373 - Klicke auf das Bild, um es zu vergrößern

Weißt wer, woher die kommen?


Grüße
Patrick
Bitte warten ..
Mitglied: Badger
30.01.2014 um 13:43 Uhr
Lt. der Microsoft Hotline soll das Problem durch diesen Hotfix gelöst werden:
http://support.microsoft.com/kb/2881993/en-us

Ich werde weiter berichten, ob dies das Problem nun behebt.
Bitte warten ..
Mitglied: Badger
07.03.2014 um 11:24 Uhr
Zitat von Badger:

Lt. der Microsoft Hotline soll das Problem durch diesen Hotfix gelöst werden:
http://support.microsoft.com/kb/2881993/en-us

Ich werde weiter berichten, ob dies das Problem nun behebt.

Leider hilft dieser Hotfix auch nicht weiter.
Mal schauen, was Microsoft noch für Lösungen anbietet...
Bitte warten ..
Mitglied: Badger
31.03.2014, aktualisiert 13.04.2015
Ich habe nun die Registry Keys
  • Certificate
  • X509 Certificate
  • X509 Certificate2
  • X509 Certificate ID

unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM gelöscht (anschließend natürlich neu starten) und prinzipiell eingestellt, dass der Terminalserver alle 3 Tage automatisch neu startet.
Seither konnte ich das Problem nicht wieder feststellen.
Bitte warten ..
Mitglied: Badger
20.04.2015, aktualisiert um 12:06 Uhr
Wir haben mittlerweile den Terminalserver auf 2012R2 gewechselt.
Auch da hatten wir gleich von Anfang an ähnliche Probleme. Leider half aber hier das Löschen der X509 Certificate nichts.

Die Probleme zeigten sich dadurch, dass tlw. die User die Fehlermeldung "Der angeforderte Vorgang konnte nicht ausgeführt werden, da die Remotedesktopdienste derzeit ausgelastet sind" bekamen.

Auch hier war dann im Taskmanager der ominöse User "4" zu sehen.

Mittels handle.exe konnte ich feststellen, dass für den "Problemuser" bereits Dateien registriert wurden, der User ab nicht im Taskmanager als solcher angezeigt wird (sondern als User "4").
Somit funktionierte auch ein Reset der Session mittels "reset session" nicht.

Nach einigen Schriftverkehr mit Microsoft wurde das Problem zwischen RDP Protokol Stack <> Smartcard Umleitung eingegrenzt.

Da es in der Zwischenzeit einen neuen Treiber für den Kartenleser als auch für die Smartcards gab, habe ich diese auf allen Clients als auch Terminalserver installiert.
Und siehe da: das Problem ist behoben!
Bitte warten ..
Ähnliche Inhalte
Cloud-Dienste
Probleme mit GoogleMail (Trello und Teambay)

Frage von PatrickKipp84 zum Thema Cloud-Dienste ...

Windows Server
RFID SmartCard Anmeldung ohne PIN (8)

Frage von podogu zum Thema Windows Server ...

Windows Server
Yoursecurecloud.de Probleme mit Pfaden (6)

Frage von WPFORGE zum Thema Windows Server ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

CMS
Lokales Wordpress im LAN - wie aufsetzen? (15)

Frage von Static zum Thema CMS ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...