Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit DNS im Netzwerk

Frage Microsoft Windows Netzwerk

Mitglied: batman00

batman00 (Level 2) - Jetzt verbinden

03.01.2006, aktualisiert 05.01.2006, 4899 Aufrufe, 20 Kommentare

Hallo,
ich hab ein Problem mit meinem DNS, woher ich vermute das ich Replikationsprobleme habe..
Wenn ich ein nslookup mache, dann setzt er automatisch meine Internetdomaine dahinter. Also Firmenname.com

Beispiel:
Ich mache in der DOS Box ein nslookup web.de
er macht darauf web.de.FIRMENNAME.com, sodass ich immer die IP Adresse unserer Homepage im Internet bekomme...

Und somit vermute ich auch, das ich Porbleme mit der Replikation habe, denn ich einen server über den dns anpingen möchte, dann setzt er wieder diese FIRMENNAME.com dahinter...

pinge ich hingegen nur den Namen an, also meines erachtens wins, dann bekomm ich die richtige ip...

Das ist doch sicherlich wieder ein scheiss Hacken den ich deaktivieren muss, aber nicht finde.
Mitglied: 14078
03.01.2006 um 15:06 Uhr
netzwerkkarte testweise:

TCP/IP -> ERWEITERT -> DNS -> Übergeordnete Suffixe des Primären ....

deaktivieren, also damit mal spielen....
Bitte warten ..
Mitglied: batman00
03.01.2006 um 15:13 Uhr
Hm, habs jetzt an meinem Rechner versucht. Passiert trotzdem. Ich versteh halt nicht das ein ping funktioniert, sobald ich aber nslookup mache er den dns namen nach jedem server usw anhängt... Und das ist ja an allen Clients und Servern....
Bitte warten ..
Mitglied: 14078
03.01.2006 um 15:16 Uhr
gut, das irgendwas am dns nicht richtig eingestellt ist steht ausser frage, hiermit haettest du aber erstmal an deiner kiste was testen koennen...

auch wenn du die anderen moeglichkeiten im DNS feld nutzt passiert nichts ?
Bitte warten ..
Mitglied: batman00
03.01.2006 um 15:25 Uhr
Leider nein. Alle kombinationen ausprobiert. Immer das gleiche Problem... Ping geht, beim NSLOOKUP gängt er was an...
Ich vermute da eher eine fehleinstellung im DNS server. Aber da find ich einfach nix was mit dem Problem zusammenhängen könnte.
Bitte warten ..
Mitglied: gemini
03.01.2006 um 22:26 Uhr
Hallo Jan,

die DNS-Suffixe können an verschiedenen Stellen festgelegt werden:
a) in den Eigenschaften von Internetprotokoll (wie von Maurizio beschrieben)
b) in Systemeigenschaften > Computername > Ändern > Weitere
c) mit einer Policy: Comp.konf. > Adm. Vorl. > Netzwerk > DNS-Client

Ich halte in deinem Fall Möglichkeit c) für die Wahrscheinlichste:<blockquote>... Diese Einstellung ermöglicht Ihnen, das primäre DNS-Suffix für eine Gruppe von Computern festzulegen und verhindert, dass es Benutzer, einschließlich Administratoren, ändern.
...
Durch diese Einstellung wird das Dialogfeld "DNS-Suffix und NetBIOS-Computername", das Administratoren zum Ändern des primären DNS-Suffixes eines Computers verwenden, nicht deaktiviert. Falls Administratoren jedoch ein Suffix eingeben, wird dieses ignoriert, wenn diese Einstellung aktiviert ist.</blockquote>
Auszug aus der Erklärung des GPO 'Primäres DNS-Suffix'

HTH
gemini
Bitte warten ..
Mitglied: 14078
04.01.2006 um 02:16 Uhr
ahrg dein B) hatte ich vergessen, da soll er mal gucken !!!
Bitte warten ..
Mitglied: gemini
04.01.2006 um 06:18 Uhr
ahrg dein B) hatte ich vergessen, ...
... genau wie c)
Bitte warten ..
Mitglied: batman00
04.01.2006 um 08:46 Uhr
Also jetzt bin ich verwirrt...
In der GPO steht davon nichts drin. Überall sind die Punkte DNS Suffix nicht konfiguriert. Hab die jetzt mal auf deaktiviert gesetzt, aber nichts...
Jetzt habe ich mal Punkt b versucht...
Das Resultat... Es funktioniert nun mit web.de bild.de usw...
Nur wenn ich jetzt ein nslookup auf einen Server oder sonstiges im Netzwerk kann er es nicht mehr finden... Auch hier hängt er dann den DNS Suffix, den er ja jetzt setzen sollte nicht mehr..
Also ist das wohl auch nicht ganz in Ordnnung.
Meine Frage... warum meint er, dasss wenn ich nslookup web.de, dass web.de der dns nicht korrekt ist und er das dns suffix anhängt?
Bitte warten ..
Mitglied: 14078
04.01.2006 um 08:54 Uhr
poste doch mal den response wenn du dein nslookup command eingibst, vieleicht koennen wir mal dns eintraege vergleichen.
Bitte warten ..
Mitglied: batman00
04.01.2006 um 08:59 Uhr
Ja wie gesagt. Wenn ich ping web.de eingebe, dann pingt er die WEb.de Adresse an und die passt. Und das mit dem Ping geht mit allem.

Mach ich das alles aber mit nslookup, setzt er immer noch ein DNS Suffix was aber auch gar nicht zu meiner Domäne passt. Unsere Domäne heisst FIRMENNAME.FIRMENNAME.COM, er aber setzt nur FIRMENNAME.COM

Aus nslookup web.de macht er dann web.de.FIRMENNAME.COM und somit löst er die IP Adresse unserer Internetseite auf und nicht die von web.de...

Gebe ich dann zum beispiel nslookup SERVER-> das funktioniert mach ich das dann so:
nslookup server.FIRMENNAME.FIRMENNAME.COM -> was so gehen sollte macht er wieder folgendees daraus:

server.FIRMENNAME.FIRMENNAME.COM.FIRMENNAME.COM
Bitte warten ..
Mitglied: gemini
04.01.2006 um 19:33 Uhr
Hallo Jan,

In der GPO steht davon nichts drin.
In welcher? GPOs kann es viele geben, angefangen von der Default Domain Policy.
Hast du alle kontrolliert?

gemini
Bitte warten ..
Mitglied: batman00
05.01.2006 um 08:52 Uhr
Also wir haben genau 4 policies... Zweimal eineDefault für die Domain und die DC's. Da es noch ein Win 2000 Server hat er das nich nicht unter Admin Vorlage Netzwerk DNS, sondern unter Admin Vol., System, DNS. Dort DPrimäres DNS Suffix Nicht Konfiguriert...
Ich hab mir das jetzt mal überlegt. Was passiert denn bei euch, wenn ich jetzt z. Bsp nslookup web.de eingebt? Was kommt da bei euch? und was passiert wenn ihr nslookup SERVER eingebt...
Bitte warten ..
Mitglied: gemini
05.01.2006 um 09:06 Uhr
01.
C:\Dokumente und Einstellungen\<<a>username<a>>>nslookup web.de 
02.
Server:  <<a>dc<a>>.<<a>domäne<a>>.<<a>ext<a>> 
03.
Address:  192.168.1.1 
04.
Nicht autorisierte Antwort: 
05.
Name:    web.de 
06.
Address:  217.72.195.42 
07.
 
08.
C:\Dokumente und Einstellungen\<<a>username<a>>>nslookup <<a>dc<a>> 
09.
Server:  <<a>dc<a>>.<<a>domäne<a>>.<<a>ext<a>> 
10.
Address:  192.168.1.1 
11.
Name:    <<a>dc<a>>.<<a>domäne<a>>.<<a>ext<a>> 
12.
Address:  192.168.1.1
192.168.1.1 ist der DC, leitet weiter auf 194.25.2.129
Das ganz ausgeführt auf einem Clientrechner
Bitte warten ..
Mitglied: batman00
05.01.2006 um 09:25 Uhr
Also bei mir sieht das so aus...

C:\>nslookup web.de
Server: <DC>.<DOMÄNE>.<DOMÄNE>.com
Address: 192.168.110.12

Nicht autorisierte Antwort:
Name: web.de.<DOMÄNE>.com
Address: <IP UNSERER INTERNETSEITE VON DOMÄNE.COM>


C:\>nslookup TERMINALSERVER
Server: <DC>.<DOMÄNE>.<DOMÄNE>.com
Address: 192.168.110.12

Name: <TERMINALSERVER>.<DOMÄNE>.<DOMÄNE>.com
Address: 192.168.110.9

Ich versteh das einfach nicht...
Muss aber dann doch eine lokale einstellung auf dem Rechner sein. Hab mein Notebook dann gestern mit heim genommen, und wa wars gleiche Problem... Aber irgend eine Policie die das Problem einstellt... Ach ich hab kein Plan...
Bitte warten ..
Mitglied: batman00
05.01.2006 um 09:26 Uhr
Na toll jetzt hat der all meine Bemerkungen in >< rausgenommen...
Bitte warten ..
Mitglied: batman00
05.01.2006 um 09:27 Uhr
auf jeden fall setzt er bei web.de noch einen teil des dns namens der domäne dazu. aber auch nur einen teil, also ists auch nicht mal komplett...
Bitte warten ..
Mitglied: gemini
05.01.2006 um 09:57 Uhr
Na toll jetzt hat der all meine Bemerkungen in >< rausgenommen...
Die Inhalte von Spitzklammern werden als HTML-Tags interpretiert.

Workaround
entweder < TextInSpitzklammern > Mind. ein Leerzeichen innerhalb direkt vor/nach einer Spitzklammer, das Leerzeichen ist dann halt sichtbar
oder <<a><<a>a<a>>TextInSpitzklammern<<a>a<a>><a>> Das a dient lediglich als Platzhalter, aussehen tuts dann so <<a>TextInSpitzklammern<a>>
Bitte warten ..
Mitglied: batman00
05.01.2006 um 10:24 Uhr
Na dann auf ein Neues:


C:\>nslookup web.de
Server: < DC >.< DOMÄNE >.< DOMÄNE >.com
Address: 192.168.110.12

Nicht autorisierte Antwort:
Name: web.de.< INTERNETDOMÄNE >.com
Address: < IP UNSERER INTERNETSEITE >


C:\>nslookup < TERMINALSERVER >
Server: < DC >.< DOMÄNE >. <DOMÄNE >.com
Address: 192.168.110.12

Name: < TERMINALSERVER >. <DOMÄNE> . < DOMÄNE > . com
Address: 192.168.110.9
Bitte warten ..
Mitglied: gemini
05.01.2006 um 11:46 Uhr
Hallo Jan,

bin ich jetzt momentan überfragt, Sorry

Einen Strohhalm hab ich noch, das könntest du überprüfen.
Ist aber nur ein Gedanke und nicht verifiziert!!

In den Forwardzonen und deren Unterordnern sind einige Einträge die wie folgt lauten:
(identisch mit übergeordnetem Ordner)
Als Wert ist u.a. der FQDN deines DNS eingetragen.
Diese Werte MÜSSEN mit einem Punkt enden, also <<a>dc<a>>.<<a>domäne<a>>.<<a>ext<a>>.
Über die genaue Bedeutung des Punktes müsste ich erst nachlesen; damit hatte ich noch nie Probleme.
Imho autorisiert er den DNS für diese Domäne und verhindert dass bei Anfragen des DNS die Suffixe angehängt werden.
Ist aber, wie gesagt, mit Vorsicht zu geniesen; wenn ich mich irre geht dein DNS evtl. gar nicht mehr.

Gruß
gemini
Bitte warten ..
Mitglied: batman00
05.01.2006 um 12:18 Uhr
Hm muss ich nachher mal schauen...
Wie sieht es denn aus? So ein DNS komplett neu gestalten, bzw zurücksetzen oder so...
Wie geht denn das bei nem ActiveDirecotyintegrierten DNS.. Kann ja schlecht den DNS von dem Server nehmen und wenn ich den neu aufsetze bekommt der dieINfos von den anderen wiederzugeschoben... Scheint mir aber irgendwie die einzigste lösung...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
Seltsame DNS-Probleme (4)

Frage von Leo-le zum Thema Windows Server ...

DNS
gelöst Eigener DNS-Server im lokalen Netzwerk (11)

Frage von stephan902 zum Thema DNS ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...