Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme beim Einsatz eines zweiten Routers

Frage Netzwerke Router & Routing

Mitglied: Midgard

Midgard (Level 1) - Jetzt verbinden

25.05.2009, aktualisiert 14:09 Uhr, 3547 Aufrufe, 3 Kommentare

Nach der Einbindung eines zweiten Routers in Netzwerk ist der andere Router nach kurzer Zeit nicht mehr erreichbar.

Grundaufbau

Im Netzwerk befindet sich ein 3Com-Gigabit-Switch. An diesem ist zur Zeit ein Rechner und zwei Router angeschlossen. Ein ADSL-Router stammt von CISCO, konfiguriert durch T-Systems und ein ISDN-Router von Funkwerk (Bintec). Der besagte Rechner soll über zwei verschieden Wege (DSL und ISDN) mit verschiedenen Kunden kommunizieren. Dazu wurde ein spezieller CAPI-Treiber installiert um über IP eine ISDN-Verbindung aufzubauen. Ping und Kommunikation zu beiden Routern funktioniert einwandfrei, solange nur einer der beiden Router am Switch hängt. Alle IPs sind fest vergeben und kein DHCP im Netzwerk.

Problemstellung

Werden beide Router gleichzeitig an den Switch gehängt funktioniert die Kommunikation und Ping kurzzeitig. Nach ein paar Minuten (kann auch länger dauern), funktioniert plötzlich der Ping zum ISDN-Router nicht mehr. Der Ping zum DSL-Router weiterhin. Ebenso ist dann keine CAPI-Verbindung mehr möglich. Wird nur der ISDN-Router angeschlossen funktioniert es nach Tagen immer noch.

Lösungsversuche

Auch ein hintereinanderschalten der Router bringt keine Besserung, also Rechner wird verbunden mit ISDN-Router und dieser mit dem DSL-Router sodass die Kommunikation nur durch den Switch vom ISDN-Router möglich ist. Hier tritt aber das selbe Phänomen auf und nur der DSL-Router lässt sich nach einiger Zeit noch ansprechen.
Als Übergangslösung wird aktuell immer nur einer der beiden Router ans Netz gehängt. Dies ist aber nicht dauerhaft so möglich.

Vielleicht kann mir jemand weiterhelfen. Mir persönlich ist schleierhaft, was hier schief läuft.

Vielen Dank im Voraus
Midgard
Mitglied: harald21
25.05.2009 um 14:29 Uhr
Hallo,

ein paar mehr Info's wäre echt hilfreich: z. B. die internen IP-Adressen und die Routing-Tables des Cisco- und des Bintec-Routers. Welcher der beiden Router ist auf dem PC als Default Gateway eingetragen (Wahrscheinlich der Cisco-Router). Gibt es auf dem PC evtl. auch noch Routing-Einträge (auf der Kommandozeile mit "route print" überprüfen).

mfg
Harald
Bitte warten ..
Mitglied: aqui
25.05.2009 um 17:47 Uhr
Normalerweise passiert sowas auch nicht. 2 Router können problemlos im Netzwerk koexistieren.

Zumal das Funkwerk Teil gar nicht als Router mehr oder weniger benutzt wird sondern vermutlich nur eine PPP Dialin Verbindung über eine CAPI Schnittstelle emuliert.
Es gehen also nur PPP Pakete über eine IP Encapsulation zum Router und werden dort in eine PPP Session umgewandelt.

Allein diese Konfiguration ist schon unsinnig und birgt einen sinnlosen Overhead.
Man könnte direkt einen PPP Dialin auf dem Funkwerk Router machen und normal IP im Netzwerk routen, was erheblich sauberer wäre.

Durch die von harald21 angemahnten fehlenden Informationen kann man in der Tat nur raten...

Fakt ist das beide Router sich im Netz niemals so behindern das eine Kommunikation nicht möglich ist.
Voraussetzung dafür ist das sämtliche dynamischen Routingprotokolle ABGESCHALTET sind !!
Beim Cisco der T-Com kann man das wohl voraussetzen, ansonsten musst du mal einen Wireshark Sniffer ins Netz hängen um das zu prüfen !!

Der Schuldige ist vermutlich der Server selber der vermutlich ein ICMP redirect Paket an einen der Router schickt und so Paketet auf sich selber redirected.
Das kann man aber nur raten...ist aber der einzige Grund für so ein verhalten sofern sichergestellt ist das keine dynamischen Routingprokolle auf den Routern laufen.

Vermutlich reicht es auch schon im Server selber in den erweiterten Eigenschaften der Windows Firewall unter ICMP den Haken bei Umleitungen zilassen zu entfernen.

Ansonsten hilft nur sniffern, denn es ist vermutlich ein Problem falsch konfigurierter Endgeräte niemals aber der Router selber !
Bitte warten ..
Mitglied: Midgard
26.05.2009 um 14:36 Uhr
Also, schon mal vielen Dank im Voraus. Werde der Sache in den nächsten Tagen nachgehen, sobald ich wieder beim Kunden Vorort bin und gegebenfalls IPs etc. nachliefern. Haben leider zum größten Teil mein Vorgänger, die T-Systems und eine Drittfirma bisher rumgewurschtelt und ich muss erst mal einen Überblick über die Sache bekommen.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
gelöst Crontab mit Shell Probleme (9)

Frage von mschaedler1982 zum Thema Batch & Shell ...

Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...