Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Explorer-Befehl

Frage Entwicklung Batch & Shell

Mitglied: 62436

62436 (Level 1)

08.03.2008 um 12:27 Uhr, 2558 Aufrufe

Hallo liebe 'Administratoren' ;)


Wenn ich mit dem Befehl:

01.
@echo off & setlocal 
02.
Set /p LW=<LW.txt 
03.
explorer %LW% 
04.
exit
das Laufwerk LW aufrufen möchte, klappt dies wunderbar, allerdings, öffnet sich nach einigen Sekunden (>5) Verzögerung* immer ein leeres DOS-Fenster, welches KEINE Funktion hat (m.E.). Wieso kommt dieses immer hervor? Ich habe ja sogar explizit ein EXIT angegeben. Ich bin ratlos. Genau so verhält es sich, wenn ich das virtuelle Volume mit

01.
@echo off 
02.
explorer M:\ 
03.
exit
öffnen möchte... Komisch.

Zum Verständnis: Die Befehle klappen wunderbar, es öffnet sich sowohl Laufwerk LW, als auch das Laufwerk M. Das 'mysteriöse' Fenster erscheint allerdings trotzdem.

Danke schonmal,
Mattes

*Die Verzögerung kommt glaube ich durch mein OS (=Vista) zu Stande, und auch immer NUR, wenn irgendwas "schief" läuft. Zum Beispiel hatte ich öfter ne .cmd-Datei, die TrueCrypt.exe aufrufen sollte, es nicht gefunden hat, aber erst nach ca. 5 - 6 Sekunden eine Warnmeldung raus gab.
Ähnliche Inhalte
Batch & Shell
gelöst Dir tc Befehl unter Windows 10 macht Probleme (14)

Frage von sugram zum Thema Batch & Shell ...

Windows 10
gelöst Fenster Mini- Maximieren per Batch-Befehl (2)

Frage von knitti zum Thema Windows 10 ...

Windows Server
Laufwerk verstecken im Explorer (10)

Frage von chattie zum Thema Windows Server ...

Debian
gelöst Weiterverarbeitung mit grep Befehl (12)

Frage von Bitcon zum Thema Debian ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (19)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...