Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Hyper V 3 auf Windows 2012 R2 Server nach 4 Wochen

Frage Virtualisierung Hyper-V

Mitglied: rbaumann

rbaumann (Level 1) - Jetzt verbinden

17.09.2014, aktualisiert 19:38 Uhr, 2184 Aufrufe, 10 Kommentare

Hallo,

wir haben einen großes Problem mit einem 2012 R2 Server in Verbindung mit Hyper V

Wir haben das System Ende Juli eingerichtet auf einer neuen Hardware (Wortmann Server).

Windows 2012 R2 als DC, darauf einen Hyper V Server und darunter einen Member Server 2012 mit Exchange.
Alles lief soweit problemlos.

Auf dem DC nur eine Netzwerkkarte mit einem Virtuellen Switch für Hyper V.
Auch mehrfache Neustarts mit Windows Updates ging problemlos.

Am letzten Freitag dann wegen Umbau des Servers in einen 19" Schrank runter gefahren und nach Einbau wieder neu gestartet, wobei auch hier ein paar Windows Updates liefen.

Server startete, aber in Hyper V konnte die weitere Maschine nicht gestartet werden, weil Hyper V Dienste nicht liefen.

Nachgeschaut, der Virtuelle Switch in den Netzwerkadaptern fehlte. Im Gerätemanager steht er unter Netzwerkkarten drinnen, allerdings dazu, dass der Treiber fehlerhaft sei.
Ein weiteres neues unbekanntes Gerät ist dazu gekommen, wozu dieses nun gehört weiß ich auch nicht.

Bei den USB Schnittstellen sind auch mehrere fehlerhafte Hyper V Adapter aufgelistet.

In Hyper V gibt es beim Aufruf des Managers für virtuelle Switche eine Fehlermeldung, dass lokalhost nicht bezüglich Virtueller Switche nicht durchsucht werden kann.


Soweit alles versucht Treiber neu zu laden oder zu ersetzen.

Auch Hyper V Rolle mehrfach komplett entfernt und neu installiert. Gleicher Fehler.
Windows Updates deinstallier, keine Abhilfe.

Wir haben auch eine Datensicherung testweise zurückgespielt, aber auch hier ist der Fehler vorhanden.


Wir sind hier so ziemlich ratlos, was passiert ist bzw. wie wir das Problem lösen können.

Vielen Dank für eure Hilfe

Richard
Mitglied: certifiedit.net
17.09.2014 um 09:56 Uhr
Hallo Richard,

das Ding ist komplett falsch konzipiert und installiert. Das gehört komplett anders aufgebaut (Hyper-V ist stand alone, ist stand alone, ist stand alone.)

Grüße,

Christian
Bitte warten ..
Mitglied: rbaumann
17.09.2014 um 10:05 Uhr
Hallo Christian,

das stimmt schon, ist ne Schmalspurlösung. Dennoch die Frage, warum das Problem jetzt nach 1,5 Monaten auftritt und Hyper V und deren Treiber plötzlich nicht mehr läuft.

Wir haben hier zum internen Test mehrere Maschinen genau so unter 2008 und 2012 so laufen, wo das Problem nicht auftritt.

Im Internet habe ich nur darüber gelesen, dass andere auch unter Windows 8.1 und Hyper V nach MS Updates (aus Juni) da Probleme hatten.

Sonst keine Idee?
Bitte warten ..
Mitglied: Pjordorf
17.09.2014 um 10:38 Uhr
Hallo,

Zitat von rbaumann:
Dennoch die Frage, warum das Problem jetzt nach 1,5 Monaten auftritt
Weil dein Blech neue oder andere oder alte neue Hardware meint gefunden zu haben. daher passt dein Blech nicht mehr zur Registry. Netzwerkkarte nicht geändert, aber plötzlich neue oder falsche Treiber? Korrigiere dies, dann sehen wir weiter.

Immer nur auf OK Klicken, kann auch mal Fehler verursachen....

Fehlermeldung " Es geht nicht" ist auch sehr aussage kräftig.

Gruß,
Peter
Bitte warten ..
Mitglied: Dani
17.09.2014, aktualisiert um 15:48 Uhr
Moin,
Dennoch die Frage, warum das Problem jetzt nach 1,5 Monaten auftritt und Hyper V und deren Treiber plötzlich nicht mehr läuft.
Meinst du das ernst? Warum ist DC und Hyper-V-Rolle auf dem selben Host seitens Microsoft nicht supportert:
We don’t recommend that you combine Domain Controller and Hyper-V host on the same physical computer, especially in production environment.
Deutlicher geht es nicht mehr. Daher würde ich erstmal den Standard für solch eine Umgebung herstellen. auf einen weitern phy. Server Windows Server installieren, hochstufen zum DC, Rollen übertragen, Hyper-V DC herunterstufen. Somit hast du eine Grundlage für die Analyse.

Der Wortmann-Server ist für Windows Server 2012R2 Hyper-V soweit zertifiziert oder auch eine Schmalspurlösung? Wurde Hardware getauscht oder erweitert?

Im Internet habe ich nur darüber gelesen, dass andere auch unter Windows 8.1 und Hyper V nach MS Updates (aus Juni) da Probleme hatten.
Ich kann dich beruhigen. Unsere Hyper-V-Umgebung ist auf dme neusten Patchlevelstand und keiner der Hosts macht bisher Probleme.


Gruß,
Dani
Bitte warten ..
Mitglied: rbaumann
17.09.2014 um 11:00 Uhr
Hallo zusammen,

von der Hardware her wurde nichts getauscht oder sonst Updates von Firmware usw. gemacht.

Das System hat auch zur physikalischen Netzwerkkarte keine neuen Treiber geladen oder gefunden. Diese läuft problemlos, auch jetzt noch.

Der virtuelle Switch von Hyper V kann seine Treiber nicht laden, diese können auch nicht ersetzt werden.
Auch nach der Deinstallation der Rolle und Neuinstallation von der Hyper V Rolle laufen diese nicht.

Treiber zu den virtuellen Switchen von Hyper V haben wir schon testweise ersetzt, aber dies brachte kein Erfolg. Der Treiber kann nicht geladen werden.

Ich werde 2012 neu als reinen Hyper V ohne sonstige Rollen installieren und dann den DC und Exchange als virtuelle Maschinen laufen lassen.

Nur trotzdem bleibt ein komisches Gefühl, warum Hyper V plötzlich Probleme hat.
Wortmann spricht nach Rücksprache von einem Problem mit der CPU, die wohl jetzt getauscht wird.

Kann mir dennoch kaum Vorstellen, dass dies die Ursache ist.
Bitte warten ..
Mitglied: Dani
17.09.2014, aktualisiert um 11:06 Uhr
Ich werde 2012 neu als reinen Hyper V ohne sonstige Rollen installieren und dann den DC und Exchange als virtuelle Maschinen laufen lassen.
Auch da gibt es etwas zu beachten. Dies disktuieren wir im Rahmen folgender Frage.

Kann mir dennoch kaum Vorstellen, dass dies die Ursache ist.
Warum hast du die Umgebung überhaupt so installieren bzw. konfigurieren lassen? Was reizt Admins daran nicht supportete Designs auzuprobieren.... ich versteht's nicht.


Gruß,
Dani
Bitte warten ..
Mitglied: rbaumann
17.09.2014 um 11:25 Uhr
Ja das mag ja alles stimmen, auf dem DC kein Hyper V.

Ich habe es selber nicht installieren lassen, dazu fehlt mir persönlich die Kenntnisse.
Ein Techniker bei uns hatte es so aufgesetzt. Ja es war wohl keine gute Idee.

Dennoch versuche ich jetzt herauszubekommen, ob es an der Konstellation DC mit Hyper V liegt oder was nun die Ursache dafür ist, dass die Hyper V Dienste bzw. Treiber defekt bzw. nicht geladen werden können.

Wenn ich was finde, poste ich es.
Bitte warten ..
Mitglied: rbaumann
17.09.2014 um 15:29 Uhr
Sofern sich das doch jemand anschauen möchte, anbei hier ein paar Screenshots.

https://www.dropbox.com/sc/6d531doye0wsiso/AABidKZiEiTqZx6E0K2xlAiia


Das Mainboard und CPU sind getauscht, wie zu erwarten war gab es keine Verbesserung.
Bitte warten ..
Mitglied: Pjordorf
17.09.2014 um 23:41 Uhr
Hallo,

Zitat von rbaumann:
anbei hier ein paar Screenshots.
Und wir sollen uns fremde Werbung und sonst noch was ansehen? Stelle die Bilder hier ins Forum. bearbeite deine Frage, lade dort Bilder hoch und stelle die Links entweder direkt in deiner Frage oder hier als Antwort rein....

Das Mainboard und CPU sind getauscht, wie zu erwarten war gab es keine Verbesserung.
Nach dem tausch hast du jetzt noch weniger Chancen überhaupt raus zu bekommen was denn ursprünglich sich geändert hat. da sich etwas geändert ist ja klar, sonst hätte dein OS ja nicht ...und sei es nur ein sporadischer alter Wackelkontakt... Ihr habt das ganze bewegt.....

Treiber vom Mainboard alle korrekt?
Nötigen Treiber vom Mainboard alle eingespielt?

Gruß,
Peter
Bitte warten ..
Mitglied: rbaumann
24.09.2014 um 09:20 Uhr
Guten Tag,

warum sollte ich Werbung einstellen?

Es ist etwas schade, dass man hier kaum Hilfe zum eigentlichen Problem erhalten hat.
Sicherlich ist die Konfiguration nicht richtig gewesen, hat aber mit dem eigentlichen Problem nichts zu tun, auf dass nicht eingegangen wurde.

Ich habe einen entsprechenden neuen nackten 2012 als Hyper V Maschine installiert und den DC und Exchange jeweils als virtuelle Maschine laufen lassen.

Auch hier trat das Problem dann nach Einspielung der MS Updates auf.
Ja es sind alle Mainboardtreiber installiert, auch stimmt sonst alles in der Konfiguration.

Es war dann zusätzlich auffällig, dass sich beim DC keine Hyper-V Dienste installierten, bzw. die Installation lief durch aber die Hyper V Dienste waren nicht aktiv in der Maschine.

Nach einigen Tests haben wir dann auch einmal über den Host mit der Windows 2012 CD aus der Installation ein Upgrade des Servers durchgeführt.
Danach liefen die Hyper V Switche usw. sofort wieder. Alle unbekannten Treiber im Gerätemanager waren weg bzw. wieder korrekt gestartet.
Auch dann nach dem Einspielen der aktuellen Updates lief wieder alles richtig.

Nach dem Upgrade mit der Windows CD des virtuellen DC liefen dort auch die Hyper V Dienste (Maus, Netzwerkkarte 10 GB usw.).

Testweise haben wir dann auch noch einmal die ursprüngliche Maschine mit DC als Host und virtuellen Exchange eingespielt, dort den DC dann mit der Windows 2012 upgegradet und danach wieder alle Updates eingespielt. System läuft ohne Probleme mit Hyper V usw.


War also auch wie auch schon im Internet gefunden ein Update Problem.

Trotzdem vielen Dank für die Hilfe
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Windows 2012 R2 DNS Server Verwaltungskonsole Ansicht doppelt (3)

Frage von nahdeka zum Thema Windows Server ...

Windows Server
Nic Teaming unter Windows 2012 R2 Hyper-V (2)

Frage von akae11 zum Thema Windows Server ...

Batch & Shell
gelöst Powershell + dhcp auf einem 2012 R2 Server (5)

Frage von pixel0815 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...