Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Integrierter Windows-Authentifizierung bei IIS6

Frage Internet Server

Mitglied: itdienstleister

itdienstleister (Level 1) - Jetzt verbinden

18.07.2008, aktualisiert 19.07.2008, 16737 Aufrufe, 3 Kommentare

Ziel: Intranet mit Identifizierung der User über die Integrierte Windows-Authentifizierung (IIS 6 / IE 6 und IE 7) damit keine Eingabe von Benutzername/Passwort erforderlich ist.

Hallo!

Ich habe folgendes Problem:
Auf einem IIS 6 der auf einem Server in der Domäne läuft, habe ich eine Website "Intranet" angelegt.
Bei dieser ist der Anonyme Zugriff deaktiviert, die Integrierte Windows Authentifizierung ist aktiviert.

Im Internet-Explorer unter Extras / Internet Optionen / Erweitert ist das Hakerl bei "Integrierte Windows Authentifizierung aktivieren" gesetzt.

Auf dem Server funktioniert alles tadellos.
Ich kann die Seite im IE 7 aufmachen, und auch Links aus Outlook Express öffnen, auch wenn noch keine Instanz des IE offen ist.

Auf Rechnern im Netzwerk mit IE 6 habe ich folgende Probleme:
Der direkte Aufruf über den IE 6 (http://192.168.0.2) funktioniert.
Wenn ich einen Link auf die Seite aus einem E-Mail in OE öffne, funktioniert es erst (ohne Benutzerabfrage - sprich über die Integrierte Windows Authentifizierung) wenn bereits vorher irgendeine andere Seite im Internet Explorer offen ist.

Auf einem Rechner mit IE 7 stellt sich das Problem folgendermaßen dar:
Weder der direkte Aufruf im IE noch der Aufruf über einen Link aus einem Mail (OE) funktioniert wenn nicht vorher der Internet Explorer mit irgendeiner anderen Seite offen ist.


Woran kann das liegen???
Ich bin ratlos und habe schon alles möglich durchprobiert.
Sowohl der Webserver als auch die PCs sind Mitglieder in der gleichen Domäne.

Vielen Dank im voraus!

Grüße, FFK
Mitglied: Nailara
19.07.2008 um 10:01 Uhr
Hi,

schau Dir mal ganz genau auf dem Client an, ob die aufgerufene Seite zur Intranetzone gehört, denn nur da funktioniert das mit der integrierten Authentifikation.

Grüße Mathias
Bitte warten ..
Mitglied: itdienstleister
19.07.2008 um 10:38 Uhr
Unglaublich - das war es!
Vielen Dank!


Warum ist das so unglaublich?
Wie oben beschrieben hat es ja auch ohne den Eintrag in der Intranetzone funktioniert - wenn vorher bereits eine andere Seite im Internet Explorer geöffnet war. Nur wenn der Internet Explorer noch nicht geöffnet war, hat es fallweise (vor allem beim Öffnen von Links aus OE) Probleme gegeben.

Außerdem sind in die Zone "Lokales Intranet" standardmäßig "alle Sites die den Proxyserver umgehen" eingeschlossen. Und für 192.168.0.2 wird der Proxy umgangen. Ich mußte die IP trotzdem in die Liste eingeben, erst dann hat es fehlerfrei funktioniert.

Interessanter Bug!? Oder doch ein Feature?

Grüße, FFK
Bitte warten ..
Mitglied: Nailara
19.07.2008 um 12:07 Uhr
Hi,

es ist MS-Software, also Feature .

Grüße Mathias
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst EWS Exchange 2016 Authentifizierungs Probleme

Frage von camelion zum Thema Exchange Server ...

Windows Server
Migration von IIS6 auf IIS 8.5 (1)

Frage von Stefan007 zum Thema Windows Server ...

Windows Server
Portierung IIS6 Virtuelle FTP Verzeichnisse nach IIS8 FTP (1)

Frage von flop zum Thema Windows Server ...

Windows Netzwerk
Domänen Authentifizierung über Internet (11)

Frage von EditorialBagPipe zum Thema Windows Netzwerk ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (56)

Frage von pjrtvly zum Thema Internet ...

Server-Hardware
HP DL380 G7: Booten vom USB via USB 3.1-PCI-e Karte möglich? (24)

Frage von Paderman zum Thema Server-Hardware ...

LAN, WAN, Wireless
gelöst IP Adressen - Modem - Switch - Accesspoint (23)

Frage von teuferl82 zum Thema LAN, WAN, Wireless ...

Windows 7
Bluesreens unternehmensweit (22)

Frage von SYS64738 zum Thema Windows 7 ...