Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit ISS unter SBS 2003 Standard

Frage Microsoft Windows Server

Mitglied: Pageman2

Pageman2 (Level 1) - Jetzt verbinden

22.04.2007, aktualisiert 21:22 Uhr, 6577 Aufrufe, 5 Kommentare

Hallo liebe Profis,

ich bin leider kein Profi und mit meinen Wissen jetzt an folgende Grenze gestossen. Ich habe SBS 2003 Standart installiert und wollte im IIS eine ASP.net 2.0 Seite einrichten die als Website meiner Firma dienen soll.

Jetzt habe ich nur das Problem das entweder das Companyweb funktioniert oder die Website aber nie beides gemeinsam. Mein ISP hat mir die DNS Einträge auf meine IP gesetzt und ich komme auch immer auf die Standartseite des Servers. Jedoch wenn ich die Hostheader angegeben habe (www.domain.at) schreibt er mir immer das die Webanwendung nicht verfügbar ist.

Ausser diesem Problem habe ich auch noch ein zweites und zwar mit den Frontpageservererweiterungen. Ich kann die Website direkt am Server nicht verwalten weil er immer mein Kennwort zurückweist. Setzt ich mich aber auf einen Client und steige via Visual Studio auf die Seite ein nimmt er das Kennwort und läst mich auch in die Frontpageadmin der Seite.

Habt Ihr vielleicht eine Lösung für mich? Habe schon im Internet gesucht und mir auch ein Buch über den Server gekauft jedoch leider ohne Erfolg.

Mit besten Dank

Pageman2
Mitglied: Dani
22.04.2007 um 19:44 Uhr
G' Abend,
also erstmal was grundsätzliches:
ISS - Dabei handelt es sich um die internationale Raumstation die im All ist und sich zur Zeit noch im Aufbau befindet.
IIS - Der IIS ist der Internet Information Server aus dem Hause Microsoft. Wird hauptsächlich bei Serverprodukte mitgeliefert und ist eine kl. / gr. Konkurrenz zu Apache.

So, fertig mit Klugscheißen!
Also lass doch bei deiner Standardwebsite einfach mal den Header weg. Da diese im Normalfall immer vom IIS gewählt wird. "companyweb" jedoch muss seinen Header behalten, da es sonst zur Kollision kommt (auf den Port bezogen).


Gruß
Dani
Bitte warten ..
Mitglied: Pageman2
22.04.2007 um 20:33 Uhr
Hi

und erstmal Dank für deine Antwort. Nur kannst du mir bitte erklären wie das funkt? Companyweb liegt auf der Internen IP (Header sind eingetragen) und die Website auf der öffentlichen IP (Header eingetragen) Ein 2ter DNS Eintrag meines ISP liegt auf der Standartwebsite (Keine Header eingetragen).

Jetzt funkt Website über www.domain.at und die Standardwebsite über den vpn.domain.at Eintrag.
Companyweb aber nicht mit folgender Fehlermeldung:

Die Serveranwendung ist nicht verfügbar

Die Webanwendung aus diesem Webserver ist derzeit nicht verfügbar. Klicken Sie im Webbrowser auf "Aktualisieren", um den Vorgang zu wiederholen.

Administratorhinweis: Eine detaillierte Fehlermeldung zu diesem Anforderungsfehler finden Sie im Systemereignisprotokoll des Webservers. Dort finden Sie auch mögliche Ursachen für diesen Fehler.

Wenn ich dann den IIS neu starte ist es genau umgekehrt also Companyweb und Standardwebsite (vpn.domain.at) funken aber die Website nicht.


Kannst du mir bitte sagen was da falsch läuft?
Bitte warten ..
Mitglied: Dani
22.04.2007 um 20:46 Uhr
*grübel*
Also von wie vielen Websites reden wir nun??

companyweb:
- Header
- Interne IP zugeteilt

Standardwebsite:
- Header (www.domain.at)
- Öffentliche IP zugeteilt

So müsste es dann gehen, auf jeden Fall!


Gruß
Dani
Bitte warten ..
Mitglied: Pageman2
22.04.2007 um 21:00 Uhr
Also es gibt:

Companyweb : -> Lokal 192.168.0.100 -> ASP1.1

Standardwebsite : -> Lokal (http://server) und extern erreichbar (vpn.domain.at) -> ASP 1.1

Firmenwebsite : -> nur extern zu Erreichen über www.domain.at -> ASP 2.0


Hab auch den Fehler schon gefunden. Es ist nicht möglich 2 versch. ASP Versionen im gleichen Anwendungspool laufen zu lassen.

Lösung: Einen Anwendungspool erstellen und der Firmenwebsite diesen zuweisen.

Das wars!!


Hab das jetzt nur hier reingeschrieben in der Hoffnung das es mal einen anderen helfen kann (Auch wenn ich nicht denke das allzuviel so unwissende wie ich hier auf der Seite unterwegs sind *gg*)


Jetzt funkt auch wirklich alles. Sowohl Companyweb mit allen Funktionen und auch die Standardwebsite inkl aller Links (Webarbeitsplatz usw..)


Danke für die Hilfe!!
Bitte warten ..
Mitglied: Dani
22.04.2007 um 21:22 Uhr
Für welche Hilfe?? Das Problem hast du selber gelöst.
Bitte den Thread als "gelöst" markieren. Dazu oben bei der Problembeschreibung auf editieren klicken und den entsprechenden Haken setzen. Danke...


Grüße
Dani
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst SBS 2003 Exchange deaktiviert - E-Mail-Versand untereinander funktioniert nicht (3)

Frage von Wirdnoch zum Thema Exchange Server ...

Windows Server
SBS 2011 Standard virtualisieren (24)

Frage von HeinrichM zum Thema Windows Server ...

Windows Server
öffentlicher kalender bei sbs 2003 exchange (5)

Frage von jensgebken zum Thema Windows Server ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Festplatten, SSD, Raid
PC stellt nach dem Bios ab (18)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

iOS
16 iPads zentrall verwalten (18)

Frage von simonlohr zum Thema iOS ...

Viren und Trojaner
Ransomware .nm4 (15)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

Windows 7
Freeware MSI Tool (13)

Frage von uridium69 zum Thema Windows 7 ...