Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme mit Konfiguration eines Cisco 1941 - Telnet etc.

Frage Netzwerke Router & Routing

Mitglied: ef8619

ef8619 (Level 1) - Jetzt verbinden

26.07.2013, aktualisiert 17:30 Uhr, 4329 Aufrufe, 6 Kommentare

Hallo,

ich habe hier einen nagelneuen Cisco ISR 1941 Router. Die Verbindung über den Mini USB Console Port steht, ich kann das Teil auch über Putty konfigurieren. Zugangsdaten habe ich bereits geändert.

Nun wollte ich den Router im Parallels Windows 8 mithilfe des Cisco Configuration Professional Programmes konfigurieren. Die Vorbereitungen nach dieser Anleitung habe ich auch getroffen (Konfiguration über die Konsole, damit das CCP Zugriff auf den Router hat): http://www.cisco.com/en/US/products/ps9422/products_configuration_examp ...

Allerdings schlägt jedes Mal die Discovery im CCP fehl. Zudem bekomme ich auch keinen Telnet-Zugriff auf den Router mit einem Terminal Programm. Der Ping geht aber durch.

Weiß jemand Rat?
Mitglied: shjiin
26.07.2013 um 18:23 Uhr
Meine Glaskugel ist gerade in der Waschmaschine. Poste doch mal die Ausgabe von "show run".
Bitte warten ..
Mitglied: ef8619
26.07.2013, aktualisiert um 18:33 Uhr
Ok, hier komplett aus Putty herauskopiert (secret habe ich entfernt):




router#show run
Building configuration...

Current configuration : 5185 bytes
!
! Last configuration change at 15:51:57 UTC Fri Jul 26 2013 by admin
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
lease 0 2
!
!
ip domain name yourdomain.com
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-2083690069
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2083690069
revocation-check none
rsakeypair TP-self-signed-2083690069
!
!
crypto pki certificate chain TP-self-signed-2083690069
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32303833 36393030 3639301E 170D3133 30313232 31393338
33395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 30383336
39303036 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100D274 E1A0DE74 34991BDA 2EF2B9A4 BC80511C 09A5ACE8 419DD6C9 7FDB1E36
2ABA600A 43F71021 26808FD3 1C514566 5E2FBA5A 60A90015 1DA5D43E B3406124
2BD20ACD 5E6D3D56 12C2EC89 7560733D 1F1A2B20 BD7B9275 1CEFB5CD CF40C960
71A79316 F6A992FB 7A4D572E 5ED548A9 4F70048F 8F1F394B 04E8067B 2E08F658
7F210203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14C612DF 06D8F371 1DF1AA57 16A569F6 10FCE451 82301D06
03551D0E 04160414 C612DF06 D8F3711D F1AA5716 A569F610 FCE45182 300D0609
2A864886 F70D0101 05050003 8181000F 780A0FD4 D1CB31B8 AE123816 A0D94868
65887115 D99B05BB AF41D8D0 CE2DDA8F CF288948 822CC63A EBC79A5E 793393D8
553CE8FC 53F45CB9 6E7BC6B5 A7777C89 641B4DAC 268C89AA 03290ADC 7594E4B9
5BC61B72 FBB83101 3C06B422 BBD115A9 084BAE46 55E01397 725A64FE 1C752A6C
1684BA28 65D91FE5 E26639D1 DFDB04
quit
license udi pid CISCO1921/K9 sn FGL1704224A
!
!
username admin privilege 15 secret 4 <secret>
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 10.10.10.1 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 192.168.178.80 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
!
!
control-plane
!
!
banner exec ^C
% Password expiration warning.
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

^C
banner login ^C
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE PUBLICLY-KNOWN
CREDENTIALS

Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>
no username cisco


Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL NOT BE ABLE
TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
^C
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
access-class 23 in
privilege level 15
password <password>
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end
Bitte warten ..
Mitglied: Dobby
26.07.2013 um 18:58 Uhr
Hallo,

ich habe hier einen nagelneuen Cisco ISR 1941 Router.
Hast Du mal nach einer neueren Firmware geguckt und sie eventuell drauf "geflasht"?

Ist der Zugang via Console auch freigegeben und erlaubt?

01.
Replace <myuser> and <mypassword> with the username and password you want 
02.
 to use.
Schon gemacht?

Allerdings schlägt jedes Mal die Discovery im CCP fehl.
Mal mit SSH oder Putty versucht?

Zudem bekomme ich auch keinen Telnet-Zugriff auf den Router mit einem Terminal Programm. Der Ping geht aber durch.
Telnet ist doch eine unverschlüsselte Verbindung kann es daran liegen?

Gruß
Dobby
Bitte warten ..
Mitglied: shjiin
26.07.2013, aktualisiert um 20:10 Uhr
Ich glaube, ich habe den Fehler. In der Config steht ja gar kein "enable secret". Du hast dich zwar als Benutzer für line vty 0 4 eingetragen, was SSH, Telnet ermöglicht, wenn es aber kein "enable" PW gibt, schmeißt dich der Router wieder raus.
'Ist es eigentlich gewollt, das "no service password-encryption" und password für die line configs verwendet werden? Denn so kann jeder der ein show run ausführt, die PWs einsehen.
Bitte warten ..
Mitglied: ef8619
27.07.2013 um 12:04 Uhr
ich habe hier einen nagelneuen Cisco ISR 1941 Router.

Sorry, ist ein 1921.

Hast Du mal nach einer neueren Firmware geguckt und sie eventuell drauf "geflasht"?

Nein, noch nicht.

Ist der Zugang via Console auch freigegeben und erlaubt?

Ähm, das kann ich dir nicht sagen (du meinst Telnet/SSH?).

Replace <myuser> and <mypassword> with the username and password you want
to use.

Ja, habe ich gemacht.

Mal mit SSH oder Putty versucht?

Ja, keine Chance. Mithilfe von Putty kann ich nur die serielle Verbindung aufbauen.

Ich glaube, ich habe den Fehler. In der Config steht ja gar kein "enable secret". Du hast dich zwar als Benutzer für line vty 0 4 eingetragen, was SSH, Telnet ermöglicht, wenn es aber kein "enable" PW gibt, schmeißt dich der Router wieder raus.

Ok, habe ich im globalen Config Modus erlaubt mit "enable secret <mein_secret>". Kann mich trotzdem nicht via Telnet mit dem Router verbinden. CCP findet auch nichts.


Ich muss dazu sagen, dass ich die obige Konfiguration nicht erstellt habe. Diese war (bis auf die Telnet und User-Geschichte) bereits so auf dem Router vorhanden.
Bitte warten ..
Mitglied: ef8619
27.07.2013 um 16:55 Uhr
Hallo,

habe es jetzt hinbekommen. Es war die ACL. Diese hat für den Port 23, also Telnet, keine Verbindungen von meiner IP zugelassen (192.168.178.81), siehe

access-list 23 permit 10.10.10.0 0.0.0.7

Gruss
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Konfiguration Cisco ASA5505 (7)

Frage von Yannosch zum Thema Router & Routing ...

Router & Routing
Cisco 6500 telnet out of local ports (1)

Frage von profski15 zum Thema Router & Routing ...

DSL, VDSL
gelöst VPN-Probleme (CISCO AnyConnect) in Zusammenhang mit Router "Vodafone EasyBox" (7)

Frage von donnyS73lb zum Thema DSL, VDSL ...

TK-Netze & Geräte
Konfiguration einen Cisco SPA122 an einer Auerswald COMpact 5000 (4)

Frage von SarekHL zum Thema TK-Netze & Geräte ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (19)

Frage von patz223 zum Thema Windows Userverwaltung ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (15)

Link von Penny.Cilin zum Thema Viren und Trojaner ...