Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme bei Kopie einer Datei mit Batch-Datei

Frage Entwicklung Batch & Shell

Mitglied: kafri84

kafri84 (Level 1) - Jetzt verbinden

30.10.2006, aktualisiert 31.10.2006, 5502 Aufrufe, 10 Kommentare

Größenprobleme bei Datei-Kopie???

Hallo Kollegen,

ich möchte gerne eine Datei von einen Server auf einen anderen kopieren und mir anschließend in einem Log-File ausgeben lassen, ob die Kopie funktioniert hat.

Dafür habe ich mir folgendes ausgedacht:

xcopy \\server1\d$\Backup\backup.bkf \\server2\d$\Daten\USER\ /E /Y /I
if errorlevel 1 goto error
echo Das Kopieren der Datei am %datum% um %uhrzeit% Uhr war erfolgreich!!! >> c:\Berichte\Bericht.log
goto :eof
:error
echo Das Kopieren der Datei am %datum% um %uhrzeit% Uhr war leider nicht erfolgreich!!! >> c:\Berichte\Bericht.log

Nun mein Problem:
die Datei ist ca 6 GB groß, muss aber zur Datensicherung einmal wöchentlich auf einen anderen Server geschoben werden.
Wenn ich die Datei ausführe, dann fängt er zwar scheinbar an zu kopieren, da ich den Datei-Namen schon im Ziel-LW sehen kann.
Aber irgendwie führt er die kopie nicht zu ende bzw. arbeitet mein script nicht weiter ab.

Wenn ich eine kleinere Testdatei nehme und diese kopiere, dann funktioniert alles prima.

Kann es sein, dass es bei der Kopie von Dateien eine Größenbegrenzung gibt?
Oder hab ich vielleicht woanders einen Denkfehler?

Falls mir jemand weiterhelfen kann, wäre ich Ihn/Ihr sehr dankbar!
Mitglied: Escobar
30.10.2006 um 13:01 Uhr
hallo,

wie siehts denn mit manuellem kopieren der datei aus (explorer und maus oder cp quelle ziel)? - also mit der 6gb datei(!).
arbeitest du auf einem win32-sys?

Esco
Bitte warten ..
Mitglied: kafri84
30.10.2006 um 13:32 Uhr
Hi,

klar wäre es möglich, es manuell zu kopieren. Aber ich wollte die Kopie automatisch über einen Taskmanager laufen lassen, damit ich es nicht vergesse....

Ja, arbeite auf einem win32 sys!
Bitte warten ..
Mitglied: onegasee59
30.10.2006 um 13:36 Uhr
Ich hab mir angewöhnt das in " zu setzen

xcopy /k /r /e /i s/ c /h /y /q "\\server1\d$\Backup\backup.bkf" "\\server2\d$\Daten\USER\"

.... am %datum% um %uhrzeit% Uhr ........

steht da wirklich %datum% und %uhrzeit%?
Sollten diese Variable nicht erzeugt worden sein aus anderem Input, dann musst es lauten %date% und %time%!

gruß
onegasse59
Bitte warten ..
Mitglied: kafri84
30.10.2006 um 13:56 Uhr
Ich habs auch schon in "" gehabt. Funktioniert prima. Aber wie schon gesagt, wenn ich eine kleinere Datei kopiere dann läuft alles, so wie es jetzt ist, wunderbar.
Es hängt igrendwie an der Größe der Datei glaub ich....

Ach ja und das mit %datum% und %uhrzeit% kommt, da ich oben noch folgende Zeilen habe:

set datum=%date::=%
set uhrzeit=%time:~0,5%
Bitte warten ..
Mitglied: miniversum
30.10.2006 um 14:50 Uhr
Um nochmal die Frage von escobar aufzugreifen, Funktioniert es den die 6GB Datei manuell zu kopieren oder kommt dort auch ein Fehler?

Welches Dateisystem wird den benutzt? Gibts Timeouts die im Netzwert gelten udn beim kopieren überschritten werden?

miniversum
Bitte warten ..
Mitglied: kafri84
30.10.2006 um 14:58 Uhr
das manuelle kopieren der Datei funktioniert.

Auf dem einen Server ist win2003 Server drauf und auf dem anderen win2k.

timeouts gibts keine...

kafri84
Bitte warten ..
Mitglied: onegasee59
30.10.2006 um 15:35 Uhr
Es hängt igrendwie an der Größe der Datei glaub ich....

Du schreibst zwar es gäbe keine Timouts aber ich könnte mir vorstellen es gibt sie doch im Hintergrund. Eventuell Firewall oder Virenscanner.

Im übrigen kopier ich hier _jeden Tag_ ca. 35GB problemlos als Datensicherung unsererer Datenbanken, zusätzlich zum sowieso nächtlichen Komplett-Backup.

Gruß
onegasse59
Bitte warten ..
Mitglied: miniversum
30.10.2006 um 18:26 Uhr
Also kanns ja nicht an der Datei oder ihrer Größe liegen wenn es manuell geht.
Schonmal mit dem einfachen copy statt xcopy versucht?

miniversum
Bitte warten ..
Mitglied: Biber
30.10.2006 um 19:09 Uhr
Moin kafri,

ich kann da auch nur mitraten, da ich das Problem noch nicht selbst hatte.

Grundsätzlich würden mir beim Rumphantasieren drei denkbare Gründe einfallen, wenn der Prozess tatsächlich (wie Du beschrieben hast) einfach nicht zurück bzw. zu Ende kommt.

a) die Größe der Datei ist das Problem
...also so etwas wie in http://support.microsoft.com/kb/259837/en-us angeblich gefixt wurde.
Bei der Beschreibung könntest Du zumindest überprüfen, ob Xcopy, copy, robocopy alle dasselbe Verhalten aufweisen (weil ja alle über die CopyFile- und CopyFileEx-Kernel-Routinen gehen.
--> wenn ja: was solls. Dann halt statt einer Monster.bkf per Batch 10 kleinere anlegen von diesen und jenen Unterzeichnissen.

b) es liegt an -ich sag mal- "TimeOuts"
b1) Dein Netzwerk ist zu langsam.... irgendwann sagt einer Deiner TCI/IP-Services, dass seit Stunden keiner mehr mit ihm spricht und geht eine Runde schmollen.
So ähnlich wie hier http://dnn.mssbsfaq.de/SBS2000/Server/NiedrigeNetzwerkleistungbeimKopie ... beschrieben für den Explorer.

b2) Wäre ein TimeOut, weil das Script zu lange dauert..... da kommen wir in den undokumentierten Bereich.
Bei Login/Logoff-Skripts gibt es so etwas. Kein Login/logOff-Skript kann/darf ohne Änderung der Gruppenrichtlinien länger als 600sec/10min laufen. Dann wird der Hahn abgedreht.
[gpedit.msc->Computerkonfiguration->Administrative Vorlagen->System->Skripts->maximale Wartezeit für Gruppenlinienskripts]
Nichts weist darauf hin, dass M$ auch für andere Skripts (z.B. über Taskplaner gestartete) derartige "Defaultwerte" irgendwo hinterlegt hat - aber zutrauen würde ich es ihnen.

Kannst Du denn angenommene Ursache a) verifizieren/falsifizieren? Liegt es an xcopy oder an allen [...]copy-Befehlen?
Ist Dein Netzwerk eher flott oder eher träge - wie lange dauert denn das Kopieren der Datei?
Wie lange würde das Skript denn so in Minuten brauchen?
Und steht irgendetwas im Ereignisprotokoll?

Grüße
Biber
Bitte warten ..
Mitglied: kafri84
31.10.2006 um 14:32 Uhr
So..

ich habe die Lösung des Problems gefunden:
Ich habe das Script beim testen immer auf meinem Admin-PC ausgeführt, dass war der Fehler.
Aber wie bin ich drauf gekommen:
Ich habe mir von meinen PC aus, jeweils die LW der Server gemappt und dann die Kopie manuell angestossen. Dort stand, dass er für die 6GB-Datei ca, 250 Minuten benötigt..

Fand die Zeit sehr hoch. Deswegen hab ich mal zu Testzwecken, auf dem einen Server mir das LW des anderen Servers gemappt und auch dort eine Kopie angestossen.
Diese brauchte nur 20 minuten...

Da ich wie schon erwähnt immer das Script nur auf meinen PC ausgeführt habe, hat er dann angefangen zu kopieren. Da ich das Script aber nach ca 90 minuten abgebrochen hatte, konnte er ja keine komplette Datei sichern, da er ja ca 250 minuten benötigt.

Also hab ich das Script jetzt auf einem der beiden Server gestartet und siehe da...nach knapp 20 minuten war alles fertig kopiert und ein Eintrag in der log-Datei war auch da!!


Trotzdem möchte ich mich bei EUCH ALLEN für die zahlreiche UNTERSTÜTZUNG BEDANKEN!!!

Viele Grüße

kafri84
Bitte warten ..
Ähnliche Inhalte
Windows 7
Kopieren was in einer Datei steht (Batch-Datei)
Frage von helmuthelmut2000Windows 71 Kommentar

Hallo, Ich möchte folgendes machen, aber weis nicht genau wie ich das hinbekomme. Ich habe eine Text-Datei wo folgendes ...

Batch & Shell
Batch: Loop zum kopieren von Dateien
gelöst Frage von BiffBaffBatch & Shell1 Kommentar

Hallo zusammen, leider bin ich nicht sehr vertraut mit dem erstellen von Batch dateien daher mag die Frage vielleicht ...

Batch & Shell
Batch Datei Kopieren
gelöst Frage von FragerBatch & Shell17 Kommentare

Hallo Zusammen, ich bekomme es nicht hin ich muss aus einem Ordner (liegt auf einem Server) eine von vielen ...

Batch & Shell
Batch - Kopieren von Dateien in Userhome
gelöst Frage von BellociBatch & Shell2 Kommentare

Hallo liebe Admins, ich würde sehr gerne einige Dateien unterschiedlichster Form (txt, html, wahrscheinlich in der Zukunft wachsend) in ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...