Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Probleme beim Kopieren per Kommandozeile auf Netzlaufwerk

Frage Netzwerke LAN, WAN, Wireless

Mitglied: tobitobsn

tobitobsn (Level 1) - Jetzt verbinden

05.09.2009, aktualisiert 10:29 Uhr, 5553 Aufrufe, 7 Kommentare

Moin,

ich habe ein kleines Problem. Undzwar möchte ich gleich morgens per Script Dateien vom meinem Rechner auf ein NAS kopieren. Dies ist aber noch im Schlafmodus und wird erst durch eine Anfrage "wieder wach". Wenn ich im Explorer auf das Netzlaufwerk klicke, ist es nach ca. 3-4 Sekunden zugreifbar. Wenn ich aber per Kommandozeile kopieren will wenn das Laufwerk noch "schläft", bekomme ich die Meldung Netzlaufwerk nicht gefunden. Egal, ob ich es vorher anpinge oder im Skript per "Dir t:" mir den Verz.inhalt anzeigen lassen will, um es vorher aufzuwecken. Es scheint nur wach zu werden, durch die Klick im Explorer.

Daher meine Frage: Gibt es eine andere Möglichkeit? Und wenn nicht, könnte ich per Skript den Explorer mit Direktreferenz auf das Netzlaufwerk aufrufen, was ja funktioniert. Aber kann ich per Skript danach umgehend das gleiche Explorerfenster auch wieder schliessen?


mfg
Tobias
Mitglied: tobitobsn
05.09.2009 um 11:29 Uhr
Habe gerade ne Anleitung zum PID herausfinden und Prozess abschiessen gefunden. Problem hierbei ist natürlich der Explorer. Es gibt nur einen Prozess und wenn man den abschiesst, verabschiedet sich auch der Desktop...

Jemand evtl. ne idee, wie man es anders realisieren könnte...?
Bitte warten ..
Mitglied: Wilko1985
05.09.2009 um 12:18 Uhr
Kannst du deinem NAS nicht den Schlafmodus verbieten bestimmt oder?

Was für ein NAS hast du denn es sollte da auch was geben um es wie du sagst zu "wecken"...
Bitte warten ..
Mitglied: tobitobsn
05.09.2009 um 12:51 Uhr
Hallo,

natürlich könnte ich den Schlafmodus ausschalten, aber dann läuft das Gerät 24Std., was schlecht für die Platten und die Stromrechnung ist. Daher ist das keine Option. Das NAS ist DLINK DNS323. Man kann es auch über das HTTP Menü aufwecken, aber das ist definitiv nicht automatisierbar.

Ich habe nun versuchsweise die Netzlaufwerke auf nicht persistent gestellt und erstelle sie bei jedem Rechnerstart neu. Das könnte evtl. Änderung bringen. Denn komischerweise funktioniert der Zugriff per Kommandozeile trotz Schlafmodus nach dem ersten händischen Zugriff mit dem Explorer.
Bitte warten ..
Mitglied: Wilko1985
05.09.2009 um 13:06 Uhr
Gibt es die Möglichkeit ähnlich wie bei einigen NAS Wake on LAN?
Bitte warten ..
Mitglied: tobitobsn
05.09.2009 um 14:28 Uhr
Es hat ja einen eingebauten WOL, der bei jedem Zugriff die Platten und das NAS aktiviert. Ich denke, dass es mit dem Netzlaufwerk und Windows zutun hat. Und da ich die Netzlaufwerke nun bei jedem Neustart wieder einrichte, funktioniert es jetzt scheinbar.
Bitte warten ..
Mitglied: Pjordorf
05.09.2009 um 16:39 Uhr
Hallo tobitobsn,

Es hat ja einen eingebauten WOL, der bei jedem Zugriff die Platten und
das NAS aktiviert.
Dein D-Link DNS323 unterstützt die WOL Funktion nicht.
Dein D-Link DNS323 unterstützt das Hibernate für die Festplatten only. (Seite 46 deines DE Handbuchs)

Und da ich die Netzlaufwerke nun bei jedem Neustart wieder
einrichte,
Falls du VISTA verwendest, dann lies mal das PDF von D-Link dazu.
ftp://ftp.dlink.de/dns/dns-323/documentation/DNS-323_howto_de_WindowsV ...
ftp://ftp.dlink.de/dns/dns-323/documentation/DNS-323_howto_de_netzlauf ...
ftp://ftp.dlink.de/dns/dns-323/documentation/DNS-323_howto_de_erstellu ...

Handbuch hier:
ftp://ftp.dlink.de/dns/dns-323/documentation/DNS-323_B1_MANUAL_de_1.4. ...

Peter
Bitte warten ..
Mitglied: tobitobsn
09.09.2009 um 10:20 Uhr
Moin,

stimmt, WOL hat es nicht, aber der Hibernate Modus ist ja so ähnlich und erfüllt die Funktion (Strom sparen, Resourcen schonen), die ja auch WOL erfüllen soll.
Ich benutze Win XPP.
Mit dem neu einrichten bei jeden Neustart bzw. der non persistent Schaltung der Netzlaufwerke klappt es nun mit der Sicherung per Skript aufs Netzlaufwerk.

mfg
tobsn
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
E-Mail Client für Kommandozeile (6)

Frage von Androxin zum Thema Batch & Shell ...

Windows Server
Flexlm aus Kommandozeile als Service starten (3)

Frage von rodgerwilco zum Thema Windows Server ...

Windows Netzwerk
Netzlaufwerk Verbindung bricht ab (5)

Frage von Martin1984 zum Thema Windows Netzwerk ...

Windows Server
Netzlaufwerke verbinden sich nicht (6)

Frage von MyBRis4Shot zum Thema Windows Server ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (13)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...