Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme im Lan mit VPN-Tunnel Zwischen 2 Routern

Frage Netzwerke

Mitglied: Blade-

Blade- (Level 1) - Jetzt verbinden

19.01.2006, aktualisiert 20.01.2006, 8927 Aufrufe, 19 Kommentare

Hallo ich habe ein seltsames Problem

Ich habe 2 Standorte also 2 Lans über ein VPN-Tunnel ( Gateway to Gateway ) verbunden.
die Konfiguration sieht wie volgt aus:

Standort 1: LAN

192.168.20.0
IP Range: 192.168.20.1 - 192.168.20.254
SubnetMask: 255.255.255.0

Router1 - Linksys RV082: 192.168.20.1 ( VPN-Tunnel ) ( Gateway für Server )
Router2 - LevelOne: 192.168.20.2 ( Gateway ins Internet für alle Clients )

Win2003 Server:
IP: 192.168.20.100 ( Statische IP )
SubnetMask: 255.255.255.0
Gateway: 192.168.20.1
DNS: 192.168.20.100

Alle Clients Bekommen die IP Adressen vom Windows 2003 Server (über DHCP)

zb:
Client PC01 ( DHCP Server = 192.168.20.100 )

IP:192.168.20.30
SubnetMask: 255.255.255.0
Gateway: 192.168.20.2
DNS: 192.168.20.100


Standort 2: LAN

Alles gleich ausser das es ein Anderes Subnet ist: 192.168.30.0

fürs Routing Zwischen den 2 Subnetzen die über den VPN-Tunnel verbunden sind benutze ich Statische Routing einträge auf den Routern

ZB:

Standort1
Router2 ( Gateway für die Clients )

Destination: 192.168.30.0 Mask: 255.255.255.0 Gateway: 192.168.20.1

Router1 ( Vpn-Tunnel zu subnet 192.168.30.0 )

Destination: 192.168.30.0 Mask: 255.255.255.0 Gateway: 192.168.20.1 ( Als gateway sich selber da dieser Router ja den Vpn-Tunnel zu Standord2 aufbaut und den Weg ins andere Subnet kennt )


Das Problem das ich habe ist nun volgendes...

Im Lan hab ich mit VPN-Tunnel komische unterbrüche, zb: beim Pingen gehen oft Packete veloren ( ping nach 2 Stunden 16 verloren )
und ohne vpn-tunnel gehen keine verloren ( ping nach 2 stunden 0 verloren )

Manchmal geht das lokale netz auch für einige sekunden ( ca 2-5 sek ) überhaupt nicht.
zb: ich lade eine Datei aus dem Internet herunter von einem der clients und plötzlich geht das Internet nicht mehr und Lan auch nicht.
Am Provider kanns ja nicht liegen da sonst wenigstens der Server im Lan erreichbar sein sollte.

Das passiert aber nur mit VPN tunnel ohne das vpn zum andern subnetz läuft alles normal.
weis jemand voran das liegen könnte ?


<img src='/images/articles/3ef7efa2d45635c2a35e6ed17496ce4f-lan_map2.PNG' align='default' hspace='0' vspace='0' border='0'>
Mitglied: Blade-
20.01.2006 um 08:10 Uhr
find ich toll wie viele Antworten man hier bekommt
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 09:27 Uhr
mom... bin grad am geistigen nachbauen deines netzwerkes - habs erst jetzt gelesen - da seit heut reg.
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 09:32 Uhr
also ich denk das ds problem bei deinen routern liegt!

zuerst mal: warum hast du 2 router?!?!? --> geht doch auch mit einem!

hast du wo eine dreiecksroute eingebaut?

wie hast das ganze verkabelt? also alles am switch?
oder router 1 auf router 2 und dann Modem?!?!

oder wie ?!?
lg
MIKE
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 10:14 Uhr
Die 2 Router damit die clients im Internet nicht mit der gleichen Wan Ip Adresse wie der Server auf dem Web Surfen usw darum die 2 router auch desshalb weil auf dem server noch dienste laufen die auch vom internet her erreibar sein müssen zb: ftp , http, usw..
hab dafür auf dem router1 ( 192.168.20.1 ) die entsprechenden Forwards gemacht zum server ( 192.168.20.100 )

Die Verkabelung siehe Foto !

Vom Internet gehts zuerst aufs Cablemodem das selber komischerweise keins ip hat.
Von dort auf den ersten Switch , dann von diesem switch auf die 2 Wan Ports der Router die dann vom Provider jeweils 1 IP bekommen.

Danach von den 2 Routern ( LAN ports ) gehts zum Zweiten Switch und von dort an alle clients ausser der Server ist am GBIC Gigabit port angeschlossen.

sollte eigentlich alles richtig sein so von der verkabelung
sind alles Cat5 kabel
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 12:47 Uhr
wart noch
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 12:54 Uhr
ok wie wärs damit:

router 2 macht für deine clients den dhcp und dns (wie viele clients hast??)

router 1 macht gateway ins inet für den server .......und ist getrennt von switch 2 ....direkt auf router 1 (oder brauchen die clients zwecks file & print server zugriff auf den server?!?!

du bekommst auch 2 verschiedene ip`s von deinem isp oder?!?
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 13:01 Uhr
Ja switch2 ist vlan fahig
Ja ich bekomme 2 öffentliche ip vom provider

die clients müssen zugriff auf den server haben
der Server ist im moment auch der Dhcp für die clients un gibt den clients als Gateway die ip von router2, bei deiden routern ist der dhcp ausgeschaltet.

im ganzen sind es 12 clients 1 server ( standort1 )
standort2 - sind es weniger - 5 clients und 1 server

...und ja ich habs auch nur mit einem Router probiert nützt aber nichts nur ohne vpn-tunnel gehts ohne probleme.

Ich versteh einfach nicht wieso im Lan einige ping anfragen verloren gehen ist schon seltsam.... soll ich dir heut mal die genaue Routing Tabelle von Router 1 posten ?

aber falls es am Routing liegen sollte wieso hab ich den nur zeitweise ausfälle ? hab ja statisches routing benutzt.

Dann würde es doch entweder überhaupt nicht klappen mit den Pings falls die Route falsch ist. und nicht nur zeitweise einmal ja, dann wieder nicht...

Versteh ich nicht so ganz.... und ausserdem mach ich die Pings ja direkt vom Server zum Router1 da muss er ja gar nicht ins andere Subnetz routen also wieso gehen einige pings verlohren ?? leider hab ich keine möglichkeit zu prüfen ob es irgendwo colisionen oder sowas gibt.
Aus den Logs der Router sieht man auch nichts was diese probleme betreffen könnte.
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 13:06 Uhr
es wird auf jeden fall einfacher und sicherer wennst die web dienste auf nen seperaten server legts und zur not einen 2 ten server zu den clients hängst wenns gar nicht anders geht....

kannst ja auch mit dem router2 ne vpn machen für deine clients.....

ich würd dir raten auf jeden fall von dieser "all in one" lösung wegzukommen
lg
mike
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 13:13 Uhr
hmmm.... noch ein gedanke für "deine config":

was ist wenn router2 die vpn macht und du wirklich nur router 1 für den server verwendest?!?!

sollt doch auch funzen - und lass das mit dem statischen routen, du hast bei deinem router sicher so ne funktion wie "anwahl auslösendes packet"! soll heisen der router baut die vpn automatisch auf wenn jemand (server, client) eine anfrage in dein 192.168.30.0 netz sendet und nach einer gewissen leerlaufzeit baut er di verbindung wieder ab.....
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 13:18 Uhr
packete (pings) gehen vorloren weil meiner meinung nach es nicht ideal ist wenn du vom client den request ausführst - du per GW auf Router 2 der per static route nach router 1 (wo er dann die möglichkeit hat a. über die wan b. über die lan(wobei er die lan bevorzugen wird) und dann noch per VPN ins 30er netz .........

würd mich auch nicht auskennen wenn ich so ein packet wär!


machs nicht unnötigerweise kompliziert!!
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 13:20 Uhr
Dann würde es doch entweder
überhaupt nicht klappen mit den Pings
falls die Route falsch ist. und nicht nur
zeitweise einmal ja, dann wieder nicht...

Versteh ich nicht so ganz.... und ausserdem
mach ich die Pings ja direkt vom Server zum
Router1 da muss er ja gar nicht ins andere
Subnetz routen also wieso gehen einige pings
verlohren ?? leider hab ich keine
möglichkeit zu prüfen ob es
irgendwo colisionen oder sowas gibt.
Aus den Logs der Router sieht man auch
nichts was diese probleme betreffen
könnte.

aka: dreiecksroute
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 13:33 Uhr
na wie sollte mein netz den sein um die 2 standorte per vpn zu verbinden und das alle clients auf den server zugriff haben und auch ins andere subnetz können. nehme eure vorschläge gerne an
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 13:38 Uhr
ok hier mal lösung 1 die zu 95% funktionieren wird:

http://www.in-takt.at/mod1.png

und loösung 2 die wieder probleme verursachen kann:

http://www.in-takt.at/mod2.png

lg
Mike
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 14:11 Uhr
Und wie wärs hiermit ?

<img src='/images/articles/65b3e72b0f4e00747a707b07ade31be6-lan_map3.PNG' align='default' hspace='0' vspace='0' border='0'>
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 14:27 Uhr
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 14:29 Uhr
packete (pings) gehen vorloren weil meiner
meinung nach es nicht ideal ist wenn du vom
client den request ausführst - du per
GW auf Router 2 der per static route nach
router 1 (wo er dann die möglichkeit
hat a. über die wan b. über die
lan(wobei er die lan bevorzugen wird) und
dann noch per VPN ins 30er netz .........

würd mich auch nicht auskennen wenn ich
so ein packet wär!


machs nicht unnötigerweise
kompliziert!!


moment mal das der statische routing eintrag auf Router2 ist ja blos wenn ich nach 30.0 pinge würde..

Destination: 192.168.30.0
SubnetMask: 255.255.255.0
Gateway: 192.168.20.1

sollte ja soviel heissen wie....... falls das packet nach 30.0 will .... ( also im header = Destination ....30.0 ) dann Route nach ....20.1 ansonsten sollte es doch normal übers Lan gehn ist ja ne ip im gleichen subnet wenn ich vom einem client den Router1 pinge, in diesem fall gilt der routing eintrag für die ping packete doch gar nicht oder irre ich mich da ?
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 14:39 Uhr
würd ich dir nicht raten - warum willst du die 2 router miteinander verbinden ?!? wenns sie ja eh getrennte aufgaben haben?!?!?


http://de.wikipedia.org/wiki/5-4-3-Regel

das ding is halt das du eine ringstruktur ähnliches netzwerk hast und solltest aber baumtopologie verwenden!

so wie du kann mans schon machen ober das ganze ist dann eine redundante leitung und braucht man um ausfallsicheheit zu gewährleisten und wird nicht so verwendet wie du in deinem netzwerk sonder in der regel zwischen 2 switches, die aber hardwaremäsig dafür ausgestattet sind ....

machs bitte einfach einfacher ... und trenn die router auf der lan einfacher - oder probiers mal halt einfach aus ....
lg
mike
Bitte warten ..
Mitglied: Blade-
20.01.2006 um 14:42 Uhr
Hier mal die Routing Table von Router 1 ( 192.168.20.1 )
Bitte warten ..
Mitglied: Aufmuckn
20.01.2006 um 15:08 Uhr
tu ihm die dritte route raus - 30er über 20.1 auf br0 - lösch das - hat je eh die route für die wan drinnen .... und nenn mir echt mal einen plausiblen grund warum du das so "kompliziert machen willst, is doch voll mieß je verdrehter desto fehleranfälliger !!!

geh jetzt heim sch. wochenende

LG
MIKE
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
Zugriff aus dem LAN auf VPN Tunnel
gelöst Frage von sschultewolterNetzwerkgrundlagen4 Kommentare

Hallo, ich habe gerade ein kleines Problem, dass ich nicht weiß, ob es anders zu lösen ist. Ich habe ...

Netzwerke
VPN-Tunnel zwischen zwei Routern für Backups
Frage von Mean1312Netzwerke14 Kommentare

Hallo zusammen, ich habe mir einen Microserver von HP zugelegt, den ich mit FreeNAS als NAS verwende um u.a. ...

Switche und Hubs
VPN Router (client) VPN Tunnel Bauen
Frage von fundave3Switche und Hubs26 Kommentare

Hallo zusammen, ich habe mir ma wieder ein Projekt ageschafft. Da ich einen Server gemietet habe und nur ungern ...

Router & Routing
W-LAN Router mit VPN
gelöst Frage von MarkowitschRouter & Routing5 Kommentare

Hallo liebe ITler, ich bin auf der suche nach einem vernünftigen W-LAN Router der auch VPN an Bord hat. ...

Neue Wissensbeiträge
Erkennung und -Abwehr

Necur-Botnet soll Erpressungstrojaner Scarab massenhaft verbreiten

Information von BassFishFox vor 6 StundenErkennung und -Abwehr

12,5 Millionen Spam-Mails aus einem Bot-Netz mit 6 Millionen Computern? Eigentlich eine schwache Leistung. Die Erpresser setzen dabei auf ...

Microsoft

Nadeldrucker-Problem unter Windows - Microsoft liefert Updates

Information von BassFishFox vor 7 StundenMicrosoft

Hat ja nicht lange gedauert. Nachdem die November-Updates für Windows 7, 8.1 und 10 zahlreiche Nadeldrucker lahmgelegt hatten, stellt ...

Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 14 StundenLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Heiß diskutierte Inhalte
Windows Server
Kann man im KMS nachschauen , wieviele Clients den Key in Anspruch genommen haben
gelöst Frage von rainergugusWindows Server15 Kommentare

Hallo, wir haben einen KMS Windows 10 Key. Dieser ist ja W7 kompatibel. Aber unser Windows 7 Pool registriert ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux14 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...