Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit MKLINK

Frage Microsoft

Mitglied: loveforgod

loveforgod (Level 1) - Jetzt verbinden

15.11.2008, aktualisiert 16.11.2008, 24197 Aufrufe, 4 Kommentare

Fehlermeldung bei der Erstellung eines Verzeichnislinks

Guten Tag

AUf Grund einer Anleitung hier und vieler diverser Unterlagen im Web wollte ich die Benutzerdaten unter Widows Vista Premium vom LW C: auf D: verschieben.

Mein Vorgehen:
Neuen Benutzer angelegt und mich als dieser angemeldet.
Den Benutzerordner auf D:\Benutzerdaten kopiert und anschliessend eine Konsole mit Admin-Berechtigung gestartet.

Am Prompt folgenden Befehl eingegeben: mklink /J C:\Users\NamedesBenutzers D:\Benutzerdaten\NamedesBenutzers
Habe das gleiche auch mit der Option /D versucht und erhalte jedes Mal die Fehlermeldung:

Eine Datei kann nicht erstellt werden, wenn sie bereits vorhanden ist.

Was mache ich da falsch oder woran kann das liegen?

Ich habe auch nach ausgiebiger Recherche dazu leider nichts gefunden, was mir weitergeholfen hat.

Danke für eure Hinweise.
Gruss Xaver
Mitglied: dog
15.11.2008 um 14:06 Uhr
So wie du es erklärt hast, gibt es momentan zwei User-Ordner:

C:\Users\horst
D:\Benutzerdaten\horst

Damit du einen Junction-Point anlegen kannst musst du natürlich erst C:\Users\horst löschen, dann kannst du einen Junction-Point mit dem gleichen Namen erstellen.

Grüße

Max
Bitte warten ..
Mitglied: loveforgod
16.11.2008 um 12:49 Uhr
HAllo Max

Herzlichen Dank für deine Antwort.

Kurz nach meinem Post habe ich dies trotz meiner totalen Übermüdung selbst kapiert

Aber vielleicht kannst du mir in diesem Zusammenhang mit einer grundsätzlichen Frage weiterhelfen:

Auch nach ausgiebiger Recherche habe ich bis heute keine vernünftige Lösung gefunden, welche es ermöglicht das Defaultkonto unter Vista so einzurichten, dass das Profil neu angelegter Benutzer automatisch auf ein anderes Laufwerk/Ordner abgelegt wird, ohne auf der Systempartition Soft- bzw. Hardlinks zu hinterlassen.

Es gibt da eine ANleitung (http://joshmouch.wordpress.com/2007/04/07/change-user-profile-folder-lo ...), welche aber nicht wirklich funktioniert.
Wenn nach dieser Beschreibung vorgegangen wird und ein (wirklich) neuer Benutzer mit eingeschränkten Berechtigungen angelegt wird, so erfolgt bei einem Neustart mit diesem Benutzer eine Fehlermeldung, welche besagt, dass der Benutzerprofildienst nicht gestartet werden konnte - und Windows fordert zu einer Reperaturinstallation auf.
Vermutlich hat dies entweder mit fehlenden Berechtigungen und/oder (was ich eher vermute) mit nicht vorhandenen Registry-Einträgen zu tun.

Ist dir irgendeine sinnvolle Vorgehensweise (so wie unter XP, wo man einfach ein entsprechendes Profil vorbereitet hat und dieses dann in das Default-Profil kopiert hat) unter Vista bekannt oder gibt es eine Software/Script dafür.

Mit herzlichem Gruss
Xaver
Bitte warten ..
Mitglied: dog
16.11.2008 um 19:18 Uhr
Sorry, dazu kann ich nichts sagen. Ich benutze Vista nicht.

Grüße

Max
Bitte warten ..
Mitglied: loveforgod
16.11.2008 um 20:48 Uhr
Herzlichen Dank Max für deine Hilfe!

Vielleicht hat jemand anders einen Tipp?

Gruss Xaver
Bitte warten ..
Ähnliche Inhalte
Windows Systemdateien
Windows Defender Probleme (mal wieder) lassen sich um keinen Preis beheben (2)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Outlook & Mail
Outlook Probleme nach Juni Updates - KB3203467 ist Schuld

Information von Deepsys zum Thema Outlook & Mail ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Update
MS: Update-Server-Adressen OHNE Wildcards (16)

Frage von mrserious73 zum Thema Windows Update ...

Multimedia & Zubehör
Laptop per HDMI an TV - einer geht, einer nicht (10)

Frage von dreizehneinhalb zum Thema Multimedia & Zubehör ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (10)

Frage von Matsushita zum Thema Microsoft Office ...