Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Probleme im Netzwerk - DNS? Verkabelung?

Mitglied: chefkochbln

chefkochbln (Level 1) - Jetzt verbinden

12.06.2006, aktualisiert 19.06.2006, 5133 Aufrufe, 13 Kommentare

Hallo!

Ob meine Frage hier schon einmal erläutert wurde, glaube ich nicht, und so langsam gehen mir die Ideen aus, wo denn der Fehler liegen könnte. Das Szenario ist folgendes:

Ein mittelgroßes Netzwerk von 12 Rechnern (alle Win2K) ist aufgrund einer räumlichen Trennung unterschiedlich mit Hubs zusammengefasst, die dann wiederum alle in einen Hub gehen. Insgesamt liegen in dem Netzwerk 4 Hubs vor, wobei im letzten Hub quasi alles zusammenläuft und auch der Server mit dranhängt.
Der Win2K-Server ist als ADS mit DNS konfiguriert. Alle Clients wurde eine statische IP-Adresse zugewiesen, die auch in dem DNS richtig eingetragen wurden. Der DNS ist richtig konfiguriert, zumindest gibt es keinen Fehlermeldungen in der Ereignisanzeige.
Eine Internetverbindung wird über einen Router eingerichtet, der an einem Hub angeschlossen ist.

Jetzt stellt sich folgendes Problem:
An den Clients sind folgende Einstellungen im TCP/IP gemacht:

IP-Adresse: ist eingerichtet, bspw. 192.168.0.20
SNM: 255.255.255.0
Gateway: 192.168.0.1 (IP-Adresse des Routers)

bevorzugter DNS-Server: 192.168.0.1 (IP-Adresse Router)
alternativer DNS-Server: 192.168.0.3 (IP-Adresse Server)

Mit dieser Konfiguration ist es den Clients möglich, ins Internet zu kommen und Seiten problemlos aufzurufen. Jedoch dauert die Anmeldung erheblich lang (bis zu 15 Minuten).

Meine erste Vermutung war, dass die TCP/IP-Einstellungen falsch sind und so habe ich die beiden DNS-Server ausgetauscht. Der Effekt war folgender: Anmeldung war problemlos - jedoch war es nicht mehr möglich, ins Internet zu kommen.


Meines Wissens zufolge hat doch die IP-Adresse des Routers nichts in den Einstellungen des DNS-Servers zu suchen, da dieser nur als Gateway fungieren soll, damit die Clients ins Internet kommen.
Der Austausch der beiden DNS-Serveradressen hat jedoch nur zu Folge, dass bei einer Kombination die Anmeldung am Win2K-Server normal ist, aber keine Internetseiten aufgerufen werden können.
--> Es geht entweder die Anmeldung normal und das Internet nicht oder die Anmeldung dauert immens lang, dafür können aber Internetseiten aufgerufen werden.


Woran kann das liegen - hat vielleicht jemand eine Vermutung?

Ach ja: Ein Teil der Clients ist mit dem Hub (an dem auch der Server angeschlossen ist) durch (vermutlich) Cable-Sharing verbunden - also ein RJ-45-Kabel wurde aufgesplittet, damit weniger Kabel verlegt werden mussten.
Kann dies eine mögliche Fehlerursache sein - oder liegt ein reiner Konfigurationsfehler vor?


Vielen Dank schonmal für eure Hinweise - ich bin mit meinem Latein erst einmal am Ende.
Mitglied: unzhurst
12.06.2006 um 21:05 Uhr
Servus,

sollte relativ einfach machbar sein...
Stell an den Clients wieder den Server als DNS ein.
In den Eigeschaften deines Server im DNS-Manager kannst du "Weiterleitungen"
bzw. "Forwarder" eintragen - hier muss dein Router eingetragen werden.

So können sich die Clients sauber an der Domäne anmelden und DNS-Auflösung
ins Internet tut auch.

Gruß aus dem Badischen
Patrick
Bitte warten ..
Mitglied: chefkochbln
12.06.2006 um 21:12 Uhr
Servus,

sollte relativ einfach machbar sein...
Stell an den Clients wieder den Server als
DNS ein.

Als bevorzugten oder alternativen DNS? Ist wohl erster, hm? ;)

In den Eigeschaften deines Server im
DNS-Manager kannst du
"Weiterleitungen"
bzw. "Forwarder" eintragen - hier
muss dein Router eingetragen werden.


Hmmmmmm.........
ich grübele etwas, weil ich auf Arbeit auch ganz sauber (allerdings über Switches (aber das ist ja eigentlich egal) auch kein Forwarding eingestellt habe - dort läuft komischerweise alles rund.

So können sich die Clients sauber an
der Domäne anmelden und
DNS-Auflösung
ins Internet tut auch.

Gruß aus dem Badischen
Patrick


So oder so, ich werd das mal ausprobieren. Danke aber auf jeden Fall erst einmal!!!

Kannst du vielleicht erklären, wieso man die Weiterleitung im DNS auf den Router eintragen muss? So ganz will mir das nicht in den Kopf....hat es vielleicht damit etwas zu tun, dass man die IP-Adresse eines Routers nicht direkt im DNS eintragen kann?
Bitte warten ..
Mitglied: unzhurst
12.06.2006 um 21:15 Uhr
was heisst "auf arbeit"?
Ist dass dein Heimnetzwerk mit den 12 PCs ??

Bitte warten ..
Mitglied: chefkochbln
12.06.2006 um 21:18 Uhr
Ja das ist quasi meine zweite Arbeit, in der ich das "komische" Netz habe. Das doofe daran ist, dass da mehrere Leute mit unterschiedlichen und teilweise gegensätzlichen Einstellungen daran rumstellen etc.
So weiß der eine nicht, was der andere tut und ich bin i.d.R. derjenige, der's ausbaden muss. Naja, wie auch immer...

Hatte noch eine kleine Ergänzung geschrieben: Könntest du vielleicht kurz erklären, wieso ich das so im DNS auf den Router weiterleiten muss, bzw. wieso eine Weiterleitung auf den Router erfolgen muss? - Das will mir nämlich nicht so ganz in den Kopf - kann es vielleicht damit etwas zu tun haben, dass man die IP eines Routers nicht direkt im DNS eintragen kann und quasi dann der gesamte DNS auf den Router weitergeleitet werden muss?

Vielen Dank erst einmal!!
Bitte warten ..
Mitglied: unzhurst
12.06.2006 um 21:24 Uhr
die Weiterleitung musst du machen damit an irgendeiner Stelle DNS ins Internet aufgelöst werden kann. An den Clients gehts nicht, weil die in Verbindung mit Active Directory zwingend den internen DNS-Server als einzigen brauchen. Sonst hast du eben die Anmeldeprobleme.

Du musst die Weiterleitung in der DNS-Verwaltung auf dem Server eintragen. Die muss aber nicht zwingend auf den Router gemacht werden, du könntest auch einen DNS-Server aus dem Internet verwenden. Aber warum nicht den Router, wenn er das unterstützt?!
Der Router macht nix anderes als die Anfragen die von deinem Server kommen, an die
Server weiterzuleiten die er bei der Interneteinwahl als DNS-Server bekommen hat.

Reicht dir die Info oder ist noch was unklar?

Gruß
Patrick
Bitte warten ..
Mitglied: chefkochbln
12.06.2006 um 21:27 Uhr
Hm, erst einmal nicht - vielen vielen Dank für die schnelle Hilfe - ich denke ich werde das morgen mal ausprobieren und dann sollte das ja klappen - wenn nicht, meld ich mich nochmal, wenn's okay ist.


Danke nochmal!!
Bitte warten ..
Mitglied: unzhurst
12.06.2006 um 21:29 Uhr
ok - wenns klappt 5* ;)

Gruß und schönen Abend
Patrick
Bitte warten ..
Mitglied: Schranzer23
13.06.2006 um 05:20 Uhr
Ich habe bei mir zum Beispiel DNS Adressen vom Provider bekommen (Versatel) diese wurden bei mir am Router eingetragen (zweie an der Zahl).

Vielleicht müssen auch diese DNS Adressen am DNS Server mit eingetragen werden ?

is nur so nen Gedankengang von mir, probieren geht über studieren
Bitte warten ..
Mitglied: FaBMiN
13.06.2006 um 07:20 Uhr
Das bei Dir überhaupt irgendwas irgendwo ankommt ist mir ein Rätsel.Hast Du die CollisionDetection für deine "Hubs" selbst geschrieben? ;)
Spass bei Seite.Mach einen Forward auf deinen Router.Allerdings wirst du bei mehr als 50%Netzwerklast weder Internet noch sonst irgendwas in deinem Netzwerk schicken können....
Bitte warten ..
Mitglied: chefkochbln
13.06.2006 um 11:14 Uhr
Also ich wollte das gerade ausprobieren und habe festgestellt, dass das Einstellen einer Weiterleitung - so wie du es beschrieben hast - nicht möglich ist. Alle Einstellungen sind deaktiviert und es steht dort, dass keine Weiterleitungen möglich sind, da es sich um einen "Stammserver" handelt. - Nur kann ich wenig mit der Info anfangen.

Einer von euch vielleicht?? - Wie kann ich dennoch so eine Weiterleitung einrichten?
Danke schonmal
Bitte warten ..
Mitglied: unzhurst
13.06.2006 um 11:28 Uhr
du hast wahrscheinlich unter deinen Forward-Zonen noch eine Root-Zone,
d.h. eine die mit . beginnt?! Diese musst du rauslöschen damit es funktioniert.

Gruß
Patrick
Bitte warten ..
Mitglied: chefkochbln
19.06.2006 um 10:23 Uhr
Also.....ich poste hier mal die Lösung zu meinem Problem, denn mittlerweile läuft alles so, wie ich es gern hätte

1. Patrick hatte Recht. Im DNS war die Root-Zone eingetragen (.) - Nach dem Löschen dieser Root-Zone ist es möglich, die von ihm angesprochene Weiterleitung im DNS einstellen zu können - diese war nämlich deaktiviert.

2. Wenn die Weiterleitung aktiviert wird, ruhig den Server neu starten zwischendurch mal - schaden kann es i.d.R. nicht ;)

3. Bei den TCP/IP-Einstellungen der Clients habe ich dann den Router als Gateway eingetragen und als bevorzugten DNS-Server den Server. Da dieser die Anmeldeinformationen beinhaltet, die für die Win2K-Anmeldung benötigt, sollte dieser als DNS eingetragen sein, wenn DNS im Zusammenhang mit AD installiert wurde.

4. Des Weiteren muss in den TCP/IP-Netzwerkeinstellungen der Clients unter Erweitert-->Registerkarte "DNS" ganz unten die beiden Einträge "Adressen dieser Verbindung in DNS registrieren" und "DNS-Suffix dieser Verbindung in DNS-Registrierung verwenden" aktiviert werden. Zumindest war es in meinem Fall so.

Nachdem die Einstellungen getätigt worden sind, den Client neu starten lassen. Es kann eine Weile dauern, bis die Einstellungen vom Server übernommen wurden (auch das war in meinem Fall so). - Mittlerweile funktioniert alles jedoch wieder problemlos.


Vielen Dank nochmal für eure hilfreichen Antworten
Bitte warten ..
Mitglied: unzhurst
19.06.2006 um 10:28 Uhr
Danke fürs Feedback!!

Gruß aus dem Badischen
Patrick
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Probleme mit Internetanschluss, DNS, Netzwerk, oder was auch immer

Frage von luklukLAN, WAN, Wireless11 Kommentare

Hallo zusammen, Ich weiß nicht, ob ich hier im richtigen Unterforum bin aber irgendwie passt das Nirgends rein. Ich ...

Windows Netzwerk

DNS-Probleme

Frage von BiGnoobWindows Netzwerk18 Kommentare

Guten Morgen Habe seit längeren DNS Probleme. Angefangen hat es mit dem Tausch meines Speedports gegen eine fritzbox. Was ...

DNS

DNS Probleme?

Frage von kamajDNS4 Kommentare

Hallo zusammen, Ich hab mal in unserem Firrmennetzwerk mit dem Befehl dsquery eine Abfrage gestartet, weil ich wissen wollte ...

Windows Server

DNS Probleme evtl DNS Einstellungen

gelöst Frage von winlinWindows Server2 Kommentare

Habe zwei netzwerkzonen, eine interne und eine externe.in der internen habe ich zwei RWDCs und zwei RODCs. In der ...

Neue Wissensbeiträge
Vmware
VMware Update für den ESXi 5.5 verfügbar
Information von sabines vor 12 StundenVmware

Nach dem ganzen Hickhack um Update mit Microcode Anpassungen und Rückzug, gibt es nun für den ESXi 5.5 ein ...

CPU, RAM, Mainboards

Meltdown und Spectre: Intel zieht Microcode-Updates für Prozessoren zurück

Information von keine-ahnung vor 16 StundenCPU, RAM, Mainboards5 Kommentare

Moin, extrem lutztig. Nur gut, dass ich noch nicht beim Probanden-Bingo mitgemacht habe :-) LG, Thomas

Router & Routing
PfSense als Addon auf QNAP
Information von magicteddy vor 1 TagRouter & Routing7 Kommentare

Moin, für Spielereien eine ganz nette Idee aber ich fürchte das soetwas auch als echte Firewall genutzt wird: In ...

Datenschutz

Teamviewer kommt für IoT-Geräte wie den Raspberry Pi

Information von magicteddy vor 1 TagDatenschutz1 Kommentar

Moin, jetzt werden IoT Geräte endgültig zur Wanze? Anscheinend kann man auf einem Dashboard seine Geräte visualisieren Ich stelle ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Preis für Wartungsvertrag ok?
gelöst Frage von a-za-zNetzwerkmanagement26 Kommentare

Hallo! Mal ne Frage, weil ich mich mit dem akzeptablen Preis für einen Reaktionszeitvertrag nicht auskenne. Meine Firma hat ...

Windows Server
TEMP-Profile
gelöst Frage von Forseti2003Windows Server21 Kommentare

Guten Morgen, wer kennt sie nicht, die lieben Temporären Benutzerprofile, vorallem immer dann, wenn man sie am wenigsten braucht. ...

Multimedia & Zubehör
Welches Tablet für die Verkäufer?
Frage von Hendrik2586Multimedia & Zubehör15 Kommentare

Guten Morgen meine Lieben, vielleicht könnt ihr mir ja helfen. Es geht um unsere Außendienstmitarbeiter /Verkäufer. Sie sollen demnächst ...

Ubuntu
Ubuntu - Routing mit 2 Netzwerkkarten?
Frage von gabrixlUbuntu13 Kommentare

Hei Folgende Situation: Ich habe zwei virtuelle Maschinen: 1 - Server für DHCP, DNS und Routing - Netzwerkkarte 1: ...