Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mit Proftp

Frage Linux Debian

Mitglied: DestE

DestE (Level 1) - Jetzt verbinden

02.11.2012 um 19:00 Uhr, 5335 Aufrufe, 12 Kommentare

Hallo zusammen,

ich musste eben feststellen, das mein FTP-Server nicht mehr läuft.
Wollte diesen mit " /etc/init.d/proftpd restart "
neustarten und dann kam folgende Fehlermeldung:
"-bash: /etc/init.d/proftpd: No such file or directory"

Was ja schon mal wirklich nicht sehr gut klingt.
Nach weiterem suchen habe ich meine config auf dem Server gefunden aber mir scheint es so, also wäre der FTP-Server an sich nicht mehr vorhanden.
Webmin zeigt mir zum Modul ProFTP nichts mehr an.

Ich nutze Plesk und dort finde ich nun auch nichts mehr über einen FTP Server.
Nutze Debian

Könnt ihr mir da helfen?

Vielen Dank schon einmal.

Gruß
Mitglied: Alchimedes
02.11.2012 um 21:50 Uhr
Nabend,

als root den Befehl angegeben?

sonst nen "dpkg --reconfigure proftp" mal starten.

ebenso kannst du natuerlich auch die Logfiles nach errors durchgrepen.


Gruss
Bitte warten ..
Mitglied: DestE
02.11.2012 um 22:08 Uhr
Habe ich versucht.

dpkg: unknown option --reconfigure

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !


Gruss
Bitte warten ..
Mitglied: Alchimedes
02.11.2012, aktualisiert um 22:25 Uhr
Nabend,

sorry... tipp ins Terminal: 'man dpkg-reconfigure' und schau mal wie die Option fuer reconfigure aussieht....


Der Befehl lautet: # dpkg-reconfigure proftp


Gruss
Bitte warten ..
Mitglied: DestE
02.11.2012 um 23:49 Uhr
Guten Abend,

Package `proftp' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: proftp is not installed


Package `proftpd' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: proftpd is not installed


sieht nicht gut aus, was?

Gruß
Bitte warten ..
Mitglied: Hitman4021
03.11.2012 um 00:57 Uhr
Hallo,

sieht so aus als wäre da echt kein Proftpd mehr.

Guck mal unter /etc/proftpd ob zumindest die Config da ist. Die wird normalerweise nicht mit gelöscht.

Wenn ja installier proftpd einfach neu.

Gruß
Bitte warten ..
Mitglied: DestE
03.11.2012 um 01:05 Uhr
Hallo,

ja die Config ist da bzw. ist unter /etc/proftpd.conf .
Es gibt keinen Ordner in etc bzw in init.d für den Server.

Das Problem ist, weil ich ja Plesk nutze wie ich den Server am besten neu installiere.

Gruß
Bitte warten ..
Mitglied: Hitman4021
03.11.2012 um 01:15 Uhr
Hallo,

versuch einfach ein apt-get install proftpd. Vermutlich liest Plesl alles neu ein.
Die Konfig ist ja noch da ubd gleich ;)

Gruß
Bitte warten ..
Mitglied: DestE
03.11.2012, aktualisiert um 01:23 Uhr
Das hatte ich auch schon versucht:
Ergebnis:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'proftpd-basic' instead of 'proftpd'
Suggested packages:
proftpd-doc proftpd-mod-mysql proftpd-mod-pgsql proftpd-mod-ldap
proftpd-mod-odbc proftpd-mod-sqlite
The following NEW packages will be installed:
proftpd-basic
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2404 kB of archives.
After this operation, 3955 kB of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 187468 files and directories currently installed.)
Unpacking proftpd-basic (from .../proftpd-basic_1.3.3a-6squeeze4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze4_amd64.deb (--unpack):
trying to overwrite '/etc/pam.d/proftpd', which is also in package psa-proftpd 1.3.4a-debian6.0.build110120606.19
configured to not write apport reports
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Und wenn ich:

apt-get install psa-proftpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
psa-proftpd is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



Gruß
Bitte warten ..
Mitglied: Hitman4021
03.11.2012, aktualisiert um 01:31 Uhr
Hallo,
versuch mal
01.
apt-get remove proftpd 
02.
apt-get clean 
03.
apt-get update 
04.
apt-get upgrade 
05.
apt-get install proftpd
Gruß
Bitte warten ..
Mitglied: DestE
03.11.2012, aktualisiert um 11:20 Uhr
Wenn ich removen möchte kommt schon der erste Fehler das proftpd nicht installiert sei ;)

Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'proftpd-basic' instead of 'proftpd'
Package proftpd-basic is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

apt-get clean hat keine Fehler gezeigt
aot-get update sah ebenfalls gut aus

apt-get update
Hit http://debian.intergenia.de squeeze Release.gpg
Ign http://debian.intergenia.de/debian/ squeeze/contrib Translation-en
Ign http://debian.intergenia.de/debian/ squeeze/main Translation-en
Ign http://debian.intergenia.de/debian/ squeeze/non-free Translation-en
Hit http://debian.intergenia.de squeeze/updates Release.gpg
Ign http://debian.intergenia.de/debian-security/ squeeze/updates/contrib Translation-en
Ign http://debian.intergenia.de/debian-security/ squeeze/updates/main Translation-en
Ign http://debian.intergenia.de/debian-security/ squeeze/updates/non-free Translation-en
Hit http://debian.intergenia.de squeeze Release
Hit http://debian.intergenia.de squeeze/updates Release
Hit http://debian.intergenia.de squeeze/main Sources
Hit http://debian.intergenia.de squeeze/contrib Sources
Hit http://debian.intergenia.de squeeze/non-free Sources
Hit http://debian.intergenia.de squeeze/main amd64 Packages
Hit http://debian.intergenia.de squeeze/contrib amd64 Packages
Hit http://debian.intergenia.de squeeze/non-free amd64 Packages
Hit http://debian.intergenia.de squeeze/updates/main Sources
Hit http://debian.intergenia.de squeeze/updates/contrib Sources
Hit http://debian.intergenia.de squeeze/updates/non-free Sources
Hit http://debian.intergenia.de squeeze/updates/main amd64 Packages
Hit http://debian.intergenia.de squeeze/updates/contrib amd64 Packages
Hit http://debian.intergenia.de squeeze/updates/non-free amd64 Packages
Reading package lists... Done


apt-get upgrade hat keine alten Module gefunden:

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.


Und beim installieren kommt dieser Fehler:

apt-get install proftpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'proftpd-basic' instead of 'proftpd'
Suggested packages:
proftpd-doc proftpd-mod-mysql proftpd-mod-pgsql proftpd-mod-ldap
proftpd-mod-odbc proftpd-mod-sqlite
The following NEW packages will be installed:
proftpd-basic
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 2404 kB of archives.
After this operation, 3955 kB of additional disk space will be used.
Get:1 http://debian.intergenia.de/debian/ squeeze/main proftpd-basic amd64 1.3.3a-6squeeze4 [2404 kB]
Fetched 2404 kB in 0s (8235 kB/s)
Preconfiguring packages ...
(Reading database ... 187468 files and directories currently installed.)
Unpacking proftpd-basic (from .../proftpd-basic_1.3.3a-6squeeze4_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze4_amd64.deb (--unpack):
trying to overwrite '/etc/pam.d/proftpd', which is also in package psa-proftpd 1.3.4a-debian6.0.build110120606.19
configured to not write apport reports
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/proftpd-basic_1.3.3a-6squeeze4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Gruss
Bitte warten ..
Mitglied: DestE
03.11.2012 um 14:16 Uhr
Habe nun eben noch ein wenig gesucht und habe gesehen das der proftpd Server bei Plesk psa-proftpd heißt.

Dieser ist auch installiert.

psa-proftpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
psa-proftpd is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Aber ich kann nicht sehen wo er ist und wie gesagt die Methoden um einen Neustart des Servers zu machen gehen nun nicht mehr.

Hilft dies vll weiter?

Gruß
Bitte warten ..
Mitglied: 16568
04.11.2012 um 19:40 Uhr
So ungern Du das lesen wirst, aber:

laß einen Fachmann das machen.
Oder spiel ein funktionsfähiges Backup ein.


Lonesome Walker
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows 7
gelöst Sind euch verstärkte Probleme bei Windows 7 Updates aufgefallen? (4)

Frage von RadioHam zum Thema Windows 7 ...

Cloud-Dienste
gelöst OwnCloud 8 Probleme mit Vorschaubildern auf Mobilgeräten (1)

Frage von zeroblue2005 zum Thema Cloud-Dienste ...

Windows 10
gelöst VPN Verbindung Probleme (6)

Frage von Yeter2 zum Thema Windows 10 ...

Windows 10
Windows 10 Start-Probleme - Hilfe (9)

Frage von clragon zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...

Exchange Server
DNS Einstellung - zwei feste IPs für Mailserver (15)

Frage von ivan0s zum Thema Exchange Server ...